Question

WIFI Calling Preferences Being Forced to Cellular Preferred

  • 10 October 2020
  • 66 replies
  • 16918 views

Userlevel 3
Badge

I am experiencing my WIFI Calling Preferences always being forced to “cellular preferred”, as are others.   I live in an area with poor T-mobile mobile data signal and this recent behavior makes my phone unable to make and receive calls and text messages.   I believe the problem only started happening after the next to last T-Mobile software update.  Everything was fine for my first 5 months of ownership.  A Google search shows posts of other users experiencing the same issue, but no options other than a tedious workaround of manually switching the phone to Airplane mode and changing the WIFI calling preferences back to “WIFI preferred”.  I have to do this kind of process each time I enter and leave my home, and sometimes have to reboot my phone as well.   The times I’ve forgotten, I’ve missed package deliveries and went to a doctor appointment when the doctor had left a message that he was out sick.  This appears to be a carrier specific issue as far as I can see.   I even tried replacing my rock solid Netgear R6400 router with an ASUS AX3000 router with no resulting changes.   I’m in a small apartment only 10 feet from the router, with a very strong WIFI signal.  I have two Samsung Galaxy S20 phones (March 2020) which both exhibit the exact same behavior.   I spoke with T-Mobile Tech support which appeared to be clueless about this issue other than to send me two new S20 phones under warranty to my T-Mobile store.   I do not have high confidence in this approach but will try the new phones and report back. 

Does anyone know anything more?   I am not aware of T-Mobile publicly acknowledging this issue.


66 replies

Userlevel 3
Badge

Went to the T-Mobile store on 10/20/20 to get the two “new” phones I was promised.  Only one phone was there and it was a refurb despite my specifically being told it wouldn’t be.  I passed on the refurb.

The district T-Mobile manager was there that day.  He called T-Mobile from the back room where I couldn’t hear and came back with a proposed solution:  disable 5G.   I put my phones back to LTE, disabling 5G.   The WIFI Preferences optimization notifications continued incessantly as before.  Actually I noticed that that the phone was actually bouncing between WIFI Preferred and Cellular Preferred settings, as others have described.   I had been setting it to WIFI Preferred and observing it being flipped to Cellular Preferred.   I did not realize that it would also optimize to WIFI Preferred, although much less often than to Cellular Preferred.

Interestingly, a new software update installed to my phone early in the morning on 10/21/20, which was the second update I received during the month of October.   For the rest of the day my phone continued changing the WIFI Calling Preferences just as it had before and making frequent notifications.   But by the next morning, the behavior abruptly stopped and both of my phones now seem to be working normally for the last six days, despite WIFI Calling being left set to Cellular Preferred and my being in a very weak signal area.   Hmmm.  

So everything seems good now for both phones.   Hopefully, I’m not celebrating too soon.   I might eventually reenable 5G and see what happens.

I’m guessing there may be some kind of learning going on where the phone now might be figuring out where I spend most of my time and connect to WIFI.   I wish there were a technical explanation somewhere about what really goes on “under the hood” with WIFI Calling, what the issues have been, and what fixes or other changes have been implemented over time.

I will post back if problems reoccur.

Userlevel 1

I am not a techie and I do not understand but I am having the EXACT same problem!!! Started a few days ago. If/When I enable Wi-Fi calling, all my phone does is CONSTANTLY ping back and forth between wi-fi and cellular preferred. I’m home all the time and my wi-fi is fine. I have tried turning off/on my phone, turning off/on wi-fi calling, turning off/on wi-fi connection on the phone and NO LUCK to resolve. (Well, other than leaving wi-fi calling off, but that’s not a solution.) I have no idea how to fix it but the constant back & forth makes texting impossible along with other issues. Is there a fix at all that I can understand and do? Why did this start happening when I’ve had no problems before? Please and thank you! 

I have the exact same problem on my samsung s10e android software version 10.  The problem started very recently immediately after an update.  For over a year the phone was working fine.  Now I set my preferred network to Wifi (because there is very poor tmobile coverage at my house) I have excellent wifi signal.  After a few minutes my phone alerts me that it has updated my preference to Cellular.  There is thread from over a year ago reporting the same problem but the thread is marked solved and I don’t know why.  A lot of people started posting on it recently saying they started having the same problem in the last two months.  Does Tmobile think the problem is fixed because it most certainly is not.  

Userlevel 2
Badge +1

Happening on a Galaxy S10 as well.  WiFi preferred will not stay checked.

I find it very interesting that TMobile has not responded to this. I had the same issue with my Samsung A71. I specifically moved to TMobile for the 5G capability which is not worth the letters that make it up. Why be sold into a 5G capable phone (for obvious money) when the service is not consistent. I too disabled 5G and have so far had limited success with the results. It still toggles back and forth but instead of every 10 min, I am down to about 5 times a day...success?!?! maybe. BTW, 5G was 50% speed of my old Samsung S10 on 4G on other carrier.

Userlevel 6
Badge +11

the TMO site is peer to peer with a couple employees keeping things under control in here..if you need an agents assistance you have to go through either FB or Twitter

@fireguy_6364, I do not have a FB or Twitter account to deal with them. I have also tried calling and support was pretty useless. I had to troubleshoot through the internet to figure out to turn 5G off.

 

Userlevel 6
Badge +11

fair enough..just keep in mind that the site here is peer to peer so there wont be any agent assistance like some of the other carriers sites have.

Userlevel 2

I am having the same issue.  Wifi preference is being forced to cell preferred.  I just don’t understand why Tmobile is not taking this issue as a widespread issue.

Userlevel 1

Hey T-Mobile…

You need to fix this!  It is more than frustrating to have the Wifi Calling setting automatically switch to: “Prefer Cellular” when I have purposely set it to prefer Wifi.   Time and time again,  a contact will complain about my connection and sure enough...my setting has switched back to prefer cellular.  The LTE, around my home, isn’t consistent enough to support the prefer cellular option, which is why I select prefer Wifi.  

Userlevel 2

Hey T-Mobile…

You need to fix this!  It is more than frustrating to have the Wifi Calling setting automatically switch to: “Prefer Cellular” when I have purposely set it to prefer Wifi.   Time and time again,  a contact will complain about my connection and sure enough...my setting has switched back to prefer cellular.  The LTE, around my home, isn’t consistent enough to support the prefer cellular option, which is why I select prefer Wifi.  

I echo this frustration.  When this crap happens during the phone conversation, it actually drops the call. 

Userlevel 1

I have been frustrated with this issue for some time. I switched to T-Mobile years ago when they were the first to offer Wi-Fi calling. I needed it for a vacation, as the resort we stayed in had no cellular signal.

It worked fine for many years, always staying Wi-Fi preferred, until a software update caused it to start resetting to Cellular, even as I sit with 3 feet of my router. I switched from T-Mobile CellSpot router (ASUS RT-AC68U) to a pair of ASUS RT-AC86U routers with latest AIMesh firmware. No difference.

I update software every time it is offered, but can’t get Wi-Fi preferred to stay. With the latest November update, Wi-Fi preferred will stay for several days and then seemingly hourly continue to switch to cellular.

I have done the network reset and clear cache partition, but didn’t change a thing.

The last time I reported this to T-Mobile they replaced my SIM card, but didn’t fix it.

T-Mobile suggest S10 customers turn off 5G, but that isn’t an option for my S9.

I tried the Airplane mode with Wi-Fi on and Wi-Fi preferred, and Wi-Fi did stick, but my Windows 10 Phone Companion app wouldn’t connect to the phone. If I am on my computer, I prefer to use the app.

Except for this I am fairly happy with T-Mobile and happy with my S9. I live in Asheville, NC, and mobile service is spotty where I live. I hope the merger of T-Mobile and Sprint will offer better coverage.

As for 5G, if I ever do upgrade to get it, I will wait for the mid-range C-Band to be supported.Sprint already owns a lot of frequencies in the C-Band range that can be used for 5G.

I don’t understand the message.

“wi-fi calling preferences updated to optimize network experience”. If I have it set to Wi-Fi preferred  and am not connected to Wi-Fi, the phone will use cellular. If I connect to Wi-Fi, I want to use Wi-Fi. I set my preference and don’t want T-Mobile to reset it.

My only option may be to switch to Spectrum Mobile using Verizon network. I will have to buy a new phone, but the frustration with this issue may push me to do it.

Same thing happens to my s10 5g, switches back to cellular preferred and causes dropped calls in a WiFi area.  Been going on for about a year.  Called tmobile but the kid on the other end was so stupid he couldn't understand what I was talking about.  After about 5 minutes I jist hung up.

Same promelem for me on the note 20 ultra. I constantly have to switch back to wifi preferred at work because I get no signal. 

Same here, Galaxy s8+. Very annoying, I'm guessing it's deliberate so tmobile can get you to use their network as much as possible. Pisses me off when working from home where my cell signal is basically between zero and two bars. Drops calls all the time. When you select wifi preferred it should mean use wifi whenever you have it goddam it, not act like a smart-ass and keep 'optimizimg' it so that you cannot make or receive phone calls and miss messages. 

Same happens on my note 20 ultra, seems like I have to switch it back to wifi preferred at least once a day while I'm stuck at home this year. Actually making me consider going back to Verizon when I upgrade phones again because I get poor cell service just while inside my house, thus T-Mobile's implementation of this feature makes using a basic phone function a daily fight that is wearing my patience thin.

as of the one UI 3.0 / android 11 update, there is now a solution for this that seems to work 100% of the time via tasker without any further interaction from the user. one profile and one task and it will keep you on wifi preferred...i've had this running for over a week now and it has worked perfectly.

 

https://www.grecobon.com/2021/01/unlocked-galaxy-s20-wifi-calling-issues/

 

tldr - since the android 11 update, there's now a custom system setting that controls this that we can monitor and change via tasker. the custom setting you're looking for is wifi_calling_preferred1. create a tasker profile that will automatically set it back to wifi preferred as soon as it changes to cellular preferred. my tasker profile and action are at the link above, as well as on taskernet (link in the blog post).

@crackers8199 Just tried your fix and it worked! It’s been years since I’ve used Tasker, never thought I’d need it again but here we are :) I see the UI is still as bad as ever...

Userlevel 2
Badge +1

as of the one UI 3.0 / android 11 update, there is now a solution for this that seems to work 100% of the time via tasker without any further interaction from the user. one profile and one task and it will keep you on wifi preferred...i've had this running for over a week now and it has worked perfectly.

 

https://www.grecobon.com/2021/01/unlocked-galaxy-s20-wifi-calling-issues/

 

tldr - since the android 11 update, there's now a custom system setting that controls this that we can monitor and change via tasker. the custom setting you're looking for is wifi_calling_preferred1. create a tasker profile that will automatically set it back to wifi preferred as soon as it changes to cellular preferred. my tasker profile and action are at the link above, as well as on taskernet (link in the blog post).


Nice.  I am bookmarking your site for when the Galaxy S10+ gets the Android 11 update.  My wife will be very happy for this issue to be fixed.

a quick update: in the few weeks i’ve been using this fix, i have since seen the notification come back up again from time to time, but it seems the fix does still hold. you can just disregard the notification (or silence it if you’d rather do that), tasker will still handle making the switch for you.

Userlevel 2
Badge +1

a quick update: in the few weeks i’ve been using this fix, i have since seen the notification come back up again from time to time, but it seems the fix does still hold. you can just disregard the notification (or silence it if you’d rather do that), tasker will still handle making the switch for you.


Yeah, I noticed your message about that.  I figured I would disable the notifications for that if possible or whatever.  Thanks!

Same here (GS9+ from VZW, recent switch)

Thanks for the workaround, but T-Mobile needs to fix this from their side. I understand why they do this - i.e. for E-911, you should ideally always call from a cellular signal if available because then they can triangulate your position in an emergency - but I travel a lot (even with this ridiculous pandemic), and when I’m roaming that would be an extra cost.

The ideal workaround will be for T-Mobile to have any emergency call be forced over cellular regardless of this preference (and fall back to Wifi as a last resort), but all calls normally go over Wifi if that is preferred, and NOT MESS WITH THIS SETTING.

I am experiencing my WIFI Calling Preferences always being forced to “cellular preferred”, as are others.   I live in an area with poor T-mobile mobile data signal and this recent behavior makes my phone unable to make and receive calls and text messages.   I believe the problem only started happening after the next to last T-Mobile software update.  Everything was fine for my first 5 months of ownership.  A Google search shows posts of other users experiencing the same issue, but no options other than a tedious workaround of manually switching the phone to Airplane mode and changing the WIFI calling preferences back to “WIFI preferred”.  I have to do this kind of process each time I enter and leave my home, and sometimes have to reboot my phone as well.   The times I’ve forgotten, I’ve missed package deliveries and went to a doctor appointment when the doctor had left a message that he was out sick.  This appears to be a carrier specific issue as far as I can see.   I even tried replacing my rock solid Netgear R6400 router with an ASUS AX3000 router with no resulting changes.   I’m in a small apartment only 10 feet from the router, with a very strong WIFI signal.  I have two Samsung Galaxy S20 phones (March 2020) which both exhibit the exact same behavior.   I spoke with T-Mobile Tech support which appeared to be clueless about this issue other than to send me two new S20 phones under warranty to my T-Mobile store.   I do not have high confidence in this approach but will try the new phones and report back. 

Does anyone know anything more?   I am not aware of T-Mobile publicly acknowledging this issue.

I am having the same problem and tech support advised I turn off 5G which made things better for a few days, but now the phone is back to switching to "cellular preferred" on its own. This is very frustrating because I constantly drop calls. I live in an area with poor t-mobile coverage so I rely heavily on Wi-Fi calling. I have an unlocked Samsung Galaxy Note 20 ultra 5G with the January update. 

I've been having the same issue for months on my S10 and now also on my newly purchased S21 for a couple of weeks.

I've been having this same issue on an S20 Ultra and an S21. The Tasker workaround doesn't seem to be effective anymore. I have 5G disabled on both phones which seems to improve the situation but it will still "optimize settings" and automatically switch back to "Cellular Preferred".

Like others I have poor service in my home (all carriers, not just TMo). I went with TMo because of wifi calling but now it is partially broken and I frequently miss calls/texts. This is not acceptable.

Reply