Question

WIFI Calling Preferences Being Forced to Cellular Preferred

  • 10 October 2020
  • 81 replies
  • 23368 views

Userlevel 3
Badge

I am experiencing my WIFI Calling Preferences always being forced to “cellular preferred”, as are others.   I live in an area with poor T-mobile mobile data signal and this recent behavior makes my phone unable to make and receive calls and text messages.   I believe the problem only started happening after the next to last T-Mobile software update.  Everything was fine for my first 5 months of ownership.  A Google search shows posts of other users experiencing the same issue, but no options other than a tedious workaround of manually switching the phone to Airplane mode and changing the WIFI calling preferences back to “WIFI preferred”.  I have to do this kind of process each time I enter and leave my home, and sometimes have to reboot my phone as well.   The times I’ve forgotten, I’ve missed package deliveries and went to a doctor appointment when the doctor had left a message that he was out sick.  This appears to be a carrier specific issue as far as I can see.   I even tried replacing my rock solid Netgear R6400 router with an ASUS AX3000 router with no resulting changes.   I’m in a small apartment only 10 feet from the router, with a very strong WIFI signal.  I have two Samsung Galaxy S20 phones (March 2020) which both exhibit the exact same behavior.   I spoke with T-Mobile Tech support which appeared to be clueless about this issue other than to send me two new S20 phones under warranty to my T-Mobile store.   I do not have high confidence in this approach but will try the new phones and report back. 

Does anyone know anything more?   I am not aware of T-Mobile publicly acknowledging this issue.


81 replies

Alas, after several days, my phone spontaneously changed my wifi calling setting back to cellular preferred, so turning off the “intelligent wifi” setting was not a permanent solution after all. I am left to conclude that this “feature” must be baked into the software, and immune from deactivation by the user. Oh well, it was funwhile it lasted.

I have the same problem. I do not have good service at my home so this is a big pain.  I tried the solutions on here and I don't want to pay for an app so the solution I came up with is to put my phone in airplane mode and then enable my wifi. Cellular preferred is no longer an issue. Only down side is I have to remember to take my phone off airplane mode when I leave the house. Oh and my phone is a OnePlus. If that doesn't prove the issue is TMobile, IDK what does

So here’s my problem. I’ve had poor cellular reception for over a decade at my home, so I had T Mobile  send me a 4G LTE cellspot, which works great.  But with my new 5G phone, it refuses to use 4G and keeps trying to use 5G towers, which do not work in my neighborhood. They work very well elsewhere in my city/county, but not at home.  So I’ve tried to use WiFi calling at home, the phone says it’s using it, but it will not connect nor do I get any incoming calls. I have it set to use WiFi and not cellular preferred, it doesn’t matter as it always tries using the cellular network. The phone keeps trying to use the 5G towers which suck.  So my only solution is to turn WiFi calling off and manually change my cell service to 4GLTE while at home (so I’m using the cellspot), and then remember to change it back to 5G when I leave the house.

Setting the preferred cell network at home to Automatic (5G on/ 5G/LTE/3G/2G) won’t work either, it won’t use the full bars LTE instead of the nearly non-existent 5G. 

Alas, after several days, my phone spontaneously changed my wifi calling setting back to cellular preferred, so turning off the “intelligent wifi” setting was not a permanent solution after all. I am left to conclude that this “feature” must be baked into the software, and immune from deactivation by the user. Oh well, it was fun while it lasted.

I'm truly sorry to hear that. I've been researching this problem on a friend's Samsung phone for a long time. (It does not occur on my own Pixel 5.)

 

I really wish somebody somewhere would fix this problem.

Badge

This has been a long ongoing problem.  I have had it happen on many phones including now on my S22 ultra.   From what I’ve found out it is only on Samsung phones and only on T-Mobile. 

Every time it happens I call T-Mobile.  Yes, it is a PITA but if everyone does it maybe they will take notice.

WiFi calling and HD calling rolled out on Sprint before my GS8 replaced my GS3, and it worked flawlessly. Handoff from my killer WiFi to cellular & back no problem, ever. Even in my expanded-wire plaster, wire & lathe walls (1940’s) WiFi calling gave me HD calls all over the house …

… now disabled, a phone means life even more than the ‘maybe I need 911’ of years past. The merge got me my first T-Mobile SIM -- and bad WiFi calling, so I went back to the Sprint network, until I had to go to a new T-Mobile SIM -- WiFi calling was improved … but I’m now in ‘preferences’ v. ‘settings’ land like most every post here. Been to tech support -- forced to the Sprint side. Pushed to buy a phone at every turn, go to iOS, completely migrate to a T-Mobile account … get a Cell Spot.

No reason to expand TMo’s 4G-LTE by giving them free data, free run of my LAN, and free power, for an unregulated, unlicensed, cell tower, which will shut down as soon as power fails. I currently do better with my Ooma VoIP setup.

In my case, TMo 4G LTE is usable 1 meter inside the house, entering from the east (front). The middle is a 4G dead zone. The north window in my office can see 5 bars of ATT 4G LTE and tries to use it - but the power drops to minimum necessary, saving bandwidth, triggering a switch back to WiFi -- after a few rounds of WiFi/AT&T ping-pong -- all cell connectivity is broken, and my number is “unknown” to all callers -- no texts, no voice mail , no calls, in or out -- but I can still browse the web just fine -- I must restart my phone to restore service.

Done the support orbit for two weeks -- same exact story as everyone else.

I suspect that Samsung struck a data deal with TMo, that must use cellular data to satisfy, because if it used WiFi, it would be trivial to snoop and see what’s being forwarded … if this hypothetical is in any way correct, we’ll be very unhappy with such a dark alliance.

So, TMo and AT&T are not playing well together --- but what can you do?

This is a patch - it’s ugly - but it will keep you online and able to use 911 in an emergency, without a restart and a password. Three steps:

  1. settings→connections→WiFi→[three-vertical-dots, upper right]→advanced→switch to cellular→off

Now, go someplace where you do have TMo coverage, or this will glitch.

  1. settings→connections→mobile networks
    1. verify that T-Mobile is the Network Operator
    2. set it manually if you must
    3. Data roaming→off

Final Step

  1. settings→connections→data usage→mobile data→ off

With those 3 settings in place, my GS8 now pesters me relentlessly with a system dialog asking for permission to search for a better data connection -- why my WiFi isn’t ‘supremely endowed enough’ for their liking is impossible to fathom without considering hypothetical situations such as those expressed as my personal opinion above.

I’ll happily ignore and cancel a fast system dialog that self cancels as you type a text or e-mail. Far less painful than 6 reboots on a Sunday afternoon. It keeps me from getting kicked to the curb by AT&T, which clearly does not approve of playing ping-pong - it’s a waste of cellular setup resources - the most expensive connection in the game - no wonder they kicked my T-Mobile data-roaming to the curb.

Side note, the phone won’t scan for other Cellular Data networks if it’s connected to one, so this happens only in fringe cases and ‘sturdy’ construction -- and no, 28GHz and 39GHz 5G won’t do any better - it will do far worse - you’d need 100GHz to walk through the mesh in my walls, unscathed.

I’m unhappy, have been disrespected, and unacknowledged.

I’m patched well enough for now -- but it’s not a solution. As far as I’m concerned, I’ll let the US DOJ have an image of my phone’s firmware …

 

 

Reply