Alternative router for Home Internet Service (need bridgemode)

  • 26 November 2020
  • 31 replies

Userlevel 3

I recently added T-Mobile’s Home Internet Service to my account. Being in a rural area at the end of a copper loop my DSL speeds are usually around 3MB, so jumped on this as soon as I saw it was available. The speeds are GREAT so far, averaging around 25mb/20mb and I’ve seen 50mb a few times!

However, my needs require putting the modem into bridge mode so my router/home network is getting the public IP.  Disappointed there’s no bridge mode with this device? T-Mobile, please upgrade the firmware to allow this! In the meantime I’m looking at the Netgear LB1120-100NAS 4G LTE Modem. Is anyone using this and know if this will work with this service? This device also supports an external antenna so I use an outside mounted antenna/repeater to get a better signal. 

Anyone trying this (or if T-Mobile can respond) whether this will work I’d appreciate it.


Thank you

31 replies

I’d love to use our Netgear LB1121. I already have two directionals outside pointed at the local tower.

Unfortunately, the new T-Mobile Internet Router doesn’t have ports for the directionals, so I can’t actually direct the signal to improve speeds. Also, this router is severely locked down. We run a pfSense (soon to be tnsr) router for our network. We have to double-NAT this, and getting pfSense to cooperate is.. interesting.

Anyway, I would love to be able to have a BRIDGE mode so it acts accordingly (LTE<->Ethernet) instead of a router. That, or allow us to utilize our own equipment and either unlock the SIM card within the unit, or allow us to get a SIM card for our equipment for this purpose.

Currently, we have a CenturyLink 20/2 (bonded ADSL2+) connection as our primary and this as our secondary.

A recent subscriber to TM Home Internet, I read this thread to learn about how one might connect an alternative router to the Nokia unit provided by TM. Not an engineer, I am fairly certain I got a little dumber after all of this. 

I have an Asus RT-AC88U that I want to use vs. TM because of its superior range, so I wanted to connect it to the TM/Nokia tower as a “dumb” wifi antenna. I connected the two units, factory reset the Asus and updated the firmware to be safe. I then connected devices, which in my case are few: a MacBook, a Windows laptop, a phone, some Wyze smart bulbs and Google Chromecast v2.

At first, the computers and phone connected easily to the Asus wifi network but Chromecast kept giving me an error message that it could not connect to an unsecure network (my Asus is password protected using WPA). Then I restarted a couple of times and it completed. I have yet to set up the Wyze bulbs.

My question relevant to this thread: is there something else I need to do to my Asus to continue using it with the TM router as a “dumb” antenna? Please understand I am not an engineer nor familiar with complex networking.

One thing I will add in closing: When I originally got the TM/Nokia device and used it alone as a router, my streaming services were poorly received. YouTube and YT TV would freeze to a black screen after a minute, Netflix would get stuck when I opened it, but Plex worked. Now I have no issues with any of these, thankfully, and my speed (same with and without Asus, I believe) gets as high as 60Mbps, up to 10x my former service (I live in the boonies).

I’ve had the Nokia 5G WIFI gateway for several weeks now.  I use Alexa, Google Home products, Roku, Ring, and several other smart items.  I have several Synology NAS’s and a Synology mesh setup (RT2600ac and MT2200ac) for my residence.  I backup my NAS’s to Amazon Glacier.  I was worried that a double NAT (don’t want to disable security features provided by the RT2600ac) would disable something.  To my surprise, everything still worked without a single hiccup.  I turned on the RT2600ac’s VPN service (which I used in the past, but not lately) and it didn’t work, so turned it back off.  Was still able to remote access the router and NAS’s via QuickConnect.  Amazon Glacier backup worked as before.

Since I already have a WIFI network running, I didn’t want the gateways WIFI, so turned off all the Enable SSID and Enable Broadcast for all SSIDs.  Also changed Transmission Power to 12%, just for good measure.  This seemed to turn off the gateways WIFI since I couldn’t detect them any longer on my phone, when near the gateway.

After 4 or 5 days the 5G connection dropped and my data dropped to under 20Mbps.  I gave it a few hours and it didn’t reconnect until I turned off the gateway, waited 10 sec, and turned it back on.  I was surprised the firmware didn’t try to reconnect. 

I reboot my router nightly to keep it running at it’s best.  I looked into doing this with the gateway, but it has a battery.  I found it’s easy to remove the battery, so removed the battery and connected the gateway to a digital outlet (smart plugs won’t work when internet is not present) and set it to turn off gateway for one minute each night.

It’s been over a week and gateway operation has been great (no more dropping 5G connection).  I’m getting 80Mbps to 260Mbps, averaging about 120Mbps, and that’s with 2 bars (-100 to -104 dBm).

Would like bridge mode so can use the router’s VPN, if I wanted, and to reduce load on router with double NAT resolving.

I know I am late to this thread but if you log into the gateway via a web browser and turn off both wifi radio’s the public IP gets passed along to the lan port. Let us know if this works for anyone.

I know I am late to this thread but if you log into the gateway via a web browser and turn off both wifi radio’s the public IP gets passed along to the lan port. Let us know if this works for anyone.

It does not. Just tried everything I can think of. Any router behind Nokia modem shows a private ip 192.168.12.***. I even tried setting the public ip as static in new router guessing the settings of public IP: and DNS No internet connection doing that. GOing to have to return as need to have port forwarding/dhcp reservations in business envirmonment.

I also noticed placing a router behind the nokia with dhcp server on then windows only shows it as public network and not private. Couldnt figure out how to change that.

I have a home office system with servers, routers and two WAN using T-Mobile and Comcast. I do my own DHCP, WI-FI, and DNS. I DO NOT NEED THESE FEATURES. Just give me a Modem and an IP address, that is all I need and want. I need to turn all this useless features off and bridge directly to my Cisco router.