Continued troubles with Inseego M2000 hotspot

  • 7 February 2021
  • 8 replies
  • 697 views

Badge

So I have the Inseego M2000 hotspot with the 100 GB plan for use on a rural property. Fortunately it connects to a 5G tower here and generally speaking when it works I get good transfer speeds (30-50 Mbps down and 3-10 Mbps up).

There is some sort of insidious problem with this device that I can’t pin down though. Most of my devices work just fine - iPhones, Apple TV, Ring floodlight camera, Macbook, etc. However, there are a few consumer devices that simply will not set up on this network - as if something on this device is blocking or resetting the connection. Namely, I’ve had trouble with Ring stick-up cameras, a Yale/August connect remote lock, and a Sensi wireless thermostat. All exhibit a similar problem which is that they’ll connect to the WiFi just fine but can’t complete setup due to a generic internet connectivity issue.

However, I can get all of these devices to work just fine if i use my iPhone as a hotspot, which is also a T-Mobile-connected device (4G LTE). I’ve tried all manner of configurations but can’t pin down any cause for this intermittent issue preventing certain devices from reaching the Internet.

I wanted to document this here in case anyone else has run into this or does run into it in the future. Still don’t know what the solution is but I’ll keep hacking on it. Any advice is welcome, as well as info from anyone experiencing the same problems.


8 replies

Badge

Additional data point: if I tether my GL iNET router to the hotspot and funnel everything through an OpenVPN connection, then these devices will start to work again. So clearly something at the T-Mobile network level is blocking the traffic for some reason.

Im having kinda the same issue my fire tv connects fine to the hot spot but my windows 10 desktop connects fine sometimes but sometimes will drop eventually and say “no internet connection”.   It also will periodically connect and have “no internet connection” as soon as i connect the desktop to the hotspot.  its very intermittent. i know the hotspot has internet service because the fire tv is connected at the same time and has internet connection continuously and the hotspot show 5G service will full bars.  T-Mobile needs to find a fix please. It’s definitely an issue on their end. My computer is brand new and connects fine to the RV park wifi without dropping connection ever so it not an issue with my computer. 

Badge

I tried the tip at the end of this post:

 

Under Settings > Advanced > Networks - changed the APN to B2B.tmobile.com and the PDP to IPV4

 

This actually allowed my thermostat and smartlock to finally connect to the Internet. I haven’t tried the Ring stick-up cam again because I returned it.

Any fix for this? I have my inseego in a garage and can’t get my ring doorbell or my garage door opener to connect to the internet. Phone and computer work fine. 
 

changing APNs didn’t help. 

Any fix for this? I have my inseego in a garage and can’t get my ring doorbell or my garage door opener to connect to the internet. Phone and computer work fine. 
 

changing APNs didn’t help. 

Ok, after more work I realized that it was my previous attempts that messed things up. I turned off port filtering and port forwarding and did the apn trick above and everything works. I got my ring doorbell and stick cams working.

My m2000 won't load past the T-Mobile logo

dolanp:  I read your post above and sympathize.  I have had an Inseego M200 since December 2021 purchased through T-Mobil.  It got so bad, I wrote to Michael Sievert, CEO of T-Mobil.  Between  powering off intermittently, and not completing setup with my Amazon smart plug, it’s been a real challenge.  I now have a problem where the  device shuts itself off for now reason, even while plugged in and charging.  I am at my witts end.  I am about to write another letter to Sievert.  I did get a response from his office from a Michael someone who told me twice he would send me his direct contact info so I could keep in touch but never did send it.  I am still having power off  problems  but am going to try changing the settings you recommended to see if my Amazon plug will work.  I don’t hold much hope.  I’ll let you know.  Good Luck with the Inseego  M2000.  It’s a real piece of work.

Lou A

 

I have a similar problem with my Ring Cam & Amazon TV Fire Stick, it will not even see the wifi network but it does see and work fine with the guest wifi…  So if you have not tried to use the guest network try that as it works great for me without any other setting changes.

NOW if I can figure out why it turns itself off after about 3 days I’ll be set.  Very annoying.  I have it on a boat where I can monitor & control systems remotely from an app, but annoying when it shuts down and I lose contact.  If anyone finds a setting or fix for the auto-shutdown please let me know!

Reply