Continued troubles with Inseego M2000 hotspot

  • 7 February 2021
  • 28 replies
  • 2814 views

Userlevel 1
Badge

So I have the Inseego M2000 hotspot with the 100 GB plan for use on a rural property. Fortunately it connects to a 5G tower here and generally speaking when it works I get good transfer speeds (30-50 Mbps down and 3-10 Mbps up).

There is some sort of insidious problem with this device that I can’t pin down though. Most of my devices work just fine - iPhones, Apple TV, Ring floodlight camera, Macbook, etc. However, there are a few consumer devices that simply will not set up on this network - as if something on this device is blocking or resetting the connection. Namely, I’ve had trouble with Ring stick-up cameras, a Yale/August connect remote lock, and a Sensi wireless thermostat. All exhibit a similar problem which is that they’ll connect to the WiFi just fine but can’t complete setup due to a generic internet connectivity issue.

However, I can get all of these devices to work just fine if i use my iPhone as a hotspot, which is also a T-Mobile-connected device (4G LTE). I’ve tried all manner of configurations but can’t pin down any cause for this intermittent issue preventing certain devices from reaching the Internet.

I wanted to document this here in case anyone else has run into this or does run into it in the future. Still don’t know what the solution is but I’ll keep hacking on it. Any advice is welcome, as well as info from anyone experiencing the same problems.


28 replies

Userlevel 1
Badge

Additional data point: if I tether my GL iNET router to the hotspot and funnel everything through an OpenVPN connection, then these devices will start to work again. So clearly something at the T-Mobile network level is blocking the traffic for some reason.

Im having kinda the same issue my fire tv connects fine to the hot spot but my windows 10 desktop connects fine sometimes but sometimes will drop eventually and say “no internet connection”.   It also will periodically connect and have “no internet connection” as soon as i connect the desktop to the hotspot.  its very intermittent. i know the hotspot has internet service because the fire tv is connected at the same time and has internet connection continuously and the hotspot show 5G service will full bars.  T-Mobile needs to find a fix please. It’s definitely an issue on their end. My computer is brand new and connects fine to the RV park wifi without dropping connection ever so it not an issue with my computer. 

Userlevel 1
Badge

I tried the tip at the end of this post:

 

Under Settings > Advanced > Networks - changed the APN to B2B.tmobile.com and the PDP to IPV4

 

This actually allowed my thermostat and smartlock to finally connect to the Internet. I haven’t tried the Ring stick-up cam again because I returned it.

Any fix for this? I have my inseego in a garage and can’t get my ring doorbell or my garage door opener to connect to the internet. Phone and computer work fine. 
 

changing APNs didn’t help. 

Any fix for this? I have my inseego in a garage and can’t get my ring doorbell or my garage door opener to connect to the internet. Phone and computer work fine. 
 

changing APNs didn’t help. 

Ok, after more work I realized that it was my previous attempts that messed things up. I turned off port filtering and port forwarding and did the apn trick above and everything works. I got my ring doorbell and stick cams working.

My m2000 won't load past the T-Mobile logo

dolanp:  I read your post above and sympathize.  I have had an Inseego M200 since December 2021 purchased through T-Mobil.  It got so bad, I wrote to Michael Sievert, CEO of T-Mobil.  Between  powering off intermittently, and not completing setup with my Amazon smart plug, it’s been a real challenge.  I now have a problem where the  device shuts itself off for now reason, even while plugged in and charging.  I am at my witts end.  I am about to write another letter to Sievert.  I did get a response from his office from a Michael someone who told me twice he would send me his direct contact info so I could keep in touch but never did send it.  I am still having power off  problems  but am going to try changing the settings you recommended to see if my Amazon plug will work.  I don’t hold much hope.  I’ll let you know.  Good Luck with the Inseego  M2000.  It’s a real piece of work.

Lou A

 

I have a similar problem with my Ring Cam & Amazon TV Fire Stick, it will not even see the wifi network but it does see and work fine with the guest wifi…  So if you have not tried to use the guest network try that as it works great for me without any other setting changes.

NOW if I can figure out why it turns itself off after about 3 days I’ll be set.  Very annoying.  I have it on a boat where I can monitor & control systems remotely from an app, but annoying when it shuts down and I lose contact.  If anyone finds a setting or fix for the auto-shutdown please let me know!

We use Inseego M2000 specifically to access our business website - but suddenly our web site will not load through this M2000.  But all other websites (Google, YouTube, etc) work just fine! If I switch my laptop to use my iPhone, our website loads just fine.  Sometimes a re-start of the M2000 fixes this.  Yesterday I had to reset the M2000 to factory settings before our website would load.

 

So strange that literally the main website we need to access doesn't work through the M2000.  This is just HTTPS, no VPN or anything!

Badge

I have been researching this problem myself for a week now and have found that the problem lies in only 5G. if you use http://my.mifi , go to advanced settings then switch your inseego M2000 to 4G\LTE, you will find all your troubles end.

For me, discord voice does not connect and various games will not ping or connect properly which is a big deal because 5G gave me latency of 45ms on average while 4G LTE gives me 70ms (and more jitter) on average which is a big deal in latency driven applications. I also live in a rural area which AT&T has a monopoly over on internet access.

Basically I was also convinced it was on Tmobile’s end, but I will be confirming once Inseego emails me back whether or not it was the recent update.

For now, the fix is switching your device to 4G LTE.

my.mifi then settings, then advanced, you will see “Network Technology” with  Auto (LTE/5G) Next to it, click on that tab and then LTE/UMTS.

That should fix all your issues. It will be slightly slower but it wont be a headache.

I have been researching this problem myself for a week now and have found that the problem lies in only 5G. if you use http://my.mifi , go to advanced settings then switch your inseego M2000 to 4G\LTE, you will find all your troubles end.
 

Thanks for the suggestion.  Today I set the Inseego to only use 4G/LTE.  Everything was fine for about 3 hours and then again, we could no longer connect our browsers to our company website.  But all other sites still worked (Google, YouTube, etc).  Same exact problem as before.

 

I restarted the Inseego 3 times and deleted and re-connected the WiFI on my laptop.  Our company website started loading again.  There does not seem to be any logic to when it will stop working or why.

But thanks, Aceprojectx. Appreciate the help.

Badge

I have been researching this problem myself for a week now and have found that the problem lies in only 5G. if you use http://my.mifi , go to advanced settings then switch your inseego M2000 to 4G\LTE, you will find all your troubles end.
 

Thanks for the suggestion.  Today I set the Inseego to only use 4G/LTE.  Everything was fine for about 3 hours and then again, we could no longer connect our browsers to our company website.  But all other sites still worked (Google, YouTube, etc).  Same exact problem as before.

 

I restarted the Inseego 3 times and deleted and re-connected the WiFI on my laptop.  Our company website started loading again.  There does not seem to be any logic to when it will stop working or why.

But thanks, Aceprojectx. Appreciate the help.

Yeah the post-covid world is pretty sad; its not only Tmobile, but many other companies even in other sectors that been having non stop issues.

 Hello, 

I had similar issue where I could not connect to my home L2TP VPN. It worked on my Franklin T9 but not on Inseego. 

I could connect to work’s Cisco VPN but not home. This resolved it:

 

Under Settings > Advanced > Networks - changed the APN to B2B.tmobile.com and the PDP to IPV4

 

 

I tried the tip at the end of this post:

 

Under Settings > Advanced > Networks - changed the APN to B2B.tmobile.com and the PDP to IPV4

 

This actually allowed my thermostat and smartlock to finally connect to the Internet. I haven’t tried the Ring stick-up cam again because I returned it.


 

It worked!  Thanks for your fix.  I can finally enjoy online gaming again. 

Get a VPN for the 5g if u dont wanna lose that sweet  100mb/ps, :yum:

Lucky this one is built for free and open to the public, and what i use, if u use they’re gateway vpn, then all the other services will work 

https://www.vpngate.net/en/download.aspx

I'm so done with this mifi. I'm on my third one. I use to connect my Xbox series s online. Right now it's giving me speeds under 5 Mbps. For some reason it won't download the administration site either so I can try some of these suggestions that are posted. I'm lost, spent countless hours on the phone with tech. I'm paying for a device I can't even use. I need help please!!

Badge

I'm so done with this mifi. I'm on my third one. I use to connect my Xbox series s online. Right now it's giving me speeds under 5 Mbps. For some reason it won't download the administration site either so I can try some of these suggestions that are posted. I'm lost, spent countless hours on the phone with tech. I'm paying for a device I can't even use. I need help please!!



It isn’t the device, it is T-Mobile. They just been blaming Inseego, which arguably could be a defamation lawsuit since it is obvious they are telling everyone it is the device and not them; If you use a VPN, everything works on 5G; evidence that it is the network, not the device.

The 5G towers have yet to be finalized so all is not complete...there will be issues till done is what an agent told me.

Badge

 Hello, 

I had similar issue where I could not connect to my home L2TP VPN. It worked on my Franklin T9 but not on Inseego. 

I could connect to work’s Cisco VPN but not home. This resolved it:

 

Under Settings > Advanced > Networks - changed the APN to B2B.tmobile.com and the PDP to IPV4

 

I tried the tip at the end of this post:

 

Under Settings > Advanced > Networks - changed the APN to B2B.tmobile.com and the PDP to IPV4

 

This actually allowed my thermostat and smartlock to finally connect to the Internet. I haven’t tried the Ring stick-up cam again because I returned it.


 

 

I am getting the same performance out of this as just using 4G on inseego; but they did say it didnt work for them.

Incase this helps someone else, I was able to get my Ring Stickup Cam working by:

  1. Making APN changes (described above)
  2. Switching to LTE mode (also described above)
  3. Setup Ring

After the Ring was setup I was able to re-enable 5g mode and it works fine.  I did have to leave the new APN settings though because it would fail to connect if I tried putting them back.

My APN is greyed out so I can’t change it.  What is the trick?

Badge

Im having kinda the same issue my fire tv connects fine to the hot spot but my windows 10 desktop connects fine sometimes but sometimes will drop eventually and say “no internet connection”.   It also will periodically connect and have “no internet connection” as soon as i connect the desktop to the hotspot.  its very intermittent. i know the hotspot has internet service because the fire tv is connected at the same time and has internet connection continuously and the hotspot show 5G service will full bars.  T-Mobile needs to find a fix please. It’s definitely an issue on their end. My computer is brand new and connects fine to the RV park wifi without dropping connection ever so it not an issue with my computer. 


I am having very similar problems gaming using my Galaxy S21 as a hotspot. My old S7 never had this problem. It does look like a T Mobile 5G issue with respect to gaming.

Finally found out that my problem was when I bought it they never activated the data plan. 


My BLINK Cameras work great now with my Inseego2000. After I made the below changes I deleted and reinstalled the SYNC module along with the cameras. 

I changed...
“Under Settings > Advanced > Networks - changed the APN to B2B.tmobile.com and the PDP to IPV4”.  
“AUTO (LTE/5G) to LTE/UMTS.”  

Checked my speeds and still getting the great speeds for now.  Will continue to check. 

Here was my problem:

My company LT2P VPN would not connect when connected to the Inseego 5G MiFi. Also, when using my company’s VoIP soft phone on my laptop, I couldn’t hear the caller and the caller couldn’t hear me. These things worked on my old Franklin LTE hotspot.

Here is my solution:

  • In the MiFi’s Advanced Settings, change the APN from fast.tmobile.com to B2B.tmobile.com
  • Change PDP from IPV6IPV4 to IPV4
  • Save
  • Disconnect from WiFi
  • Reconnect to WiFi.

    If you don’t disconnect your computer and reconnect, your computer won’t pick up the changes. Once doing this, everything works and I get the fast 5G speeds that you would miss if you force your modem to LTE only.

Thanks to the others above who helped me find where to click! 

Reply