I can't turn off message blocking? Using an unlocked AT&T with 1 line

  • 2 February 2018
  • 11 replies
  • 666 views

So originally, I have an Asus Zenphone, bought a Tmobile sim card and everything works well. However, when I got a Samsung Galaxy S6 that was unlocked from AT&T, I can't send any text message, there's the message blocking every time I tried to send SMS. I can make receive SMS and phone call, as well as data, so I don't understand.

 

The thing is that I have only 1 account on my line, so I can't access the blocking message from the plan->choose line like all the tutorial I have read, so I'm extremely confused right now, if anyone can help, I appreciate a lot.


11 replies

Yikes, not able to send a text message is no good! What is the exact error message? If you put your SIM card back in the old phone does sending text work again? Normally if you can’t send a text message it is related to the message center number. I would check your text message settings to see if you can change it. Steps are normally Messages> Settings>Message Center Number. The number should be +12063130004.

I keep receiving "Free Msg: Unable to send message - Message Blocking is active" every time I turn on after reseting the phone. And when I switch back to my old phone. I can send message normally. This is what make me so confused, thinking it's  the phone fault, then again, I can use data and stuff, so yeah...

Edit: I checked the number and it's correct

If your SIM card works in your old phone the device is the culprit. You might want to search for any blocking settings. Here is what I found on AT&T website https://www.att.com/devicehowto/tutorial.html#!/interactive/id/interactive_798091?make=Samsung&model=GalaxyS6G920A

Sometimes there is also settings inside the applications section. Settings>apps>menu>show system apps>messages see if there are any block settings in there. If still not resolved make sure your software is up to date and I would try a master reset.

That message blocking function is different, it's blocking messages from selected number. So it'she blocking message from coming in, while I can't even send my message...

I think the master reset would be best at this point.

I found the problem, it's because I connected to wifi. As soon as I turn off the wifi option, I can send text normally, weird :v

Great! How weird! I am glad you were able to find what was going on!

Userlevel 6

Hey there! It sounds like you've isolated this issue to happening on WiFi only; which is definitely an interesting twist. I know you mentioned having trouble following the steps to check for message blocking services -- we do have some troubleshooting outlined here: Message Blocking Active - are those more helpful? A single line postpaid plan should still be able to check this on MyTMobile. Can you let me know if those steps work for you?

Discussion successfully moved from Magenta Lounge to Not Sold by T-Mobile

Userlevel 5

Just checking in here to see how things are going. Did you get a chance to see the reply from @tmo_marissa​?

Userlevel 5

Happy Friday, @shizen!

I'm happy to see that you've been able to get this taken care of but I'd like to make sure you've looked over Marissa's reply which has some troubleshooting steps for the error message you see on your phone.

Please let us know if you have any other questions.

Reply