Question

is anyone having network issues with galaxy z fold 3??


Userlevel 2
Badge

after i updated my phone to android 12 my service got so dam bad i wish i dint do it my z fold 3 is slow and the service is patchy and im tired of talking to a rep it seems all i get is a reset your phone and that could help this a 1800 phone i might get rid of it and get the galaxy S22 ultra if this phone does not get any better


128 replies

I am so thankful I found this forum!!! I already tried the factory reset and was just about to mail my phone to Samsung. Applied the fiz and I'm good for now. 5 days straight of support chats and calls is not okay and definitely tests your patience!

I was having the same issue! Got it fixed thanks to this forum. I was ready to switch carriers before I found it

I thought I had a case with some magnet in it may cause interference with signal, that wasn't the case.

Got a new car, thought it was blocking signal... That wasn't the case.

Changed a new Sim card that wasn't the case.

 

Finally found this forum... Thank God at least there's a way around it until samsung gets its next update.This work around is good for now..

​​​​QUESTION: when the update comes do we need to do something after?? 

Fix worked for me too.  Thank you for sharing!  

after i updated my phone to android 12 my service got so dam bad i wish i dint do it my z fold 3 is slow and the service is patchy and im tired of talking to a rep it seems all i get is a reset your phone and that could help this a 1800 phone i might get rid of it and get the galaxy S22 ultra if this phone does not get any better

HI,

I went to the store to exchange the phone too. They told me that Samsung is aware of the issue, and will release an update soon. If anyone hear when the update is released please confirm here. I will check this forum every day, since I had to put my Sim card in a chip spare phone.

Userlevel 7
Badge +13

I thought I had a case with some magnet in it may cause interference with signal, that wasn't the case.

Got a new car, thought it was blocking signal... That wasn't the case.

Changed a new Sim card that wasn't the case.

 

Finally found this forum... Thank God at least there's a way around it until samsung gets its next update.This work around is good for now..

​​​​QUESTION: when the update comes do we need to do something after?? 

thats the big question right now..some are setting it to not reset when they restart their device..at this time its unknown if this will still be in place after Sammy kicks out an update or if the update will force reset everything for you.

I followed the directions posted here and I now have service after 4 days of being without service unless I used WiFi and countless useless calls to TMobile and Samsung technical support. Thank you to whoever submitted the work around. I pray that it holds up.

ME TOOO!!! I’ve called T-Mobile and say their network is fine. Samsung support, premium care and even Asurion don’t answer or solve the problem when sending replacement phones?! UGH!!! I can’t stand Samsung. I wan to sue them, I financed a phone thru them and now they don’t want to help correct their software issues?!

Wow, I wish I would have found this forum a few days earlier.  Ever since the Android 12 update I received on a few weeks back I was suffering without any reliable data connectivity on my Z Fold 3.  I’d spoken to T-Mobile 6 times, factory reset my phone, performed a SIM swap, updated the APN settings twice, spoke to Samsung tech support twice, and finally as per Samsung’s instruction shipped it back to them.  I’m still waiting to receive it back, but they’ve had it for 2 days now.  Hopefully they release a proper fix in the coming days because I’m sure there are tons of other Fold owners that are still living in 2G squalor.

Thank you to the user who had posted the fix. I too was going through a nightmare trying to fix this through tmobile, samsung ,ubreakitifix. I was going to try to put claim through my phone ins but did not think they would cover it because phone was just 3 months old and I thought they would require me to go through samsung.

 

I must say this experience has opened my eyes to next time I buy a phone.

*always buy phone through carrier and not manufacturer = otherwise phone service provider won't give you time of day with your hardware

* same as above for phone ins buy through phone service provider -in fairness I had not yet attempted to go through phone ins company just with experience with tmobile they only changed Sim card and deducted issue with phone after that and since I didn't buy phone from them (due to they didnt have model available at stores) and I didn't have ins through them it was not there problem. Needless to say I had four lines with them.

 

Looks like I will be open to shopping with other  phone carriers in near future.

 

One other point when problem started happening last week I immediatly thought issue might be related to upgrade on 1/28 but I discounted it because I didn't have the problems right after. I wonder it it started happening after first time phone restarted after update. 

Again thanks , this will be my first place I look next time.

Userlevel 7
Badge +13

Thank you to the user who had posted the fix. I too was going through a nightmare trying to fix this through tmobile, samsung ,ubreakitifix. I was going to try to put claim through my phone ins but did not think they would cover it because phone was just 3 months old and I thought they would require me to go through samsung.

 

I must say this experience has opened my eyes to next time I buy a phone.

*always buy phone through carrier and not manufacturer = otherwise phone service provider won't give you time of day with your hardware

* same as above for phone ins buy through phone service provider -in fairness I had not yet attempted to go through phone ins company just with experience with tmobile they only changed Sim card and deducted issue with phone after that and since I didn't buy phone from them (due to they didnt have model available at stores) and I didn't have ins through them it was not there problem. Needless to say I had four lines with them.

 

Looks like I will be open to shopping with other  phone carriers in near future.

 

One other point when problem started happening last week I immediatly thought issue might be related to upgrade on 1/28 but I discounted it because I didn't have the problems right after. I wonder it it started happening after first time phone restarted after update. 

Again thanks , this will be my first place I look next time.

 

dealing with it through insurance wouldnt matter since you would get yet another device that would have the same issue as soon as it took the update if it didnt already have it on it.

 

same with taking it into a store..not a whole lot they can do with it..an update must be pushed to the device to fix it...TMO isnt the one that makes said fix..the OEM is..

I, too have been having exactly the same problem/issues on my Z Fold 3!  Nice to know I'm not the only one! However, my issues seem more sporadic than what has been posted!.

It doesn't look like a factory reset will help? I will try the dialer technique but was wondering if a factory reset would be a good idea too?  Please advise! 

Badge

Is this issue resolved for whoever tried the code *#2263#?  I have tried in my mobile I can’t completely say it’s resolved but its better than before.  But I have noticed my battery is draining too fast now after trying this code.  As long as I’m connected to WIFI and turned on WIFI calling there is no issues as long as my WIFI works properly.  But the minute I step out of home issue kicks in with in 5 miles drive my network connectivity is getting lost at least 5 times.

 

Do you guys have T-Mobile variant of Z Fold 3?  Mine is an unlocked variant direct from Samsung.  I’m about to give up on this issue, tried calling T Mobile, Samsung and took it to the Service center but no resolution so far, Samsung cannot exchange my mobile, instead have to ship my mobile and wait for 11 business days without a phone.  Don’t have a backup phone either.  This is really ridiculous, spending almost $2000 for a phone and pay for the top of the line mobile plan but ending up having network issues cant even make a reliable phone call or browse the internet without WIFI.

I do not have the same options starting with band 71. Is there a work around for the work around 😭

This definitely worked for me and the phone data is working better than before i must say:

 

Go to the phone dialer and dial *#2263# then Pick the SIM first selection. Then select clear all 
bands. Then select LTE bands, pick band 71, then select go to main. Pick 5G band, select NR band 41 sub 6 and SA and NSA, then select
NR band 71 sub 6 SA and NSA. Then select block set by AP option, then Go select go to main and then Apply band configurations.

Should be fixed after that.

Badge

This definitely worked for me and the phone data is working better than before i must say:

 

Go to the phone dialer and dial *#2263# then Pick the SIM first selection. Then select clear all 
bands. Then select LTE bands, pick band 71, then select go to main. Pick 5G band, select NR band 41 sub 6 and SA and NSA, then select
NR band 71 sub 6 SA and NSA. Then select block set by AP option, then Go select go to main and then Apply band configurations.

Should be fixed after that.

I did this on my phone, after that definitely I have a better signal. (Before performing this configuration my mobile was had E, H+, 3G or 2G speed, after the configuration its showing 5G, LTE, LTE+, 3G) But still it doesn’t hold that well, even though it says 5G when you try to browse something it will take forever to load and also while in a phone call I still gets chopped off during the call, my callers say I’m breaking up or they didn’t hear me for a few seconds, so I have to keep repeating them again.

 

Are you using T-Mobile variant of Z fold 3 or Samsung Direct unlocked version of Z fold 3?

Im using a unlocked phone from Samsung. Did you make sure to the choose block set by AP option before applying?

everything you named was happening with mine as well before i did that and since then i havent had any issues accept for Tmobile had an outage in my area/ region and i was down for a bit on Tuesday.  

Badge

Im using a unlocked phone from Samsung. Did you make sure to the choose block set by AP option before applying?

everything you named was happening with mine as well before i did that and since then i havent had any issues accept for Tmobile had an outage in my area/ region and i was down for a bit on Tuesday.  

Good to know, Is your battery not draining fast after this configuration change?  I did select the AP option before but the battery was draining fast and my phone started to heat up while charging (this wasn’t the case before this configuration), I believe this is due to the phone keeps searching for the same network in these bands or something like that.

Hey guys... This issue happen to me as well. I bought my phone directly from Samsung ..after I did the update my phone went to crap I took it to 3 different TMobile stores and changed sim cards thinking that was the issue ..finally decided to ship it back to Samsung . 6 days after I sent it I received my phone back they told me the replaced the mother board on my phone and said it was fixed. When I opened my box from their shipment my phone was scratched. Btw I had the phone less than a month before this. I said w.e I just need/ want my phone back as I use it for work and personal use. Put my sim card and  NOTHING still the same problem immediately called them back. 2 hour wait time so I decided to have them called me back when it was my turn. 2 1/2 hours later they call back. I answered.. says I'm first in line and my call with be answered shortly 45 mins later nothing no one ever answered so I hung up. I called Monday and they said someone should be contacting me but the end of the week. Today Thursday I called they told me they were going to refund me my money because the phone couldn't be fixed. I turned in my note 10 which was flawless at the time and now I'm stuck with out a phone. Really annoyed and frustrated with the way Samsung has handled my situation !...looking into another Samsung device because I can't stand iphones 

Badge

Hey guys... This issue happen to me as well. I bought my phone directly from Samsung ..after I did the update my phone went to crap I took it to 3 different TMobile stores and changed sim cards thinking that was the issue ..finally decided to ship it back to Samsung . 6 days after I sent it I received my phone back they told me the replaced the mother board on my phone and said it was fixed. When I opened my box from their shipment my phone was scratched. Btw I had the phone less than a month before this. I said w.e I just need/ want my phone back as I use it for work and personal use. Put my sim card and  NOTHING still the same problem immediately called them back. 2 hour wait time so I decided to have them called me back when it was my turn. 2 1/2 hours later they call back. I answered.. says I'm first in line and my call with be answered shortly 45 mins later nothing no one ever answered so I hung up. I called Monday and they said someone should be contacting me but the end of the week. Today Thursday I called they told me they were going to refund me my money because the phone couldn't be fixed. I turned in my note 10 which was flawless at the time and now I'm stuck with out a phone. Really annoyed and frustrated with the way Samsung has handled my situation !...looking into another Samsung device because I can't stand iphones 

Sorry to hear that you really had a bad experience with them.  I had so many Samsung phones in the past, but this is the first time ever I face this kind of issues and this is the most expensive phone I ever bought.  Plus their customer service is getting worse, up to a point we end up dealing the issues on our own.   I’ll probably just wait until end of this month to see if they gonna roll out a security update with any fix for this.  For now, i’ll have to rely on the WIFI for calls and internet connection.

 

I have unlocked one. I did all the troubleshoot steps. But still can’t connect to the network, even the work around, I can only connect for a while then I lost connection again. I brought my phone to drop off at UBreakIFix since they are partner of Samsung Care, and they found nothing. The next day, I called Samsung and told them all the troubleshoot step I did, included downgrade to Android 11 but still no connection, they transfer me to Care+ and right away they send me a new phone, which came in yesterday, with perfect connection on Android 11. I upgraded to Android 12 and it worked fine till now. Looks like the root cause is the cellular antenna itself. Some people on other forum sent their phone back to Samsung and got mainboard replaced which fixed the issue. 

When I attempt to call the *#2263# I get "USSD Code Running" and then I get an "Unable to process this request." I'm on a Fold Z3 purchased directly from Samsung. Any ideas?

Badge

I have unlocked one. I did all the troubleshoot steps. But still can’t connect to the network, even the work around, I can only connect for a while then I lost connection again. I brought my phone to drop off at UBreakIFix since they are partner of Samsung Care, and they found nothing. The next day, I called Samsung and told them all the troubleshoot step I did, included downgrade to Android 11 but still no connection, they transfer me to Care+ and right away they send me a new phone, which came in yesterday, with perfect connection on Android 11. I upgraded to Android 12 and it worked fine till now. Looks like the root cause is the cellular antenna itself. Some people on other forum sent their phone back to Samsung and got mainboard replaced which fixed the issue. 

That is a great news!  Did they give you hard time with Care+  Do you have to pay anything extra or it’s just a quick easy mobile swap?  Also, did they give you a brand new phone as a replacement or it’s a refurbished?  Any details will be really helpful.  As I’m also in the same boat, mine is an Unlocked device directly purchased from Samsung.

I have unlocked one. I did all the troubleshoot steps. But still can’t connect to the network, even the work around, I can only connect for a while then I lost connection again. I brought my phone to drop off at UBreakIFix since they are partner of Samsung Care, and they found nothing. The next day, I called Samsung and told them all the troubleshoot step I did, included downgrade to Android 11 but still no connection, they transfer me to Care+ and right away they send me a new phone, which came in yesterday, with perfect connection on Android 11. I upgraded to Android 12 and it worked fine till now. Looks like the root cause is the cellular antenna itself. Some people on other forum sent their phone back to Samsung and got mainboard replaced which fixed the issue. 

That is a great news!  Did they give you hard time with Care+  Do you have to pay anything extra or it’s just a quick easy mobile swap?  Also, did they give you a brand new phone as a replacement or it’s a refurbished?  Any details will be really helpful.  As I’m also in the same boat, mine is an Unlocked device directly purchased from Samsung.

I have no hard time at all. the guys from customer services was awesome, he right away understand that I’m a power user, since I know what I have to do to troubleshoot. He right away transfer me to Care+, and they send me right away new replacement phone, no refurbished, it is brand new from a new sealed box. The Asurion may need your card information in case you won’t send back the malfunction device, they will charge you. if you sent the malfunction device back, there is no charge at all since my phone is under warranty.  

after i updated my phone to android 12 my service got so dam bad i wish i dint do it my z fold 3 is slow and the service is patchy and im tired of talking to a rep it seems all i get is a reset your phone and that could help this a 1800 phone i might get rid of it and get the galaxy S22 ultra if this phone does not get any better

Hello,

I also have a ZFold 3 with the same network issue after the update to Android version 12. However, only 1 of 2 of my phones have network issues. The one with the network issue with “BUILD NUMBER” “SP1A.210812.016.F926U1UES1BUL7” and the other one with “Build number” ended with xxxBULA without an issue.  Please share your “Build Number” if possible (Setting>About phone>Software information>Build number). Thanks!

Badge

after i updated my phone to android 12 my service got so dam bad i wish i dint do it my z fold 3 is slow and the service is patchy and im tired of talking to a rep it seems all i get is a reset your phone and that could help this a 1800 phone i might get rid of it and get the galaxy S22 ultra if this phone does not get any better

Hello,

I also have a ZFold 3 with the same network issue after the update to Android version 12. However, only 1 of 2 of my phones have network issues. The one with the network issue with “BUILD NUMBER” “SP1A.210812.016.F926U1UES1BUL7” and the other one with “Build number” ended with xxxBULA without an issue.  Please share your “Build Number” if possible (Setting>About phone>Software information>Build number). Thanks!

Mine ends with BULA, but I'm facing the issue. I think it's based on when & where the phone was manufactured.

Reply