Nokia Home Internet Gateway - Issues list

  • 5 February 2021
  • 4 replies
  • 647 views

Userlevel 2
Badge

Shoot I realized I posted this in the wrong area apologies! Mods feel free to delete as I have posted in the appropriate home internet subforum.

Wanted to see if any T-Mobile reps were active in these forums. I have been on the home Internet service for about a month now.

I was previously on ATT 4G LTE using a Netgear lb-1121 in bridge mode to my Watchguard firewall. I am an IT engineer and been working almost exclusively from home the last 9 months.

So to the point of this post. Current speeds are pretty good for the rural area I’m in. 1 mile from tower as the crow flies and seeing 100 down 60 up. However, I had to totally reconfigure my home network due to the VERY limited configuration available for this gateway. Okay no worries all of that done.

I understand this is a Nokia Fastmile gateway with T-Mobile specific firmware on it. I’m currently showing version  1.2003.03.0143 of the firmware. The Fastmile has configuration support for vpn passthrough as well as full bridge mode and other basic and advanced settings however it appears that T-Mobile has not developed their firmware to support these settings yet. There are TONS of reddit threads speaking to all the various issues people are having with this thing. I’m looking to hear from someone at T-Mobile who may be able to give us an update on when we might have updated firmware to address some of these issues.

Now to list all the various issues….

  • No VPN passthrough
    • I have tons of client VPNs we work with currently L2TP udp and IPSEC vpns can not traverse this gateway properly
  • Cannot change the LAN IP Subnet
    • You are locked into the private address range the device comes with
  • Wifi calling from a T-Mobile cellphone running through the T-Mobile gateway
    • Call drops, incoming calls ring once or are not received
  • Microsoft Teams calling has strange behavior periodically whether using the desktop app or Mobile App (Mobile App does seem to be somewhat better)

These are the big ones for me but you can just go to Reddit tmobileisp for more. As for my setup I am running the Home Internet gateway direct into my switching. All Wireless Radios and WLANs are turned off on the gateway as I use Ruckus wireless access points in our home. All devices are hardwired through Cat-6. Honestly never had these problems at all when on ATT granted I was running through my own Firewall with the modem in Bridge mode.

This can all be fixed if T-Mobile will get some updated firmware developed to allow us to use some of the settings available on the Fastmile.


4 replies

Badge

My experience:

  • VPN Works great for me
  • Change LAN IP Subnet - I think I changed mine, either way not a big deal to me
  • Wifi calling
    • I can call out.
    • Incoming calls don’t ring, go straight to voicemail
  • Microsoft Teams - not yet on MS Teams so no comment here
Badge

I have the same gateway with same problems.

Moreover:

  1. My VoIP phone does not work AT ALL. It worked fine with the TMobile LTE gateway. The Nokia seems to have a tougher firewall which does not allow SIP signals through port 5060. This may be the reason for your Wifi calls not working. The Tmobile “wifi calling” uses the SIP protocol.
  2. Just like the LTE gateway there is no Port Forwarding which creates a multitude of issues like not being able to access your security cameras, NAS etc. from the internet.
  3. Not being able to change the IP of the gateway is the smallest of its problems.

Adding a “bridge mode” to these gateways would be the best solution at this point. Their router features are extremely subpar and IDK why Tmobile does this.

IMHO they should stick to providing a modem only and let people use their own routers just as the cable ISPs do. Much cheaper device than this all-in-one contraption.

 

Badge

I completely agree that Tmobile should add a bridge mode to the 5G gateway so we can unplug our network from our existing broadband gateway and plug it into the Tmobile gateway.  I spent about 7 hours this evening replacing my LTE gateway with the new 5G gateway and getting my network back to functioning. 

 

First, it took me about ½ hour to figure out that I need to call Tmobile to assign the new SIM from the new gateway to my home internet plan (some instructions from Tmobile stating this would have been nice) and the I waited on hold 50+ minutes before speaking to anyone.   Once we got the gateway working, it took me a few more hours to realize that I needed to setup my Asus router in Access Point Mode and now I’m stuck with a neutered network and who knows what other issues I might experience when my wife and start working (from home) tomorrow.

 

Compare this to zero issues I had installing the LTE version of the Tmobile home internet gateway.  I have never been so pissed off at Tmobile for making this complicated and wasting my entire evening.

Badge

3 week follow up…

I've had 2 Nokia Fastmile 5G Gateways crap out. 1st lasted about 6 weeks, 2nd only one week. Are these overly sensitive to being powered by a modified sine wave inverter? 

No other devices have complained including 2 PCs, several phones, microwave.…

Use case: using the gateway in my RV for internet service.

Symptoms: gateway stops working, a reboot gets stuck at T-Mobile icon. A factory reset results in Openwrt being broadcast as SSID but no way to get connected.

Up until the gateway flaked out.…

VPN

  * Cisco Anyconnect to work (big healthcare company network) worked great. Nearly as good as Comcast gigabit. Dayum!!

 * Private Internet Access VPN for personal use stinks. Is T-Mobile blocking PIA ?

* Change LAN IP Subnet - can't do it. This was a bit annoying since I had specific IP addresses for VMs

 * Wifi calling - incoming calls go straight to voicemail. Not bad for annoying telemarketers. Quite bad when wife wants to reach me.

Reply