Power Cycling Franklin T9 Hotspot


I use a Franklin T9 hotspot to remotely control the thermostat in my cabin.  Occasionally the power goes out for an extended period of time, and the hotspot battery dies.  I then need to manually turn it back on again.  Is there a way to set it up such that it restarts automatically when the power comes back on?  Thx.

14 replies

We use a Franklin T9 hotspot as well for an extended use situation in a vending machine. We encountered after a certain period (~2-3 weeks) where the screen on the hotspot gave us the message “For extended use please remove the battery.” This makes sense because in some other devices we’ve experienced, when it’s charging and powered on constantly with the battery installed, over time this may put the battery at risk of swelling and rupturing. (Note: we have NOT had this experience with our Franklin T9, but it has happened to us with an AT&T hotspot and an iPhone 6s before.) Seems like a nice safety feature they added to have this.

HOWEVER, we did remove the battery and the unit was working great for a period with no battery, just plugged in via the usb charger. I can’t say specifically how long this period was but it was less than 2 weeks before the unit stopped broadcasting a signal and we received a message on the hotspot unit stating “Charged too long please disconnect the charger.” Alas, I don’t know if there’s a way to use these in an “extended use” scenario, but perhaps someone at T-mobile can help?


I also thought of the idea to have the outlet that the unit is plugged into essentially power cycle itself daily, so that the device would restart itself daily and not run into this problem. However, the device does not auto-startup upon losing power, the button has to be manually pushed in order to fire up and begin broadcasting a signal. Maybe there is a setting to change this auto-start, but I’ve yet to find it.


Sorry I couldn’t solve your problem but figured I’d share my struggles and hopefully we’ll resolve some day. Cheers.



I have the exact same issue as Chuck D. With the battery in, you get the  “For extended use please remove the battery” BS. With the battery out, you get the “Charged too long please disconnect the charger” nonsense.

Apparently no one knows how to remedy this problem, as this thread appears to be 3 months old. It’s totally unacceptable (and don’t even think about questioning why I think it is unacceptable).

So, given that the T9 is faulty (and it is, clearly, faulty), can anyone tell me if the T10 works properly? I am not sure I really want to stay with this lame-ass company, but you know… There is Devil you know vs. the one you don’t.


FYI, I solved this problem by buying a 4G LTE router.  I took the SIM out of the T9, dropped it in the router, and it “just worked”.  The router powers up automatically when when plugged in so it will restart automatically after a power failure, and I can put it on a timer to power cycle it if I need to.  So far I’ve not had to.

Userlevel 6
Badge +10

Wow! It is so cool to see the creative ways that the hotspot devices are being used 😃 They are originally designed to be used on the go in bursts instead of long term situations like these. It is cool that they are filling the need fairly well, but knowing the nature of the device it makes sense why these types of errors would be seen. I like the idea of getting devices that are specifically designed for the long term, stationary use. I would love to see T-Mobile offer something for long term connection in more unconventional areas where our home internet may not be available. Feedback heard and being passed along. 😁

I have the exact same issue.   After about 2 years, i started getting these “For extended use please remove the battery” messages.   I assume the battery is getting too hot.   However if you remove to battery and power is lost, then you are required to press the button to reboot.      This is a major pain.


Forward to this week his week, and my T9 stopped working, and when I got to the remote location, the battery tripled  in size and looks like it was about to explode.   


Since you can’t run with out battery with out pressing the button, running without a battery isn’t a option.

I use the T9 as a backup to the primary Starlink internet which has been working 100%, so i may not need a backup anymore.

Anyone know if the T10 solves this issue?    

The T10 does NOT solve the issue. I’m in a Homeowners Assoc and we use the T-10 Hotspots for an irrigation wifi connection for control of the system. Ours has to be online 24/7. I had asked prior to commiting to these hotspots if they could be connected and online 24/7 and I was told yes. Evidently the sales folks don’t know about the manual reboot requirement.  I also had to remove the batteries due to the same error messages but the routers still go offline regularly even though they are plugged in.  Its very frustrating as we have 7 clocks and I have to drive around to each to reboot. 

Oh no, is this what I am going to have to deal with? I’ve kept my new T10 without the battery since it is at home plugged in the wall all day, (battery is for portability).

It hasn't even been 10 days, and I noticed the internet wasn't working this morning, and find the “charged too long disconnect charger” message! I had to restart it by holding the power button - how ridiculous when there is no battery!

I hope this solves it!!! I got a hold of technical support and this is what they had me do. This is for the Franklin T10 with T-mobile. 

  1. go to to access settings to your T-mobile hotspot
  2. Password is lowercase admin
  3. it will make you set a new password 
  4. log in
  5. go to Settings-mobile network-APN
  6. under APN click Add
  7. it showed me a list of 4 profiles, profile1-profile4. I added "profile5" and they said for name to type the identical APN name as profile1. Do not select it as active yet, tap ok to the right.
  8. it will say the entry is incomplete. Say ok on the pop up. Go back and select profile5 now as the active and click ok. If it says incomplete again, wait 10 seconds and click ok again. (I remember 2 ok buttons, you should be clicking the ok that is on the same row as the new profile5 on the right).
  9. Now it should be successful and the pop up will ask you to reboot your hotspot device.
  10. Hold the power button for 5 seconds til it powers off.
  11. Wait 20 seconds.
  12. Power it back on.


As far as the hotspot and battery, they said it needs 3-5 hrs to fully charge and that it should work without being plugged in for 24 hrs; to try to only charge it 3-5 hrs a day and disconnect and avoid any of these battery or over charge warnings. I want to test the battery life for a day and then attach it to a timer to only charge 5 hrs a day and see how it goes! I hope that solves it 🤞


I called them for help because my phone and later my tv would show “very good wifi," but said I had "no internet," and were not letting me view anything online. This procedure connected my tv to the internet.


FYI, I solved this problem by buying a 4G LTE router.  I took the SIM out of the T9, dropped it in the router, and it “just worked”.  The router powers up automatically when when plugged in so it will restart automatically after a power failure, and I can put it on a timer to power cycle it if I need to.  So far I’ve not had to.

Thanks. I’m having the same issue with the T9. Using it for video surveillance at a rental property. T9 keeps going offline. Has anyone else attempted this solution before I place an order for this router?

I’m going to try Loby’s directions. Makes sense if you use an old style timer to turn on and off power to the hotspot for a few hours a day to charge the battery. The hotspot will be primarily working on battery but won’t be continuously charged. 

I have exactly the same problem.  Our lake cabin in northern Wisconsin (where temps can drop to -35F. overnight) MUST be monitored for temperature, and the Franklin T9 works, except when it doesn’t.  Goes out to lunch same as others have described.  I’ve spent HOURS pursuing this with Tmobile tech support only to be told “too bad so sad” or words to that effect.


I’m going to try the solution proposed by DaveInRiverwood and see if it works for me.  I’ll let you know.  Unfortunately, I’m in Arizona until late January, so for the next 30 days I’ll just have to keep my fingers crossed and hope that the boiler in the cabin basement doesn’t fail.


The timer option has worked for me. I give the hotspot power for 4-5 hours to charge the battery and then shut off the power with the timer. The battery does charge and drain daily but not completely. You don’t need a costly router.

My T10 would shut down approximately every two weeks or so when I had the battery removed and constantly hooked up to electricity. The hotspot has been working since October and hasn’t shut down. 


Same issue here, on vacation for 10 days and today my T10 seems to not be working, I can bet that the message says “charged too long”, as I pulled the battery out trying to solve the “charged too long disconnect the charger” issue. I thought about the timer prior to leaving but could not find one in time.

I never had this issue with the old ALCAT, the new unit cost $150 and to have these issues is very upsetting. I called T-Mobile but they could not offer me any help but to manually push the power button.

Is there some code I can text to the unit to have it reboot ?


I used to run into the charging issue as well, where I’d lose connection once every two weeks until I went out an restarted the hotspot. This was a pretty tedious and annoying problem, since I live 45 minutes to 1 hour away from where my instruments are running on the hotspot. I figured I could trick the hotspot into complying if I just discharged the battery every so often. Fortunately, you can buy a $5-$10 mechanical plug timer on amazon (or at your local hardware store) that’ll fix the issue. I set mine to charge and discharge every 30 minutes, and haven’t had any issues in the past month. Not sure what the long-term impact to the battery might be, but I’m hoping the short 30-minute bursts will prevent it from overheating. Might be better to use longer time periods and fewer cycles, but I guess we’ll find out eventually.