Roku not connecting to mifi

  • 21 April 2022
  • 3 replies


I have an Alcatel Linkzone 2 mifi on T-mobile.  In the last week all of my Roku devices (Roku2, Roku Express, and 2 Roku TV’s) have stopped connecting.  Before last week they were all working fine. 

My Rokus will connect to other home internet through other provider, my cell phone (Verizon) hotspot.  

But here’s the thing, my laptop, pc, and all of our phones (iphone, moto, kyocera) will connect to the mifi just fine.  My speed with it is currently 17mps.

The problem is the carrier says that since it works on my computer, phone, etc. that it’s Roku’s problem.  Roku says since it connects using other internet options it’s the internet’s problem.  I am stuck in a loop here.  I want to be able to use the mifi and cancel my other more expensive internet but can’t do that if I can’t use it for this purpose.

I have changed the connection settings to channel 11, max 20mhz, 802.11/b/g/n

Factory reset both Roku and mifi, checked for updates (current t-moble mifi version is:MW43TM25)

Any ideas?


3 replies

This literally just happened today to me as well! Has been working fine for months with the alcatel hotspot. I have two roku tv’s and neither will connect, even though it shows as a strong connection. Have reset both, network and factory, nothing is working. But all of my other devices, phones, laptops, computers, all connect perfectly fine. Please update if you find a solution!


@sarahmaec The solution was to:  under Admin settings for the mifi create a new APN leaving everything the same as the T-mobile APN except change to IPV4.  The IPV6 is what is preventing it from working.  Keep the .com the same too.  Good luck, it worked for me was finally able to connect after almost 2 weeks of frustration.  

I am having the same issues. I have tried setting up a new APN, but it says that profile name already exists.