Solved

Why don't callers hear my phone ringing when the call?


I have a Moto g5 plus. When I'm at home and using wifi on my phone, people who call me hear only silence on their end, and the phone never goes to voicemail., I can hear it ring, but if I don't answer, the phone won't stop ringing and won't go to voicemail.

Most inconvenient for a phone, to have callers unable to realize that they are calling you. People hang up before I can answer, as they assume they have not gotten thru. Or they hang up and then redial, assuming they did something wrong. And if I'm on my landline with a client, the cell rings and rings and rings rings and rings and rings and won't go to voicemail. Huge problem for my work. Any suggestions?

icon

Best answer by dottyeyes 18 April 2018, 20:45

I don't care whether I'm using cellular data or wifi (I guess), although I would think since I'm sharing the line, I'll use up my phone data faster. I'll have to see if the reception is worse inside my home.

Nevertheless, not good that phone doesn't work properly w/ wifi. The saga continues. I'll let you know what happens when I'm on someone else's wifi, and I'll have "wifi preferred" and turned on for phone calls. I'll keep you posted. Haha, "posted." That's really communicating old-school

View original

30 replies

Userlevel 4

That is super strange!! Is this only happening when you are connected to Wi-Fi calling? If so, have you ever been able to connect to a different Wi-Fi network to see if it still happens?

Good point. I'll have to check on another wifi. There is a similar discussion on the Moto g5 Plus owners discussion page. Other folks are having this same issue. When I turned off my wifi on the phone at home, a family memeber calle don his cell, and then he could hear my phone ringing. When I linked back up to wifi, he couldn't hear it ringing. (Meanwhile, whether wifi is turned on or off, the phone does ring for incoming calls. It's just that the caller can't hear it ringing.) I tweeted Motorola, and they say it's a carrier issue. I'm guessing if I tweet T-mobile, they'll say it's a Motorola issue. I'll let you know if I have the same problem under another wifi.

Userlevel 4

Nah, it's definitely an issue on our side. If it was the phone, it would be the same experience on Wi-Fi or not. Checking to see if its only on a specific Wi-Fi network will help us narrow down a Wi-Fi issue or a routing issue.

OK, thanks. Several times, family kept redialing, thinking they had misdialed or didn't properly connect. And because it doesn't jump to voicemail when in wifi, the phone keeps ringing. My wifi carrier is Verizon. A mobile-carrier rumble between T-Mobile and Verizon? 😊

Userlevel 4

lol, we always beefing but we wont make the customers suffer 😊 If it is the Wi-Fi, we have some tests we can run to see if it is a connection stability issue or a hardware issue.

I can verify that I am having the same issue. Moto G5 Plus, using Verizon as my ISP. Whenever I receive calls under WiFi they do not go to voicemail. The caller on the other end says the call is not going through, but I see missed calls on my phone. A tech at TMobile tried calling me and had the same experience.

Edit: wanted to add that if I see the call come in and hit "dismiss" the call will often go to voicemail.

To follow up for anyone else having the problem. TMobile wasn't able to help any further because I didn't have the phone password for the account to verify my account to the second level tech support. So I started googling.

I called the code ##004# from my phone to reset call forwarding settings.

I then followed the directions here Forwarding calls - moto g5 plus   (open phone/call app, go to menu->settings->calls) to make sure TMobile's voicemail number was listed (it was).

I just had someone call me and it finally went to voicemail, so this process may work for someone else.

Userlevel 4

That is an interesting find! Do the callers now hear the ring as well?

The caller was able to hear the ringing. The caller was also using TMobile, though, so hopefully there isn't a different outcome when a call comes from another carrier.

Thanks, magenta. Unfortunately, I followed your suggested steps, but it didn't help. The caller still doesn't hear the phone ring, and the call still doesn't go to voicemail whenever my phone is using wifi.

Userlevel 4

@dottyeyes​ - You get a chance to try it on a different Wi-Fi network yet?

Not yet. I could try this evening or tomorrow a.m. I'll let you know what I find out.

Userlevel 4

Okay, sounds good.

I'm at my home office and couldn't escape to an outside wifi place. But here is what worked.

  1. Go to Settings
  2. Go to ... More
  3. Go to Wi-Fi calling
  4. Make sure W-Fi calling switch is clicked to Off
  5. Turn phone off and back on (at least for me, I had to do the restart step)

Phone calls now ring on caller's end, and call goes to voicemail if I don't answer.

Userlevel 4

Sorry for the confusion! I thought you were intentionally using Wi-Fi calling as it helps improve indoor coverage. Were you not wanting to use Wi-Fi calling at all?

I don't care whether I'm using cellular data or wifi (I guess), although I would think since I'm sharing the line, I'll use up my phone data faster. I'll have to see if the reception is worse inside my home.

Nevertheless, not good that phone doesn't work properly w/ wifi. The saga continues. I'll let you know what happens when I'm on someone else's wifi, and I'll have "wifi preferred" and turned on for phone calls. I'll keep you posted. Haha, "posted." That's really communicating old-school

Userlevel 4

Oh definitely, it should work both ways but I am glad to hear that we have found an interim solution.

Userlevel 5

Hi, @dottyeyes​! I know that turning WiFi calling off was fixing this for you, but I just wanted to check in and see if you'd ever had the opportunity to test another WiFi network. 😊

Userlevel 5

Hey, @dottyeyes​! Just wanted to check in here and see if you'd had the opportunity to test another WiFi network yet. I hope we're not spamming you with check-ins; we just don't want you to think we forgot about you! 😊

I just wanted to update that the problem still exists. When a non-t-mobile user attempted to call me they did not get my voicemail. So it seems like something on the network side.

I've turned off WiFi calling to see if that helps.

FINALLY I got on another wifi network and had my husband phone me. When my wifi calling enabled, he could not hear the phone ring. So the same problem exists on another wifi besides my own home wifi.

*with my wifi calling enabled*

Userlevel 4

@dottyeyes - Okay, so since we have confined this to a Wi-Fi calling issue, we are going to need to get our engineers to take a look at what is going on on the network side. Please contact us when you have a moment.

@magenta4679655 - So when a non-tmo person calls you they hear ringing but it never goes to voicemail and when a tmo person calls you, they hear ringing and it does go to VM if you do not answer?

I have the same phone and exact same issues. I even returned one phone because of this bug. Drives me insane, I’m ready to revert back to my old Note 2!

That's correct. I was able to verify that the non-t-mobile user called, they heard ringing this time, but never were directed to voicemail. IvI' disabled wifi calling for now, which is disappointing, as the service in some areas of my home is not great.

Reply