Solved

Wifi and 4g lte on at the same time on S7 edge. How do I fix this?


I just got S7 edge and I'm having issues with the WiFi and 4g being on at the same time. I disabled the name caller ID. My wifi connection is great. How can I fix this?

icon

Best answer by clgonz6 13 April 2016, 14:14

View original

15 replies

Userlevel 5
Badge +12

Has probably something to do with an app you have installed, or the backup source when it restored caused a bug. What have to tried so far?

Well got the phone like 5 days ago. I'm not really sure what else it could be. I first read somewhere it was the name caller id and i disabled that.  I don't really know what app it could be since most are social media apps Facebook etc.

Userlevel 5
Badge +12

Did you use a backup when you went through the setup process?  If yes I have a feeling that's what the problem is.  Some setting isn't jiving well, and causing the problems.  You may need to do a clean install of stuff instead of using a backup.

Userlevel 5
Badge +12

Just some info I haven't disabled any apps yet.

Userlevel 2

Perhaps I'm missing something here, but why wouldn't LTE & WiFi be on at the same time? Such is almost always the case for me.

If you are using WiFi calling, the cellular network will disconnect completely (routing all calls & texts through WiFi). Otherwise, I would think you'd want both to be enabled. While at home, for example, I use WiFi for data and am also connected to the cellular network for calls and texts (I use the cellular preferred setting on WiFi calling).

While out and about, I leave the WiFi enabled. That way, if I go somewhere that has a network on my preferred list, it will automatically connect to the WiFi network. Also, if I turn off the WiFi, chances are that I will forget to turn in back on, thereby burning data from my high speed bucket (not that I'm a major data user anyhow).

Userlevel 5
Badge +12

My guess both icons are showing.

Sounds like your download booster is turned on.  I am not sure where that setting is on the S7 but you can search for it.

Userlevel 6
Badge +15

Hey @tidbits‌ has a good suggestion with uninstalling some apps. Were you able to find the one that may be causing this?

Well I didn't uninstall any apps. I did do a back up maybe that's why. I turned on my wifi calling as suggested above. It seemed to do the trick. Now I don't have problems with the wifi being connected and 4g network at the same time when I'm at home now using my wifi.

Userlevel 6
Badge +15

Awesome sauce! I'm glad that worked. Thanks for keeping us posted! 😊

I'm having the same exact issue... I recently just got the S9 plus and when I'm connected to my wifi my 4G LTE is still there as well.

Your mobile network needs to refresh. Go to mobile network and switch to something else then back to 4g then boom fixed

This did not change anything.

Same problem on J7 Prime after Oreo update.   When both are on, my battery drains faster.

If I go into Device Maintenance and select Fix Now, when completed my 4G is off - for a  while, then comes back on again.

If your battery drains quickly with WiFi and 4G LTE on at the same time – and especially if you see the "4G LTE" icon appear briefly every few seconds in the top status bar / system tray –

For us, it was toggling "VoLTE calls" off and on again, under Connections > Mobile Networks (this was on a Samsung S6).

Hope that helps someone.

Reply