Solved

YouTube App Video Quality Is Horrible & Won't Allow Me To Change It


I turned off BingeOn in January and my YouTube App video quality went back to normal plus I was able to manually pick if I wanted 720p, 1080p and so on. As of yesterday whenever I try to to change the video quality in the YouTube app I get "Manual quality selection over cellular network is not supported" which sucks! Why do I pay all the money for this iPhone 6s Plus to watch videos in crappy low resolution? I don't care about the unlimited data plan BingeOn feature because I have unlimited data on my account!!!


How can I get this changed???


Thank you

icon

Best answer by smplyunprdctble 24 March 2016, 15:48

Did it coincide with an update to the Youtube app?

There could be a bug in the app.

View original

34 replies

Userlevel 7
Badge +13

Turn Binge On off.

Binge On how-tos

Gramps28,

I know all about Binge On and how it works plus I've used used #264# on my phone and it says "Binge On is currently disabled" but I still get the same message when I try to change the video quality in the YouTube app? The little "gear" that you use to change the video quality is grayed out. I even deleted the app and it's still the same?

Userlevel 7
Badge +13

Have you tried to disable it through your MyTmobile account to see if it's a

glitch using #264# ?

It says it's disabled on my account also? I used the #263# again to see if that does anything but if not I don't really know what I can do besides call customer care I guess. This just started happening about 2 days ago which I thought was weird.

Userlevel 6

Did it coincide with an update to the Youtube app?

There could be a bug in the app.

Not that I know, my YouTube version is 11.10.9

Is there a newer version out because the App Store is saying that's the current version?

Userlevel 6

I'm asking did Youtube update to that 11.10.9 when the problems started.

Well I just went into the Apple app store and checked when the latest version was released by checking the "Version History" at the bottom of the YouTube app in the Apple app store and yes it says version 11.10 was released on March 22, 2016 so that could be my issue?

I'm surprised no one else with an iPhone has run into this problem yet unless it's just something on my account?

Userlevel 7
Badge +12

It kind of coincides with Google doing their own network optimization for BingeOn. There may be a few bugs and may need to bring it up with Google and YouTube app can be updated in the sense of the backend which we'll never see.

Makes sense and thanks everyone for the help, I'II just wait it out for a few days to see if it changes.


extremevl wrote:



I don't care about the unlimited data plan BingeOn feature because I have unlimited data on my account!!!


No such thing as "unlimited data". Keep watching 1080p youtube videos and you'll be getting throttled down in a few days. You are paying for "unlimited data" but not for "unlimited data at LTE Speeds". Data at 2G speeds is useless for watching videos as you simply can not watch videos w/ 2G speeds, what your speed would be after using 25GB of LTE data with your data plan.

It does make great "Development sense" to auto adjust resolution of videos while on a cellular network, otherwise you'd be buffering the 1080p content for 7 hours to watch a 2 min video if your connection is slow, spotty or constantly being handed over (travelling). Surely it is not something favorable from the end user point of view, as every single customer have a unique use scenario. Developers tend to oversimplify use scenarios, I know for a fact 😊

I've never gone over 7GB of data in a month and that was with using YouTube, watching videos at 1080p and using other data intensive apps all the time with my normal usage habits, that's why I don't carry about the data. My videos didn't buffer that much on LTE speeds here in Las Vegas, Nevada where I live and I got a good connection. I can see where you're going but at the end of the day I have my phone with it's HD screen for a reason and if I get a Samsung Galaxy S7 Edge or whatever comes out in the future then I want to use it the way it was intended. If I want to watch videos in HD then let me watch them in HD, if I go over my data plan I'II deal with it and pay for it. To go from using YouTube the way I did before to now watching video in crappy low resolution is horrible. My friends have AT&T and Verizon and they watch YouTube videos at 1440p on their phones over cellular data with no issues at all so please don't tell me over wise .

Userlevel 7
Badge +12

Did you adjust your APN?

could be a reason why you are having trouble.  Remake your APN and copy it exactly as the original one.  The only thing you are going to change is IPv6 to IPv4/IPv6. 


extremevl wrote:



so please don't tell me over wise .


I take back everything I said. You got this all figured out, sorry.

Userlevel 7
Badge +12

extremevl wrote:



I've never gone over 7GB of data in a month and that was with using YouTube, watching videos at 1080p and using other data intensive apps all the time with my normal usage habits, that's why I don't carry about the data. My videos didn't buffer that much on LTE speeds here in Las Vegas, Nevada where I live and I got a good connection. I can see where you're going but at the end of the day I have my phone with it's HD screen for a reason and if I get a Samsung Galaxy S7 Edge or whatever comes out in the future then I want to use it the way it was intended. If I want to watch videos in HD then let me watch them in HD, if I go over my data plan I'II deal with it and pay for it. To go from using YouTube the way I did before to now watching video in crappy low resolution is horrible. My friends have AT&T and Verizon and they watch YouTube videos at 1440p on their phones over cellular data with no issues at all so please don't tell me over wise .


Also did you go into settings of the YouTube app and turned off limit mobile data usage?  It forces the app to not show anything over 480P iirc and doesn't give the option to go higher resolutions.  Also do the APN thing.  Your overall speeds will thank you later.

I'm not mad at you so sorry to make it seem that way but I used to work at AT&T from 2005 to 2012 as a sales representative so I know how data plans work, I sold phones and setup plans for years. When I had AT&T (personal line not my work phone) I used my unlimited data plan and never went over 8GB - 9GB every month. I never had an issue using my LTE data speeds and watching YouTube videos at 1440p resolution and using other data intensive apps ever. I only left AT&T because my bill was too high for the services I was getting and T-Mobile had unlimited data plans still so I switched last year. Everything was great until T-Mobile launched this Binge On program and then I had issues with my data streaming speeds with T-Mobile, it went away since then but now it's back again and that's why I'm upset.

Nothing is working, I will just wait it out until next week and then contact technical support if nothing changes or check some online forums to see if they is an issue with YouTube, T-Mobile or both?

Userlevel 7
Badge +12

No I do not have trouble with any of them.  I did have data speed issues and changing the APN fixed the problem.  So you did check your YouTube settings to ensure Limit Mobile Data Usage is off?

The new version of YouTube in the Apple App Store doesn't seem to have that option anymore -

Restricted Mode Filtering

Open Links with Chrome

Play HD on Wi-Fi only (turned off)

Connected TVs

Contact location

Upload quality (1080p)

Upload over Wi-Fi Only (turned off)

The other options are about only about privacy

There was just a post on another forum complaining Amazon Video used 3GB of data in about 40 minutes. If you really do watch 1080p content a lot, I can not imagine not getting to tens of GBs of data without Binge On. That was my assumption but your experience preceeds my assumptions.

I never used data that fast, seems weird to use that much in 40 minutes but I tend to watch quick little videos which never really amounted to much data on my part. I think I may have found the issue -YouTube and Google Play Join T-Mobile's 'Binge On' - Fortune and this just happened on March 18th, 2016. I upgraded my phone but hated it so I returned it and switched back to my iPhone 6s Plus on Monday. I wonder if making that switch and Google joining the Binge On Program is why I'm having this issue? My Binge On is turned off for sure; I checked on my phone, over the phone with T-Mobile Customer Care and in person at the T-Mobile store today. No one knows what the problem is but I've seen other people in forums online having problems now also. Maybe it's a staggered rollout and because I switched phones recently I'm seeing the problem first? I hope its just something wrong with my account only but I don't know now.

Userlevel 7
Badge +12

I mention that earlier Google is in control on their end. T-Mobile is hands off as part of how they got Google on board. If there is a problem you have to bring it up with Google.

Right now I have BingeOn off on my iPhone 6 line and I tested it out (at work developer) and no trouble at all. Waiting for some coworkers to come in and see if they can test theirs. Not sure when they'll be in IF they come in. Had a wicked party last night before some of us ship to Korea for a major project.

It is weird, None of us are able to replicate such an issue with our devices and the latest youtube app. I just did a test and was able to set video quality to 1080p over 4G connection (not LTE)

Something to think about, does your iPhone have an iOS update available and waiting for you to do it? I know sometimes apps show unpredictable behavior under this specific circumstance.

Do you have your iPhone listed as your current device on your t-mobile account or the one you did not like? I am not sure but the Binge On may be tied to the device rather than sim?

‌I'm on iOS version 9.3 which just came out, new SIM card, IMEI is correct on my account and showing the correct phone, Binge On turned off and verified multiple times, deleted and reinstalled YouTube app, YouTube app settings triple checked...don't know what else to do besides wait? I'm fairly tech savvy but I'm not getting anywhere,  this just started happening on Tuesday or that's at least when I noticed. Also I turned Binge On off when they first launched the program because I was put on it automatically and everything went back to normal within minutes. When I checked my account on Tuesday Binge On was still off but I keep getting that error I explained in the first post, it's weird.

Thanks for the help anyway!

I'll try to wait it out, thanks for the help!

Reply