Alcatel Linkzone Connect To Internet.

  • 23 September 2019
  • 3 replies

I had received an Alcatel Linkzone hotspot from my school to connect to a chrome book. It came with a T-Mobile SIM card. The Hotspot is able to create a wifi network but when connected it has a popup window for T-Mobile ConnectMe. When I press the "Get Started" button nothing happens except the page starts loading and about 3 minutes later the page times out. I have tried pressing it on a MacBook, an iPhone, and a Chromebook, all with similar results. I tried seeing if it was possible by activating it by putting a SIM card in the iPhone but had no luck. The iPhone displayed it was TMobile LTE. After restarts and reseting network settings I checked if I was able to use data using it or make calls to see if it was just the hotspot, but both did not work. The SIM card is 4G LTE. I have hard reset the hotspot several times, with no luck. The hotspot is updated to MW41_00_02.00_28. Please let me know if you have any ideas.

Thank you.

3 replies

Userlevel 5

Well that is super odd! Do you by any chance have another laptop you could try connecting to the network, perhaps a friends?

Userlevel 5

Good morning! Just wanted to check in to see if you've had a chance to try connecting to the network with a different device? If so, how'd that work out?

Sorry about this. But I had forgotten about this thread I had made, and I do still have the issue. Yes I have tried connecting via Chromebook, IPhone, and iMac since than. I have factory reset the hotspot with no difference. I had seen another thread that said it could be resolved by changing the password of the Hotspot and reconnecting. This did not work. The hotspot seems to have access to anything in the domain The ConnectMe page is and I was able to go to where it said that the hotspot needed an update. I tried following the instructions and it told me to press check for updates in the device settings. The check for updates had failed. Thank you for your concern in helping me.