Can't activate Test Drive hotspot

  • 30 August 2019
  • 29 replies

I'm having problems with activating the hotspot. I tried on a iPhone , Samsung and the computer

and the "Get Started" did nothing.

(messed up with the screenshot)


Best answer by tmo_amanda 3 September 2019, 18:52

View original

29 replies

I have same issue.  Hotspot is fully charged and connected and everytime I get to the sign in page and click the "Get Started" button, it just sits there doing nothing.

Doesn't bode well for me wanting to go with T-Mobile...

Same issue here. I spoke with 3 different people in  "Support" and none of them were very helpful. The third and final person was almost rude and said that I had to wait two hours for it to activate...yeah, right. 4 hours later still NADA!  NOt looking good in the Magenta camp.

Same issue here. The login screen when connecting to wi-fi hangs and doesn't receive a response from the server. I can't activate the mobile hotspot from test drive. I received it today. Signal is green, battery is charged. Tried restarting and tried different devices. No game

Not looking too promising for Big "Pink" is it?

Issues happen. Let's just make sure they know about it. They just launched it and they're ironing out the bugs.

Solved by Tmobile support! Reach out to them via Twitter with the email you used to request the service. They'll activate it server side. Works now 😊

Same issue.  I have Verizon and got this thinking just maybe I can switch.  Literally waited on hold for 20 minutes not to get anyone and I had to hang up.  Then their text support was just awful.  Had to connect multiple times just to get a number they want me to call,  took at least an hour.  Come on guys. 

I need help setting up this test drive hotspot not so cool to get it to test drive and cant use it... please reply

Call 1-833-866-4839 and have them activate.  It worked like a charm, they said 2 hours, it took about 15 minutes.  Works good so far, now to take it to the back roads of PA To test the signal strength. 

Userlevel 3

Hey everyone,

Sorry we're just now getting back to you. Everything should be running smoothly now. We had a slight hiccup, but it has been fixed. If for some reason you're still having issues with this, please call the dedicated Toll Free Number that's included in your confirmation email/quick start guide.

This site can’t be reached took too long to respond.



HI there! This is the message I get went I try to activate with the coolpad surf hotspot device.  I called the number on the instructions that came with the device but I went through 9 reps and none could fix this problem.  They all had something different to say and sounded like they didn't know much about this free trial to get new customers.  all the issues mentioned above by the rest of the postings I have the same issue.
It's funny how even some reps on the phone told me the exact thing, to wait for two hours and the problem would be fixed. LOL
Any real help would be appreciated.

I am still having this issue. After connecting to the hotspot successfully, it’s stuck in “get started“ page. I had look into the device settings, it doesn't have a phone number associated with the hotspot even with the SIM card inserted. Occasionally, the data light will flash on the test drive hotspot.

The chat and phone support isn’t helpful at all. Please advise.

Userlevel 3

@jayjay1920​, I'm a bit baffled as well as I don't see anything that shows the exact error message that you're encountering. Let me see what I can find out for you.

@deedub626​, it sounds like you may need to complete the activation. Did they confirm that everything was activated when you called the dedicated support phone number?

Hi there, they weren’t helpful. All they could tell me is to wait.

I have the same issue. I called support and the representative on the line said some SIM cards needed to be manually activated and the one that came with my device was one of them. She did so and told me if I didn't have service after resetting the device, to wait 2 hours. It's been over 2 hours now and still cannot connect. I can see it if I go to but the device indicates there is no SIM card inserted. I assure you, not only is the card in there, but I cannot even take it out if I wanted to.

Userlevel 3

@deedub626 and @patrick_d​ -- how are things working today? Everything should be fully activated by now. Send an update my way so I can get in touch with my Test Drive team to get you answers.

Still not connected. I'm a sprint customer, soon to be absorbed into Tmobile. How can I test to see if I want to be there when the merger is finalized?

All the photos attached were taken just seconds before composing this message.

Get Outlook for Android<>

Userlevel 3

I'm not seeing any photos, can you give it one more shot?

As far as testing coverage, we want to make this work so you're able to get an idea of what kind of service to expect if you were to join T-Mobile. I'm really really sorry we've hit a few bumps in the road with Test Drive but I'm doing my best to pass info along so we can get everything ironed out.

I still can't connect. I give up. Thanks for nothing Tmobile.

Userlevel 4
Badge +9

Is the SIM upside down? 😕 The metal part is facing down, right?

It's not upside down. In the photos preceding this message, does the sim appear to be upside down? It only really goes in one way. Maybe the sim is defective? I don't really care anymore. I'm done wasting time trying to get this thing to work.

Get Outlook for Android<>

the sim might need to be pushed in further it looks like its not in all the way to me . On my hotspot I can’t even see the T on the SIM card in your pictures you can see it.

Try again. That SIM card can't be pushed any farther.

Get Outlook for Android<>

I'm having the same problem. I've tried using several different devices and still doesn't help. I've even logged into the administration page and can see the strength of the service is good, it's  connected to service, etc. Every is good on that part but still get the same startup page as everyone here and goes nowhere. On the administration page you can even see data trickling through the device.  Says I've used 30 something mb already but I haven't connected to anything yet. I'm attaching screenshots.