contacts show up twice on SyncUP watch

  • 19 April 2023
  • 9 replies


My ex got my daughter a SyncUp watch and added me as a Guardian.  I also got a SyncUp watch for our other daughter and added my ex as a Guardian.


On the watch my ex purchased I show up as both “Dad” and “Scott”.  I am only in the contacts once.  She can send a test to both and I receive them both.  It seems to be messing up the watch.  How can we fix that?

9 replies

This is literally our exact issue right now too. How do I delete the text threads? My husband already tried deleting me and re-adding. That didn't work.ive tried resetting the watch too. 

Userlevel 7
Badge +14

ok. That makes more sense. It sounds like the watch is mixing up contact data and caller id information from the network. Usually, when communication goes from one device to another, the network feeds information to the destination device, i.e. phone number, caller id name, city and state. When the destination device has that phone number saved in their contacts, the name that is displayed is the name from the contacts instead of what the network shows. In this case, it sounds like the watch not linking the incoming communications to the contact that is saved and causing it to show separately. There isn’t a setting in the watch to turn that on or off, but when it goes wrong there are a few tricks to refresh things and make it work again. 

  1. Fully delete both message threads. Don’t even leave one message on the watch. If there is something that you want to keep, take a screenshot or forward it somewhere else so you don’t lose that important information. 
  2. Delete your contact and then readd it. 
  3. Make sure the watch is up to date.
  4. Restart the watch.
  5. If you do all of that and it is still splitting the message threads, then you would want to reset the watch to resolve whatever weird software glitch is not working correctly. The steps for resetting are shown on our SyncUp Watch Support page

In the Contacts on the Adim app, I am “Dad”.


It’s messing up the watch from the perspective that my kid sends a message to “Dad”, but gets one back from “Scott”, on the very same number.  To a kid that’s sort of a big deal, they don’t want their parents by name.  Plus, the history is scattered between the two contacts.

Userlevel 7
Badge +14

And where the Admins add contacts are you in there as Dad or Scott? I am thinking that this could have something to do with caller id and saved contacts. 

Understanding the contact situation, what is messing up on the device exactly? Are there times that calls or messages to you don’t go through? Or something else?


In the SyncUp kids app, where Admins add contacts, I am only in there once.


On the watch, she has a contact for both “Dad” and “Scott”, same number.  She can text either one, they both come to me.  It says “Scott” anytime I text her.

Userlevel 7
Badge +14

I am sorry for not understanding completely. You are only in the contacts once under what name? 

When exactly does the watch show dad and Scott? Like when she texts, it says dad, but when you call her it says Scott? Just want to fully understand when the differences occur so we can identify where the broken link is. 

Resetting can be a lot to go through for every quirk, but it can eliminate the need to try and hunt down the anomalies and test different theories because it lets you start from square one. 


In Contacts I am only in there once.  On the watch I am “Dad” and then again as “Scott”.  She is sending a text message to both contacts and I get them both.  I have not disconnected and reset, I don’t want to have to do that for every little quirk.

Userlevel 7
Badge +14

Have you tried a disconnect and reset?

Userlevel 7
Badge +14

What a peculiar issue. This is not a basic situation so I have a few questions to better understand what is going on.

  1. What name does the watch have in the contacts?
  2. When do you show up as “Dad” and when do you show up as “Scott”?
  3. Is she sending a test message or phone call when both work? 
  4. When you say that it is messing up the watch, what exactly is messing up? 

Thanks for sharing.