Stuck on "Resolving Host.."

Using a new LG-M210 phone a Mobile HotSpot I often get pages hanging up with extended "Resolving Host.." in the activity window then DNS error page.

I have worked with T-Mobile tech support multiple times, to no avail. System will work well for a short time, then start failing again.

Happens with well known web pages like, etc.

I can put a continuous ping on that site, getting a good return, but unable to resolve DNS.

Tracert shows at least 5 hops through t-mobile servers before even hitting the internet.



Best answer by tmo_chris 19 January 2018, 19:02

Hey @magenta3737472

Our engineers are still having a hard time pinpointing the issue due to the intermittency of it. I am going to send you a private message so I can gather some necessary information.

View original

23 replies

Userlevel 5

Oh man! That is super frustrating! When you spoke with our tech support teams, did they happen to open up an engineering support ticket that you remember?

They might have at one time. I don't remember. Usually they try resetting everything then say "It's good". And it is -- for a few minutes or hours.

Userlevel 5

Yeah, something is definitely not right here if it keeps reverting. Please contact us again and let them know that this is the usual pattern and we can add that information to the service ticket.

Userlevel 6
Badge +14

Hey there!

Were you able to get a new service ticket filed for this? Please keep us posted on any updates. Thanks.


Userlevel 5

Awesome! We will definitely get to the bottom of this. Please let us know how it goes.

Userlevel 5

Just wanted to check in to see if you had any updates! 😊


No. I have not heard from anyone. Internet is up and down all morning. Not sure I'll even get this message out.

Userlevel 5

Do you happen to have the ticket number that was filed for you?

Trouble Ticket #18498094

edit: tmo_chris - Removed personal information.

Userlevel 5

Thanks for the info! I was able open up that ticket and I can see that the engineers confirmed this issue is due to insufficient indoor coverage causing the disconnects. We do have plans to add L700A band 12 to your local tower and your Aristo does support this frequency. Band 12 will give you increased indoor coverage but it is not slated to go live until 3/30/2018. In the interim, you could probably benefit from one of our 4G LTE Signal booster Duo devices as it will help bring stronger signal from one area of your home (like near a window) to a less covered area of your home. The new Duo booster also supports band 12 so it will still be compatible with the upgrade we have coming to your area.

As for communication via e-mail, we do not have that ability here on the support community but if you do get this message, please contact us so our tech teams can look into getting you the 4G LTE Signal Booster Duo.

I'm not sure I can agree with their assessment.

1. The cell tower I'm working off of is 4,500 feet from the house.

2. Signal is max - 5 bars in all rooms.

3 Failure is not a connection problem, it is a DNS (Domain Name Server) problem.

I can set up a constant ping on a remote site to monitor connection. Even while getting good returns, I get cannot resolve server error messages. If I lost connection, the pings would stop.

Also, between me and the internet backbone are 5 T-Mobile servers. Their IPs are,,,, and My theory, and I cannot prove it, is that one of those servers has a problem.

March isn't too far away, it will be interesting.

Userlevel 5

My apologies, I was just referencing the trouble ticket notes but what you are saying makes total sense. I am going to add this additional information to the ticket and re-open it since it was already created. I will follow up with you here as soon as I hear back from the support teams.

Userlevel 5

Hey there! Just heard back from the engineers. Looking at the data as of 1/16 we are seeing instances of significant data traffic. Are you still having this issue?

Yes. Problem is random, but still there. Very frustrating.

I tried internet explorer instead of Chrome which I usually use. First thought it was working better, but then it started failing too. Just doesn't give me clues as to why where Chrome does.

Userlevel 5

Ahh okay, if the issue is intermittent, this would explain why we were seeing successful connections. Can you get me a couple time stamps of when the failures occur?

OK. At 5:35 after reading getting email with the above request for timestamp, I went to . Instead I got a failure. Constant "resolving dns" in the activity box. Then "This site can't be reached -'s server DNS address could not be found." error page.

While I was waiting for the page to resolve, periodically reloading, I did a ping on "". The ping returned, which is NOT t-mobile's IP. That belongs to

I have screenshots of the above.

At 5:48, 13 minutes later t-mobiles support page (this one) finally resolved.

Times are in CST.

Something I thought of. A few years ago Hugh's Net was having some similar problems. Had to do with bringing in IPV6 protocol. I've noticed on my phone in the Access Point setup the APN protocol is set to IPV6 only. Maybe should be IPV4/IPV6? Not sure how to change it.

I looked at Akamai Technologies and realize it is a content delivery service. t-mobile is probably using them, so IP probably valid.

One more bit of information. I operate a weather station that uploads weather data every 5 minutes 24/7 to NOA and other weather sites. Looking at data recorded at PWS - Station Observations for KM4VKY  you will see it never misses, even when I'm unsuccessfully surfing the internet.

It is for this reliability that I chose using the t-mobile hotspot over Hughs Net or Exede which usually fail in bad weather.

Userlevel 5

Thanks for the info! I will get this reopened and follow up with you as soon as I hear back.

Userlevel 5

Hey @magenta3737472

Our engineers are still having a hard time pinpointing the issue due to the intermittency of it. I am going to send you a private message so I can gather some necessary information.