Question

sync up kids watch says device is corrupt

  • 9 November 2022
  • 2 replies
  • 21 views

Badge

I've had my son's watch for a little less than 1 months, it has worked perfectly until now. We went on a cruise and he didn't wear his watch at all except the first day or 2. Eventually the battery died and we just left it alone until we got home. Charged it completely and now when I turn it on it goes to a screen that says "The device is corrupt. It cannot be trusted and will not boot. If no key is pressed, it will reboot in 5 seconds." But it never reboots. It stays on that screen for maybe 10 seconds and then turns back off. Anyone experienced the same?


2 replies

Userlevel 7
Badge +15

Is it rooted?  Usually rooted devices are the only reason you will see a warning about the device not being trusted.  Have you tried factory resetting it to see if that fixes it?

Badge

Idk what that means? We got it from our local tmobile store. It had been working fine until we went out of the country. I don't know how to do a factory reset. I can't get to any settings menu at all. It flashes the pink tmobile logo for a second then goes to that error screen. 

Reply