I cannot get past the security questions

I have a postpaid account which is working fine and I can manage my postpaid phone lines just fine.

However, I also had to create a separate account with a separate email address to manage a prepaid phone for an elderly relative.

Immediately after I log in to my prepaid account (email address ending in, it asks me to answer security questions, to which I no longer remember the answers. I probably entered random answers when I first set them up, because I never forget my password (I use LastPass).

In fact my password is still working just fine, so I don't even understand why it's asking me to verify security questions after I have successfully logged in?

I thought security questions were used only when you forget your password (which again, I never do).

There is no other verification method offered on the Security Questions screen. How do I get past these security questions if I don't know the answers, but do know my password?


Best answer by tmo_amanda 29 March 2018, 22:14

View original

10 replies

Userlevel 3

Hi, @grnch​!

I see you're new to our Support Community; welcome! It sounds like you're in quite the pickle. 😥  That's super odd that you're able to essentially "log in" with the correct password and are then met with security questions (which isn't the typical experience). Just to make sure I'm understanding this correctly - these aren't new security questions that you're being asked, you're being asked for previously provided answers, right? If you're being asked for previously provided answers and don't remember them, you'll want to Community-2153 to work on resetting those answers.

Userlevel 3

Hey, @grnch​!

I just wanted to swing by to see if you've had a chance to look over my previous reply to you. Please let me know how else I can help out. 😊 ​

Userlevel 6
Badge +15

Hi there!

Have you been able to get past those questions and get signed in? Please come back and let us know. Thank you.

Hello Amanda and Mike,

Unfortunately I am still unable to get past the security questions. They appear immediately after I log in, and there is no way to bypass them.

I even tried resetting my password using the "Forgot Password" feature, hoping that it might trigger some kind of reset of my account. But as soon as I clicked the password reset link in my email and entered my new password, the very next step were the dreaded security questions again.

I also tried calling customer service by phone (before I made the original post here), and they told me they were unable to reset the questions for me. Perhaps I ended up calling the wrong department in the phone menu or something.

I would appreciate if you could give me a more direct way to contact someone with the ability to reset my security questions, like which phone number to call, what option to select in the menu, etc.

Userlevel 6
Badge +15

What a bummer. Sorry this is still giving you fits. You should be able to describe the issue and get routed to our Tech Care team when you call. Another way you could get this resolved is by reaching out to our T-Force team through the social media links in my badge below or on our Community-2153​ page. The good thing about reaching out that way, is you can link them to this discussion here and they'll be able to know what to do without you having to repeat everything. Out T-Force team can securely get access to your account and start working on this right away. I suggest giving them a shot at resolving this for you.

I am having this exact issue as well. I am unable to access my account in any way because I forgot the answers to my security questions I made many years ago. I can change my password just fine but I keep getting blocked by the security question page. I tried calling support and we changed my password through him but still met with the same issue. I can't do anything with my account at all. There's no way past these questions.

Mike it would not be a bummer if two factor authentication was not forced on us.  I have two factor authentication turned off and T-mobile still makes me enter my username, password and THEN a series of questions or send a temp code to the phone to PROVE that it is me.  Customer service in Manila only knows how to send a link to reset password which solves Nothing.  A supposed "Tech"  changed my answers to the questions but then when I logged in that option to answer questions vanished.  Now the only option is to send a temp code to a phone that is not working.  Manila techs suggestion was to ask someone in the neighborhood if I could borrow their GSM phone and slip my T-mobile SIM in the get to My T-mobile.   I think the entire security process is Idiotic when that is the only option.  My bank and Social Security site has more options and does not limit me that way.

I'm having the same problems as well... I also am unable to receive a verification code which hasn't been working for any app I've used that requires one. I've been trying to get into my account to see if I could fix that but now this is getting even more frustrating with this other setback.

  • I can not get passed the security questions. Everything else is right. 1 of the questions would not be a question Id choose because their is no answer to that question. How do I fix this

2 years later, this problem still exists! What a shame!