Solved

Unable to access prepaid account on t-mobile.com since Oct 12

  • 15 October 2018
  • 32 replies
  • 3221 views


Show first post

32 replies

The bands used would have nothing to do with T-mobiles website not working correctly, plus that is always done at work or home, directly connected to the internet.  I do not have a phone through T-mobile, I have a mobile hotspot.  The hotspot works fine at least 90% of the time, always has a very strong 4G signal.  Sometimes it will only connect at the very slow "EDGE" speed following rainy weather and this happens at the exact same locations with normally strong 4G signals, so that problem is not the hotspot.

Glad to hear that.

Unfortunately, I only have one device on one account.

Well, this is new.

Given the problem is having multiple accounts on the same email, this makes total sense to fix the bug Tmobile introduced which they don't seem like they will correct.

BTW do you have the direct contact number for that person at tech support who contacted you? Thanks.

I've experienced the same problem BUT having 2 accounts with the same email was NOT the case. I was using a bookmark I'd made directly to the login page from a long time ago and even thought it did allow me to login, once I did I'd see nothing but mostly blank screens, perpetual spinning page load icons or an error message depending on which page I was trying to access. This happened in every browser. What solved it for me was to clear the browser history/cookies/cache and then go to https://prepaid.t-mobile.com/pay-as-you-go and click on MY T-MOBILE in the upper right. Logging in from that page worked and I finally started seeing my account info. Hope this helps some others.

For whatever reason everything started working again...until today. Now the whole process has changed, the screens are different and I have no way to add more data. Very frustrating!

I created a new post, with screenshots.

I'm having the same problem since we ported our numbers to T-Mobile prepaid at the beginning of this month. It's getting pretty frustrating and we may switch again if it's not fixed.

They supposedly escalated my case, but the 3 business days have come and gone without hearing from them.

If they can only fix it by separating your account, do you still get the multi-line discount?

This is what I get when I log on. Switch account is not available either.

Reply