Unable to access prepaid account on since Oct 12

  • 15 October 2018
  • 32 replies

Ever since Friday October 12, 2018, I've been able to complete the online login on to access my prepaid accounts, it worked fine prior to that. On that day after I logged in I was greeted with a message saying my password was too old and it forced me to change the password which I did. After logging in successfully with the new password, as usual I get the "Select account" screen where I select prepaid number I want to manage as I have multiple prepaid numbers on this account, the link to that page is:

After selecting a number I get the message: "We are currently having trouble with your request. Please wait a few minutes and try again."
I get the same message if I select the other numbers as well. So it appears whatever changes they made to the site last week didn't account for prepaid accounts with multiple numbers associated with the login as I can't complete the login anymore. Can someone please forward this to the appropriate department at T-mobile?


Best answer by magenta7072155 12 December 2018, 05:47

View original

32 replies

Glad to hear that.

Unfortunately, I only have one device on one account.

Well, this is new.

Given the problem is having multiple accounts on the same email, this makes total sense to fix the bug Tmobile introduced which they don't seem like they will correct.

BTW do you have the direct contact number for that person at tech support who contacted you? Thanks.

I've experienced the same problem BUT having 2 accounts with the same email was NOT the case. I was using a bookmark I'd made directly to the login page from a long time ago and even thought it did allow me to login, once I did I'd see nothing but mostly blank screens, perpetual spinning page load icons or an error message depending on which page I was trying to access. This happened in every browser. What solved it for me was to clear the browser history/cookies/cache and then go to and click on MY T-MOBILE in the upper right. Logging in from that page worked and I finally started seeing my account info. Hope this helps some others.

For whatever reason everything started working again...until today. Now the whole process has changed, the screens are different and I have no way to add more data. Very frustrating!

I created a new post, with screenshots.

I'm having the same problem since we ported our numbers to T-Mobile prepaid at the beginning of this month. It's getting pretty frustrating and we may switch again if it's not fixed.

They supposedly escalated my case, but the 3 business days have come and gone without hearing from them.

If they can only fix it by separating your account, do you still get the multi-line discount?

This is what I get when I log on. Switch account is not available either.

I have a legacy prepaid account. Unable to login for the past  months. I have changed my password 3 times, I have tried security questions. I have called customer service for a merry go round of useless fixes. Customer service said to examine problem on their end and report back, which never happened. I appears that legacy prepaid contracts are not wanted by Tmobile. I am unable to log in to and am frustrated by them.  I have had no problem before this recent round of frustration after the combo with Sprint.