[Off Topic] Purchase site and T-mobile question Xperia 1iii

  • 24 August 2021
  • 8 replies
  • 1646 views

Badge

So, at this point, I'm quite set on getting the Xperia 1 iii. I'm a T-mobile subscriber, and I've been getting conflicting information on whether this phone supports VOLTE and internet calling. I'm aware that the phone supports sub-6 5G and band 71, which is fantastic.

Also, it appears that Focus Camera, B&H, or Adorama are the three most viable alternatives for me to purchase. (Best Buy has been out of stock for a long time, and based on my experience with them, they may never restock). I was curious if anyone had any experience with the three websites mentioned.

I'm a premium customer, and I've travelled through a region where there is no AT&T service, which is where cricket Mobile is. When I went to work this morning, I uploaded it. I can tell which towers I've visited on the maps because the last one I saw was today rather than another nearby, but there is no signal trace on the roads where I travelled. Is this a flaw? Or is my upload still being processed by the site?

Also, on the Cell mapper site, I'm showing up on AT&T towers for the 4G signal, but no HSPA or HSPA+. On the map, there are no towers in this region, however there is where I have service. What's the best way for me to see who I'm linked to? Although there is a T-Mobile tower nearby, it is now teaching me how to find it.


8 replies

I have the Xperia 1 III on T=Mobile and it does support VOLTE.  Unfortunately at this time it doesn’t have VOWiFi which is a bummer.  Almost all the T-Mobile MVNOs do support VOWiFi so it is not the phone.  I purchased mine directly from Sony as the price was the same, the pre-order bundle was the same, and the ship date was the same.

It works very well on T-Mobile except for the lack of WiFi calling.  I don’t seem to get 5G at my home but I don’t have to go far before I do pick up a 5G (NR) tower.

Badge

My Xperia 1 III US does not support WiFi Calling, 5G SA, or VoNR on T-mobile.  T-Mobile also sends incorrect APN settings when you put the SIM card in.

My Xperia 1 III US does not support WiFi Calling, 5G SA, or VoNR on T-mobile.  T-Mobile also sends incorrect APN settings when you put the SIM card in.

What are the correct APN settings?  So at this point would you say the Xperia 1 iii is a waste of time?  I also thought about buying one, but after reading your comments I’m not sure anymore.  

What model version of the phone are you using? I’m trying to figure out the same thing. I ordered the xq-bc72 version but this is supposedly the version that doesn’t use US 5G bands and the 4G can be shoddy. From what I’ve read. The xq-bc62 version is what I’m finding to be the US version. Though, I’m getting a lot of mixed responses. The xq-bc72 version seems to work fine on 4G in major cities but still does not have VoLTE support, and the 4G seems to cut out randomly. Some people seem to be alright with the xq-bc72 version but I’m not so sure I should risk it and just get the xq-bc62 version. 

Badge +2

I have the Sony Xperia I iii XQ-BC62 and so far I know VoWiFi, VoNR, VIsual Voicemail, and  built in video calling doesn't work. I've contacted both Sony / T-Mobile about VIsual Voicemail not finishing setup both Sony / T-Mobile are blaming one another. I'm forced to use the terrible T-Mobile VIsual Voicemail app that doesn't actually work correctly either, it glitches like crazy. I would love for wifi calling and visual voicemail to work at minimum. 

Badge

I don’t know what happened, but the XQ-BC62 is no longer working with T-Mobile.  It appears to be connected but it has no data, calls, or texting.  Turning off 5G sometimes helps, but not always.

I noticed this a few days ago and it’s getting worse.  Sony Support said that only Verizon is supported, end-of-discussion.  I’m trying to get a refund.

So does the  xq-bc72 work on T Mobile? I was about to order one but if it doesnt have network compatability is just blocked its a waste of time and money.

We just got the pro i.  WiFi calling does not work but volte does.  We had issues with mms after sim install, we went into access point names and did restore to default.  Once it reset that, the issues disappeared

  Still no WiFi calling but no more MMS issues or anything.  It's not a TMobile issue, they don't black list Sony phones, it's a Sony issue.   

Reply