Question

Website Login --- Typically Broken, Why?


Userlevel 1
Badge

Google Chrome. Microsoft Edge.  For what seems like years now the ability to log into my business account is hit or miss. SO FRUSTRATING!  I love T-Mobile but this is ridiculous.

For a while I could clear my cookies (which I shouldn’t have to do) to resolve the matter.


Lately, I give my user, then my password. All seems well until the only thing that shows up on the next page is the footer. The address says it’s my Dashboard page. But nope! Reloading gives an error message. Back button occasionally opens my Dashboard page. But when it does take me to the Dashboard I click “Shop” and get “500 Internal Server Error”.  All I want to do is buy two phones without going to the store or spending forever talking to someone on the phone.

Why is it so hard to get your website to work?

Can we get John Legere back to drive home permanent fix?


17 replies

This issue has just about caused me to switch providers, and I’ve talked to someone in the President’s office, to no avail.  I’m quite sure they never use their own site.  Over time, I’ve used every major non-Apple-based browser, & have the same issues repeatedly.  The site functions like something from mid-90s Internet.  It’s obviously not a priority:  All the mobile companies are in competition for subscribers, & at this point, wifi calls are making coverage less of an issue, so some stasis at churn & burn is likely to win out.

bringing this back - started with T-mobile at the end of last year - never have been able to get consistent access to the website - error after error

Tried Chrome, Edge and just downloaded Firefox… same errors - crazy for a big company to have an unreliable website??

Userlevel 7
Badge +15

I literally logged in and paid mine yesterday afternoon through Edge on Windows 11.  

I have been on tmobile once or twice before and all of the account sign up and logins are broken, I cannot believe a major corporation can be run so poorly, but what do they care about the peasants and no I am not joking, that is why this is allowed, they have enough money to sit back and laugh at us

Badge

No, that URL DOESN’T work. First attempt resulted in a “Service Unavailable” error and no verification code to enter for access. Second try halted at a verification web page, took about 20 minutes sitting at that screen, then finally got both text messages with verification codes. Next screen was a show-stopper, T-Mobile will take 48 hours or more to “verify” my account access and get back to me. That’s it.

Wow, that was great advice. ALL of their web portals are either down or intermittent.

Just got off the phone with customer service. Rep said that they’re starting to get a lot of complaints about this, had no estimate for resolution.

Okay, I got off the phone with TMobile for Business support, and it appears (based off of what we tried) that if you explicitly try to log in via https://tfb.t-mobile.com/ it’ll actually work - you’ll get the same login process, but ultimately it directs you to the proper site (so now I have this month’s billing info, yay!). So they may just have a recurring issue w/r/t redirecting from t-mobile.com or my.t-mobile.com to tfb.t-mobile.com depending on how and where you try to log in. Which is irritating, but at least can be worked around by going directly to the proper site.

Hope this helps.

The “back button trick” stopped working when I tried this month. Now I just get “Cannot GET /restrictedaccess” when I try it.

The cell app still doesn’t work.

This should be embarrassing for a Tech company but apparently TMob just doesn’t care. So frustrating and has forced our company to switch carriers. Too bad b/c I liked the tax&fees included but the writing is on the wall, TMob is headed to the bottom… fast.

I have this same issue!!!! 

Same here. Beyond frustrating.

 

Same here. Edge, Chrome and Mozilla only render a footer page and pushes you back to login again. Tmobile phone support (horrible….) said: “it’s a known issue with the website.” Like, it’s obsolete and doesn’t get any attention. I can get to my account information the their cell phone app though. Maybe it’s Russian hackers f’ing web page  things up again. 

I can’t even get there with the phone app. This is completely absurd. Six different attempts across three different platforms all turned up empty and have been doing so for the last month and a half or more.

Desktop web browsers (tested: Vivaldi on Win10, Firefox on Win10, Edge on Win10, Vivaldi on macOS, Safari on macOS), after login, all just show the footer page. Attempting to access it via the cell app gets me an error message as follows: “Webpage not available” - “The webpage at tmoapp-web://https://my.tmobile.com/billandpay could not be loaded because: net::ERR_UNKNOWN_URL_SCHEME”

EDIT: Hitting the Back button helped this time around, but hadn’t accomplished anything last month.

Same here. Edge, Chrome and Mozilla only render a footer page and pushes you back to login again. Tmobile phone support (horrible….) said: “it’s a known issue with the website.” Like, it’s obsolete and doesn’t get any attention. I can get to my account information the their cell phone app though. Maybe it’s Russian hackers f’ing web page  things up again. 

I use Edge and Firefox and it is always broken for me. Half the time, I can’t log in at all and right now I can log in and see my account details but when I try to do something like pay a bill or view users I get an error from the web app and it kicks me back out to the log in screen and then won’t let me log back in because of a refer mismatch. I am going to move my business off of t-mobile because I can’t reliably track expenses with this broken site

Userlevel 7
Badge +14

I also use Edge at work at haven't had a problem using it. I actually just ordered a piece of equipment while using Edge.

Userlevel 7
Badge +15

I pretty much exclusively use Edge to access all of T-Mobile’s sites, including my account, and paying my bill.  I haven’t ran into any issues in quite a long time.  

Userlevel 1
Badge

Good to know, thanks.

 

Of course, it should work on Chrome and Edge, too.

Userlevel 7
Badge +14

 No problems using Firefox.

Reply