Solved

Why am i not getting good service with Pixel phones?


Badge

I have a home business and have used a Pixel 2XL and now a Pixel 4a. I get terrible service. I sometimes cannot make calls, send texts, don't receive texts... Yet people can call me, although sometimes the call is dropped. Overall, my service is totally unreliable. However, my husband has a Samsung phone and has perfect service here. My daughter and my friends visit with their non-Google phones and have reliable service here.

I buy my Pixel phones directly from Google for the TMobile network. I have been dealing with the issue for 3 to 4 years since starting with T mobile and every timer I have brought up the issue with tech support, I get a different diagnosis. I was pushed into getting a Samsung phone ( TMobile paid half) but I went back to Pixel because I prefer the Pixel phones. Still, I have to deal with sometimes not being able to communicate! 

 

Any ideas on why this is happening?

icon

Best answer by Jonalisa 3 May 2021, 16:26

View original

12 replies

You're not the only one. I work from home, currently have the P5, but I've owned the original and Pixel 2XL.  Both had issue on TMobile network where the signal isnt full bars.  Yet the iPhones in the house don't have any problems, even on a weaker signal.

 

Same issues, need wifi calling on at times to receive calls, but then having that on and being connected to cellular, I receive calls where I can be heard, but I hear nothing.  Or text messages come late or not at all.

 

I'll try the new apn settings. I've already been to T-Mobile Store support where they switched out my sim for a new one.  No change. 

 

But I do appear to potentially live on the edge of signal area, at least that's how my Pixel 5 behaves. 

Hey there! Sorry you’re having issues with your Pixel phone on the T-Mobile network.  Have you checked your APN settings to make sure everything is correct?

Settings > Network & internet > Mobile network > Advanced > Access Point Names

  • Name: T-Mobile US
  • APN: fast.t-mobile.com
  • Proxy: <Not set>
  • Port: <Not set>
  • Username: <Not set>
  • Password: <Not set>
  • Server: <Not set>
  • MMSC: http://mms.msg.eng.t-mobile.com/mms/wapenc
  • MMS proxy: <Not set>
  • MMS port: 80
  • MCC: 310
  • MNC: 260
  • Authentication type: <Not set>
  • APN type: default,supl,mms,xcap
  • APN protocol: IPv4/IPv6
  • APN roaming protocol: IPv4
  • APN enable/disable: <greyed out unless there are multiple APNs>
  • Bearer: Unspecified
  • MVNO type: None
  • MVNO value: Not set

Thanks so much! Was getting awful reception on my Pixel 5a. The only setting I saw different on my existing APN was that APN Protocol was set to IPv6 only. I created a new APN with the settings above, and switched that to active and my signal improved immediately!

Badge

“If neither one is selected, I’d try tapping on the T-Mobile US LTE”...

Not sure this matters, but nowhere does my phone say LTE, it only says TMobile US

Badge

Well, that is the phone I currently have. 

And when it comes time for the pixel 6, I'm willing to bet TMobile won't offer it. This has been a problem for some time... They don't offer the new Google phone and then I have to buy it from Google. And this is the cycle I'm in. I don't know why I get poor service when other people don't.

Userlevel 4
Badge +10

I understand brand loyalty! I’m saddened by the fact that LG is no longer making smart phones because they were my go-to!  I know you already have a Pixel 4a, but I didn’t know if you were aware that T-Mobile does indeed sell Pixel phones.  At this moment, the only one we offer is the Pixel 4a 5G, but it is there as an option.  

Badge

Thanks, I followed all your steps and had to add the new APN and all the manual settings.

When I reboot the phone and go back into the Access Point names, again, nothing is checked. I check T-Mobile US/fast.t-mobile.com but when I go back in, it doesn’t stay selected. I first thought this was an issue with T-Mobile and Pixels but I have talked to many users on Reddit for whom this combination is not a problem.

I have to buy my Pixels from Google because TMobile never carries them, but Google says they should work with TMobile. Idk.

Userlevel 4
Badge +10

If neither one is selected, I’d try tapping on the T-Mobile US LTE then power cycle the phone.  Otherwise, on the APN screen, you can add a new APN (either press the + or tap the three dots in the upper right hand corner and choose “Add New”) then manually enter the settings I listed above.  (Those extra settings won’t show in the default APN, just some optional settings that I’ve noticed make a difference)

Badge

@magentatechie Any help with these settings?

Badge

Also, of all those settings, my MMS port is not set, APN Protocol is IPv6 only

Badge

Thanks for the help!

When I go here: “Settings > Network & internet > Mobile network > Advanced > Access Point Names” there are only two items on the page:

T-Mobile MMS (TMUS) and T-Mobile US (fast t-mobile.com) and neither are checked!

 

 

Sorry, premature post!

So if I click TMobile US (fast t-mobile.com) everything on that page is greyed out.

Badge

Thanks for the help!

When I go here: “Settings > Network & internet > Mobile network > Advanced > Access Point Names” there are only two items on the page:

T-Mobile MMS (TMUS) and T-Mobile US (fast t-mobile.com) and neither are checked!

 

 

Userlevel 4
Badge +10

Hey there! Sorry you’re having issues with your Pixel phone on the T-Mobile network.  Have you checked your APN settings to make sure everything is correct?

Settings > Network & internet > Mobile network > Advanced > Access Point Names

  • Name: T-Mobile US
  • APN: fast.t-mobile.com
  • Proxy: <Not set>
  • Port: <Not set>
  • Username: <Not set>
  • Password: <Not set>
  • Server: <Not set>
  • MMSC: http://mms.msg.eng.t-mobile.com/mms/wapenc
  • MMS proxy: <Not set>
  • MMS port: 80
  • MCC: 310
  • MNC: 260
  • Authentication type: <Not set>
  • APN type: default,supl,mms,xcap
  • APN protocol: IPv4/IPv6
  • APN roaming protocol: IPv4
  • APN enable/disable: <greyed out unless there are multiple APNs>
  • Bearer: Unspecified
  • MVNO type: None
  • MVNO value: Not set

Reply