How do I hook up my external hard drive to my Cellspot Router?


    I recently got the TM-AC1900 wi-fi Cellspot Router.  I want to hook an external hard drive up to it that I can access from my computer and then use to create a paperless filing, system, store music, perform back-ups etc.  If I plug the hard drive directly into the USB 2.0 port on my laptop, I can access the hard drive just fine.  It shows up as an F: drive just like I am used to seeing it.  However, if I plug the external drive into the USB 3.0 port on my router, it does not show up on my computer and I cannot figure out how to access it.  I am running Windows 7 64 bit.  I have never connected a hard drive via my router before, so I am not sure if I just don't have it connected correctly, if there are compatibility issues between the router and hard drive, or if I need to access the router through some other means.  Apologies if this is a simple operation, but I am new to this.  Don't know what it is supposed to look like when it is hooked up correctly, so I don't know where to start troubleshooting.  Thanks for any guidance.

      All replies

      • drnewcomb2

        There are some posts on this forum that discuss the details.

        What I've found is that the USB 3.0 port understands USB 3.0 and the USB 2.0 port understands USB 1 & 2 and never the twain shall meet. YMMV. There is also a setting in the WiFi area that seems to turn the USB 3.0 port on and off. After you get the HD connected, you have to select a "USB Application" to apply to that port. I have a 3 TB USB 3.0 HD attached as both a SMB file share and as a DLNA media server. My Roku box sometimes has difficulty finding the DLNA server and doesn't always see newly added media files. The USB 2.0 port has a HP printer attached.

        • peanutbutterfish

          I am still not able to access my external hard drive when connected to my CellSpot Router.  I contacted ASUS technical support.  The ASUS tech support guy logged onto my router and said the router and hard drive were set up correctly.  He said T-Mobile needs to send out a firmware update to enable accessing of external hard drives.


          Evidently ASUS has its iCloud that fulfills this purpose, but T-Mobile crippled the router so this function is not present on the TM-AC1900.  I would think AiDisk would serve this purpose, but I set up and log into the LAN FTP link and the Internet FTP Link and just get blank screens.


          I called T-Mobile technical support to tell them what the ASUS tech told me.  The T-Mobile tech support person just sent me the directions on how to upgrade the firmware.  She had nothing to say about whether this router is even able to accommodate an external hard drive and whether a firmware upgrade would solve the problem.  Once she found out my issue did not involve wi-fi calling, she seemed pretty eager to get off the phone.  It does appear that I am running the latest firmware (


          This issue seems to have fallen through the cracks from a technical support standpoint.  ASUS is not able to provide technical support for T-Mobile's modifications to the router.  T-Mobile tech support indicated to me they are not able to support me on this issue since it does not directly involve wi-fi calling.  It does, however, affect whether I decide to stay with T-Mobile as a customer.  Obviously the "free" router was a huge perk, but that perk appears to have been illusory.  At this point, I have spent so much time troubleshooting this router and have still not resolved the issue that I question whether it was worth it to get it for "free".  I guess you get what you pay for.