Issues with losing connection to network since September update??


    Has anyone else had issues with the "radio" since the last update to G935TUVU4APIA??  I know John Legere had announced late August we would be getting an update for the radio to activate the 4X4 MIMO and 256QAM in the S7 and S7 Edge so wondering if there is a glitch in the firmware.  Since the update it has happened few times when I notice the phone has been quiet or I try to do something and it says it is in "offline" mode.  It shows bars but no E, 4Glte, 4G etc and when I go to service mode it shows what Band it is seeing but says "idle".  I have to go into airplane mode once or twice for over a minute or two and that seems to kick the radio back on and it is fine again.


    Curious if anyone else has seen anything "hinky" with the radio since the update.

      All replies

      • tmo_lauren



        I have seen a host of other issues with the update (are you getting push notifs? I saw someone else say they were not) but I haven't seen this one mentioned yet.


        I am going to let this sit a moment and see if anyone else chimes in while also cruising out internal forums to see if there are other examples for me to pass up.



          • makarios

            Got the update OTA last night, and haven't really noticed any difference either way. The coverage in my home is not really the greatest to begin with, but is still usable.


            I'll watch this thread (and my phone) to see if any new information comes to light.

            • li2le

              I started having the same issue after updating. My now only have 4G and sometimes 3G, which never happened before the update. sometimes, it says emergency until I restart the phone.


              I think this update have some glitches.

                • theartiszan

                  Is it just in certain areas? I don't seem to have any issue with mine. Does it still happen after restarting the phone?

                    • stevetjr

                      Yes and even though I did the update via switch I cleared the cache out.


                      If I restart it connects to the network fine. Usually just one or two

                      cycles of airplane mode will get it reconnect. It just seems to need

                      something kick the radio.


                      When it isn't connecting to the LTE (or any service it has signal, but

                      service mode shows TX (transmit) as 0 and says idle.


                      I know John Legere had said that this update would have a radio update to

                      support the 4x4 MIMO and 256 Qam in it and I do recall seeing a few similar

                      comments of the same issue on some Note 7 threads. One would have to guess

                      since the Note 7 had those features already and the S7 could be upgraded to

                      it plus the Note 7 is technically very similar to the S7 they probably have

                      the same radio.

                        • stevetjr

                          theartiszan see this is from the service mode when it seems to disconnect from network, it has signal but it will just stay in this "idle" state.  I should note it does this on Band 4 also just happens when I got home and noticed that it had done it again and at my place I only have Band 12 but it will show the same thing just Band 4.  In this screen shot it shows no service bars but I had attempted the airplane mode cycle but when it came back I got the x no service, cycled the airplane mode again but this time left it in airplane mode a bit longer and it came back to 4Glte.



                            • tmo_lauren



                              I'm keeping an eye on this and checking in some other places in the hope I get a better idea of what is going on and who needs to get the info.



                              • jgreen1280

                                I can also confirm the same behavior.


                                My phone, my wife's phone, my brothers phone, each of my sisters, all have this issue. Generally, everyone who has disclosed this issue to me have all said the only resort is to reboot, which resolves the issue until it happens again. Airplane mode does not help.


                                Wednesday, this happened to me about 7 times, as I entered and exited the data center I was working at. Any time you enter the elevator or pass through the man-trap, signal loss occurs.

                                As a result of this happening over the past few months, and Wednesdays influx of the behavior, I did find a way to resolve without reboot. I haven't nailed down the exact sequence of which step resolves, however this is what I do:

                                1. *#0011# to validate that I am actually connected to the network

                                2. Open wifi calling config. If disabled, I enable (not connected to wifi, but may also work while connected to wifi)

                                3. After each of the following, I wait about 5 seconds before toggling next setting:

                                - Toggle settings beginning with WiFi calling only (Never Use Cellular Network)

                                - Then switch to WiFi Prefered

                                - Then switch to cellular preferred


                                If that doesn't work, I basically disable wifi calling, toggle settings, re-enable and toggle again, using another sequence if I don't see results.


                                In each of the last 5 times this has happened to me, some combination of these settings cause it to begin working again and signal indicator suddenly comes back.


                                With that said, I think there may be some issue with the IMS handoff between wifi calling and LTE network, regardless of wifi calling use or not. Some times this issue happens simply driving down the road.


                                - So, add about 7 more devices to this list of devices with issues, as my entire family has reported this issue over the past few months.

                      • gregt1

                        Having the same exact issue and it's infuriating! I had it happen 4 times this past Sunday while out and about ... it's very sporadic and I can't seem to duplicate it. I did a factory reset in hopes it would help but it is still occurring (actually did the reset Friday evening and Sunday was terrible). I even had a situation where it showed I had 4G LTE but nothing would connect.

                        • gregt1

                          Well, I was on my way into work and was thinking to myself, boy I haven't had this issue since Sunday ... guess I jinxed myself LOL Took some screenshots in hopes they may help.



                          • spstreckfus

                            Accidentally posted this on a different question. Having the same issue after the update. Phone is basically wifi tablet now. Tried resetting network settings, resetting APNs to default. Once the phone loses its connection, it can never reconnect to the network. It just says (No Service) or (Searching). It sees the T-Mobile network if I search for networks, but if I try to select it, I get the "Unable to register on network" error. Sometimes turning the phone off and back on again fixes it, but not every time. Airplane mode doesn't seem to fix it at all. One other thing I've noticed is that WiFi Calling no longer works at all even when I have previously connected to the LTE network fine. It stays greyed out as "Enabling". I haven't done a factory reset at this point, and would seriously hope that I don't need to do so...

                            • stevetjr

                              Probably jinxing myself but it has been almost a week with out it getting "hung".  I have found with the airplane mode trick that you have to leave it in airplane mode for a bit and even then sometimes a second try always gets it. Once time I had to restart it but it connected right back.

                              • spstreckfus

                                It's still happening for me. I've tried all of this. Every single day it loses the data connection, saying (No signal) even though I have 5 bars. Today has by far been the worst. It's been 3 hours now. Tried toggling airplane mode on and off around 20 times, have restarted the phone 3 times, and even tried just powering it off and then back on a few times. Nothing's working. This is extremely frustrating. The phone was rock solid until that update so I know without a doubt that's what's caused this. At this point, I have no idea what to do.

                                • gregt1

                                  Nothing on this?!? I find that utterly ridiculous... this is a significant issue for those experiencing it and needs a solution ASAP!

                                  • gregt1

                                    I used my JUMP! to get an iPhone 7 Plus - problem solved for me! I just got so sick of carrier and manufacturer interference with Android! Love the openness and the whole having choices stuff, but when a carrier update cripples a device, and said carrier does nothing about it, then enough is enough! Not saying Apple is perfect, they are FAR from it, but at least they do their own "housekeeping" ... no waiting around for a fix while carrier blames manufacturer/manufacturer blames carrier BS! And don't get me wrong, no Apple fanboy here ... this is my very first iPhone EVER after years (7+/-) spent on Android and actually bashing iPhone!



                                      • theartiszan

                                        Well it is all the manufacturer. The carriers don't develop the updates at all. They do some basic testing on a small sample of devices to see how it works with the network and verify it is good to go. They most likely didn't experience this problem, just like i don't have any issue with mine either. Problem is, when something happens it needs to go back to the manufacturer to try and fix the issue. But again, this starts the process all over again and takes a long time get another update to fix it for those affected. This is also one of the problems I have with Android and is really only better if you are on the Nexus line of phones


                                        Be careful as the Apple series also have their own set of issues people are concerned about. The modem chip that Apple decided to use for the T-Mobile and at&t version of the iPhone 7 series is notably slower than that of the Qualcomm modem used in the other variant produced by Apple. This did get a number of power users pretty upset about that.


                                        • stevetjr

                                          Well you know while this was an update for T-Mobile as with all updates

                                          they are actually done by Samsung, T-Mobile doesn't do any of the



                                          In this case it is actually a radio update to take advantage of a feature

                                          only T-Mobile has at this point which is 4x4 MIMO and 256QAM. So this could

                                          actually be a Qualcomm issue with the drivers, Samsung issue integrating it

                                          or a combination of both. I guess one disadvantage of leading the way. Heck

                                          Apple was almost a year behind the Android manufacturers in finally

                                          supporting Band 12 and years for WiFi calling. Having no competitors Apple

                                          can get around to whenever they want whereas Android manufacturers are

                                          competing with each other which drives innovation. Not to mention Apple

                                          antennas still are horrible, just look at all the complaints about coverage

                                          on this forum and most are iPhone users.


                                          I agree it's frustrating, but I can tell you when it's working (which for

                                          me is most of the time) the new radio is fast. I am seeing while not

                                          double, significant bumps in speed. I have a location that I like to test

                                          my relative speed because this spot has a view of a tower about 1/2 mile

                                          away and is pretty consistent with speed across all my devices right around

                                          70MBps and now after the update I am hitting 110 to 120 on it with the same

                                          phone. Knowing Apple it will be the iPhone 7s or 8 before they put the new

                                          radio in it. Not to mention it turns out the AT&T and T-Mobile iPhone 7

                                          from recent articles has a different modem in it and the Intel modem turns

                                          out is significantly slower than the Qualcomm modem the rest of the iPhone

                                          7's have in them.

                                            • tmo_lauren

                                              Sorry for the delayed jump back in!


                                              I have gone ahead and forwarded this info on to the content owner who handles Samsung and am waiting to hear back, if I don't get anything by the end of the week I'll send another follow up.


                                              As has been mentioned, we don't develop the updates, so even when I do get a response, it's not going to be something we as T-Mobile can immediately begin work on, it's going to have to be something on the manufacturers side. Which, I totally get is pretty lame, but also not something we can change.



                                                • johnzz4

                                                  Same exact thing for me Lauren.  I've had countless calls into tech support when I had the Note7 and now with the S7 Edge.  Loses connection to network though there are plenty of bars.  Seems to happen during transitions between LTE and 4G but don't quote me on that.  A restart will take care of it for a while but always returns.  Glad to know others are experiencing this.. I've been suggesting a firmware bug, but I've been regularly reassured that the S7 Edge doesn't have any known network connection bugs.  Apparently the issue is that it's not known.. ;-)  Please keep us posted.

                                            • roald

                                              Since the update:

                                              I get the "Emergency calls only" message pop up from time to time, but it seems to recover after a short while.

                                              This happens while I see good signal "full bars" 4g or LTE.

                                              My main issue is that it no longer automatically switches to and from WiFi Calling. This is a critical thing for

                                              me since I have no T-mobile signal in my office and rely totally on WiFi calling during the day.

                                              I'll get it working by stopping wifi calling and turning it back on again, but every time I walk upstairs or any where
                                              that I get a signal and connect to 4G / LTE, the moment I go back downstairs, I'm dead in the water and have to remember to stop and restart wifi calling again.

                                              I support mission critical applications for Public Safely with the city, this is unacceptable..... 


                                              • agb

                                                A possible workaround?


                                                From a stock S7 Edge: activate Developer Options

                                                Turn on:

                                                     Aggressive Wi-Fi roaming scans

                                                     Keep Mobile data turned on


                                                Tried this last night and so far, the phone hasn't disconnected from a network, and today I was in the usual places where it does. Needs more testing, but it might be an option


                                                Note: if you restart your phone, you'll need to reset at least the Aggressive roaming scans, as it seems to turn itself off.

                                                • brodarb0072

                                                  So, I noticed this issue with my phone about a month ago and remember power cycling my phone a few times. I'm know up to having to power cycle 3-4 times a day. It would be nice if someone could fix this. At first, I thought it was just my phone but then a coworker who has the same phone and service provider( T-Mobile) has been having the same problem. I love Samsung and their phones but really want this fixed. Please help!

                                                    • theartiszan

                                                      Out of curiosity, do you notice this is some areas more than others? I haven't had problems with mine at all. There was one bug in the beta that caused issues switching from band 4 to 12 LTE but Samsung did fix that.

                                                      The other thing I can think of is that maybe something was not applied correctly during OTA. Maybe you can flash the software again using a computer and Odin.

                                                        • jgreen1280

                                                          Everyone I know with a T-Mobile Galaxy S7 Edge is experiencing this issue, some more than others. We are in the Chicago and Ottawa, IL markets. We do not have band 12 here yet.

                                                          If you have not had the issue, turn on wifi calling, set phone to wifi preferred and allow your phone to connect via wifi calling. Now, switch back to wifi preferred, and turn wifi off, leaving wifi calling enabled on cellular preferred. With that, now pass through an area where you may lose signal for a few minutes. After coming back into a coverage area, if you have signal, then your good, if not, try again. You will see the issue. I find it hard to believe that dozens of phones having this issue and it would be completely isolated to those phones.

                                                          In Chicago suburbs, I see the issue less frequently because I am less likely to lose signal. However, I do experience the issue when taking elevators, as I lose signal in elevators a lot.

                                                          This weekend, my wife had to reboot several times when this continued to happen. For her, we were in the car, and the phone was on the seat in her lap, which caused signal loss. One of those times, I happened to be with her and was able to resolve without a reboot, using the method I posted in page 3 of this post. I took a video, so I could upload to YouTube, but the video is very unstable and blurry, since she was driving while I was recording it.

                                                      • kdwhite

                                                        Just wanted to chime in here with what sounds like a similar issue and what's worked for me and not:

                                                        Samsung Galaxy S7 - 6.0.1, G935TUVU4APK1.  No mods, no root, no funny stuff. Just a stock G935T. St. Louis MO Area market


                                                        Typically lose all data/network  (Bars with X) in transition between low signal areas or between wifi and 4G. (inside a building to outside, interstate travel, etc.).  I had already noticed the transition between towers was terrible and in many cases I could recover quickly by going to


                                                        Settings -> mobile networks -> network operators -> select automatically.


                                                        Unfortunately when that doesn't work my only option has been to reboot the phone.  Upon reboot i then have to go to


                                                        Settings -> Data Usage -> ENABLE mobile data


                                                        It baffles me that mobile data is turned off when this happens.  Other things I've tried to recover are


                                                        • disable/enable wireless
                                                        • enable/disable airplane mode
                                                        • Under network operators - > Search for carriers and select any available carrier (this never works, even when roaming and no signal in general.  Phone refuses to roam despite data roaming being enabled)
                                                        • clearing cache
                                                        • Aggressive Wi-Fi scans
                                                        • Keep Mobile data turned on


                                                        This issue seems to happen about every three to four days, though sometimes it's more often.  The phone transitions better in weak areas with aggressive scan and keep mobile data on but the other issue still persists.  I'm going to start tracking and reporting it as well as I can using the tmobile app because this issue is getting beyond ridiculous.


                                                        My wife has an identical phone.  We purchased under the BOGO back when the phone was first released.  I know the issue has happened to her a few times but she hasn't mentioned it lately so I might report back with that info if it'll help.


                                                        So, I've seen a few mentions of other things to try in the thread.  I'll also give those a try and if I can come back with any new info I'd be happy to contribute to solving this.





                                                        • ubeguy

                                                          * Definite Radio issues with Samsung devices with the

                                                          J700TUVU2APK6 update on  Galaxy On5 and the J7

                                                          Noticed this directly after the  J700TUVU2APK6 on the On5 the radio would cycle for 10 minutes than lock on to weak 4g signal than  switch to ATT network with full bars since its a higher signal but no technology display i.e LTE 4G or LTE no network access though.  Than it would eventually switch to the good Tmobile LTE signal after 10 minutes but no calls could be made  frozen data arrows no data connect. Troubleshooting via tech support they concluded it was a defective device replacement arrived same exact issue. Family member came to my house with J7 its doing the Exact same! OK strange thought it was network. So since I have a unlocked Moto G4 decided to try that. Works Flawlessly on the T-Mobile network.  Next got the Cell Spot thought that should override the network.  Issue remains. Whats strange is I have only noticed this at my Home! Just very odd.

                                                          • kdwhite

                                                            Since I can't edit my post I'll add the following:


                                                            This has happened twice in the last 4 days at the same location.  I tried the Airplane mode 2x (10 count between each cycle) and that worked well.  First time I've been able to recover without actually rebooting.   Takes longer to cycle the airplane mode than to reboot but lets me keep apps running that, when at the gym, are actively tracking workouts.


                                                            Also verified with my wife that she's having to reboot just about every day she goes to work due to this issue.


                                                            Hopefully we'll get an update soon that fixes this issue.

                                                            • tech1029

                                                              I just stumbled across this post. Add me to the list of victims of this nightmare. I find it happens every time I go to my local costco. Funny thing is that I go with a friend who has the same S7 edge (but I have black and his is gold) on TMO. We both loose service in the store but when we leave he connects right back up but I suffer from everything talked about on this forum.


                                                              I drove 10 miles with it showing no service to a Tmobile store and they tried a new sim but that did nothing. I called 611 and they tried resetting my network but that didn't help. They said next step is a reload and if that doesn't work then a warranty exchange is next but from what I'm reading that sounds like a waste if time.


                                                              I have till March 6th to pull the trigger. What should I do? I really would hate to end up with a refurbished phone with the same problem knowing my phone has been treated with kid gloves for almost a year and we have a software issue.

                                                              • landeus

                                                                I have been having the same issue and I've been contacting Tmobile support for a while now trying to get this issue resolved. I've tried SIM card swaps, factory resets, and eventually they sent me a new phone while claiming that they haven't heard of this issue. Okidoki. Well, the replacement does the same thing. Should I be surprised? Basically this is my issue:

                                                                If by some means I go somewhere where I don't have a signal (I work in a hospital, I lose signal on bottom floors all the time), well, when I emerge back to the world where I should have a full signal...I Don't. In fact, my phone will not even show that I have any connection. I have to restart my phone to get the signal back. It's gotten really  ridiculous. I now have to use another phone because the Samsung is unreliable and I need to be able to communicate. I hope that The damage that it does seem has been caused by an update will be reversible. Till then I'm stuck in limbo with the rest of you. If anything changes I will post.

                                                                • landeus

                                                                  wiping cache and playing around in the developer settings didn't change anything. Still happens.

                                                                  • ubeguy

                                                                    well im beyond frustated  filed a complaint with corp on this s forked out s7 and on5 full payments and the issues continues give them very detailed feedback what is happening with my devices cleared the caches ad intructed earlier in this post  it did not help. I know its not T-Mobile's fault but seriously this is ongoing... as per all our posts. my service is suffering because of the issue.

                                                                      • brodarb0072

                                                                        I'm going to do the same thing. Maybe they will listen if more of us report

                                                                        it officially.

                                                                        • landeus

                                                                          I'm fortunate to have a 2nd phone to be able to carry around now that the

                                                                          S7 is basically a small tablet for the best part of a day and it's no

                                                                          longer reliable for communication over the network. One thing that really

                                                                          gets me and would have me absolutely livid would be if I didn't have a 2nd

                                                                          phone or an old phone to fall back on until the issue gets resolved ( IF it

                                                                          ever gets resolved ). I understand how infuriating it is and the fact that

                                                                          T-Mobile doesn't seem to acknowledge the issue just adds insult to injury.

                                                                          We aren't stupid people. We just want a phone that a phone and

                                                                          is reliable. The network may be reliable for the most part but not for us.

                                                                          We should be compensated for the garbage we are dealing with! As for not

                                                                          being T-Mobile's fault, I kinda disagree. One of the updates is causing the

                                                                          issue and they push those out. My phone never had any issues before and it

                                                                          has been since around September that I've been dealing with this "lost

                                                                          connection/no network" garbage. There should have been a patch by now.

                                                                          Something, Anything. Sorry to rant. I'm just angry for all of us. Hopefully

                                                                          the Nougat update will fix this but I'm not betting any chickens on it lol.

                                                                          I mean they "haven't have seen this issue before" SMH! lol.

                                                                          Have a great day on the meantime. Best wishes to everyone.

                                                                            • brodarb0072

                                                                              Here here I agree!

                                                                              • kdwhite

                                                                                T-mobile should definitely be more responsive about this.  With that said it looks like the Nougat update is imminent. The support site shows the update has been released to TMO and they are currently testing the update on the S7 series.


                                                                                Don't forget, a full reboot shouldn't be necessary.  You can use airplane mode on/off 2x and should be able to get a signal again.  Since I discovered that trick I've not had to reboot which has been a time saver.

                                                                                  • landeus

                                                                                    Thanks for the input. I remember when it first started happening to me, way

                                                                                    back, a T-Mobile rep had me try the Airplane mode trick and it worked for

                                                                                    me...twice lol. I try it now and I haven't gotten it to work since. I've

                                                                                    tried to put it in AP mode, wait a full minute or two only to still have to

                                                                                    reboot. It doesn't work for some but it's because they are probably not

                                                                                    waiting long enough before turning APRIL mode off. Unfortunately,  I'm

                                                                                    stuck with the reboots. It makes me wonder if the software issue might be

                                                                                    frying a component. If it worked before a couple times and then it stops

                                                                                    working to the point that only reboots will work, something changes. Maybe

                                                                                    something with files, I don't know. Like I keep saying, this is my

                                                                                    replacement S7 and it's been having the same issue right out the box.

                                                                                    They're looking into it lololol. Yep. ***I want the next person who

                                                                                    experiences this issue and has seen this thread but hasn't yet contacted

                                                                                    T-Mobile, when you finally do connect them, ask if they have heard of this

                                                                                    issue before. I wanna know how often they lie or try to cover up issues.

                                                                                    Then please post. I have 4 phones on my account and have been pouring $$$

                                                                                    into them for a long time now. I'd love to leave em.

                                                                              • tech1029

                                                                                I saw somewhere maybe back a few post to try safe mode to disable non factory-installed apps  I'm going to give it a shot and head to Costco where I know it will kill the signal. I'll report my results later or tomorrow.

                                                                                • tech1029

                                                                                  Been busy never got to try the safe mode trick yet. Now I see they released the nougat update. Anyone try it yet to see if it helped fix the issue?

                                                                                  • landeus

                                                                                    After the 7.0 update I am no longer have issues with connectivity. Yay! Looks like for now there's no more problems for me to complain about. Hope everybody else has the same experience. Best wishes!!!

                                                                                    • tech1029

                                                                                      My update is in and I have been to all the "dead spots" and all seems well. I use to walk into Costco and have emergency calls only. Now I have 4g on my display. When I walk outside I still have service. I was in Atlantic City in a few casinos where I had no service but as soon as I go outside the service returns. Even the trip down through the New Jersey pines where it was loaded with dead spots was much improved. I do think i am seeing a little more battery usage. I my need to tweek a little yet. My double down casino app crashes every time I open my chive app too.

                                                                                      • nubrian1

                                                                                        I've noticed since that update if I go to a deadzone with my s7e and go back into a covered area my phone will never connect back to 4g. I normally have to activate airplane mode twice to reconnect.

                                                                                        • ubeguy

                                                                                          I haven't gotten any update on the J7 issue continues but T-Mobile saved me they offered a brand nee Iphone SE or LG G5 free of charge no strings and told me to keep the J7 until an updat for the device is rolled out. Took the G5 no issues at all.

                                                                                          • magenta7521885

                                                                                            Hi. I am having this exact problem and just found this thread. Any updates on a fix?