Missing SMS/voicemail notifications when WiFi calling enabled


    My wife has an iPhone 6s plus, and has noticed that when wifi calling is enabled (and T-mobile WiFi shows as the carrier) her SMS messages and voicemail notifications are unreliable. I have an iPhone 6s and have not noticed this problem. Going off wifi or turning off wifi calling resolves the issue.


    I tried contacting support through the mobile app, and they told me that when WiFi calling is enabled you are not expected to get SMS messages or voicemails as you are not connected to the Tmobile network. That does not sound right and is not in line with this article: Wi-Fi Calling from T-Mobile .


    Does anyone have any suggestions on what can cause this and/or how to troubleshoot it? Or an alternate path to T-mobile support who can help investigate?



      All replies

      • tmo_amanda

        Hey, magenta2402680!


        Welcome to our Support Community! This is an odd situation you have here. I'm a proud iPhone owner and SMS' should be coming through while connected to WiFi. Is this a T-Mobile branded iPhone? Also, does this only happen on one specific WiFi network? I know you mentioned that yours is running just fine but your wife's isn't. Lastly, is your wife on the latest software version? It sounds like the device is the issue but I want to rule a few things out first.

        • tmo_marissa

          Hey, magenta2402680, thanks for your reply!
          Regarding the voicemail message waiting indicator, we do have a widespread issue right now with notification delays and failure on iOS devices. I'm glad to hear you haven't experienced this on your phone -- and it's definitely interesting that you guys are seeing a pattern with it occurring while your wife's device has WiFi calling enabled! This issue should be resolved with a future software update that's expected to be released at some point in Q3 (which we're in now, so hopefully not too long of a wait!).
          The SMS issue is definitely another beast. I took a look at the threads you linked to and I can see that these may not really be viable solutions for you -- you can't configure ports on every router you come across. Looking at all the replies on the Apple Support thread, it doesn't look like this user's issue was resolved with carrier settings/provisioning; which kind of makes sense -- newer devices like their iPhone 7 or your 6S and 6S Plus should come working right out of the box with all of the correct settings necessary!
          Is the issue on your wife's phone with iMessages, or SMS sent through the network? Are they just delayed while she's on WiFi/has WiFi calling enabled, or are they totally absent until she disables WiFi calling or disconnects from WiFi, and then they come flooding in? It sounds like this has been ongoing for quite some time; was it like this when you first got the device? What troubleshooting steps have you guys had a chance to walk through thus far?

          Thanks for reading this far! Please let us know how you're doing.


          - Marissa

            • magenta2402680

              IMessages are fine. It's just delayed voicemail notifications and SMS (group messages seem to be where she notices it the most). They don't come through immediately when she goes off wifi calling, but could be hours later. Not sure when it started, it's hard to notice a negative unless you are expecting something. We've restarted the phone, toggled wifi calling on and off (and gone through multiple iOS updates). Since I've posted this she's had wifi calling disabled. Since it seemed to effect her and not me, I was wondering if there could be something with the account that is not setup correctly when wifi calling is enabled?

            • magenta2402680

              Hi, that's the first thing I tried before coming here - you can see what the response was in my original message (that SMS and voicemails are not supported when WiFi Calling is enabled). Can you suggest what I should do differently so that I can get this resolved?

                • tmo_chris

                  So Wi-Fi calling/messaging is something that we support and have the ability to fix. In this specific situation, our tech support teams are going to need to open an engineering trouble ticket for you so that we can take a look at why these messages are getting stuck when the phone is connected to Wi-Fi calling. What I would recommend that you do is, have your wife connect to Wi-Fi calling and have her have a couple friends send her some text messages. Make note of the number that are texting her and the time that they sent the messages. If the messages do not come in, disable Wi-Fi calling and make note of when the messages flooded in. With this information, you can contact our tech teams who can open the engineering ticket with these examples so we can pinpoint the issue.

                    • jahartz

                      I am having the same problem with two different LG phones on the T-Mobile network -- it started over the past week or two...  SMS works perfectly when connected to WiFi & WiFi calling is disabled; but as soon as WiFi calling is enabled two things happen:

                      1) Sent messages just get a spinning sending icon, which eventually fails and goes to retry -- but recipients seem to be getting the SMS message

                      2) No inbound messages are received until the WiFi connections drops or WiFi calling is turned off


                      It does not matter if I use the native messaging app or another messaging app -- I tested several with the same result.


                      PLEASE HELP!


                      This is a big problem!  I have to use WiFi calling because there is no T-Mobile signal anywhere in my house or church except at the windows...

                        • magenta2466327

                          same problem here with my two Nexus 6P.  I hope T-mobile can fix this.

                          • jahartz



                            My home network has not changed:

                            *  Comcast/Xfinity 200+ Mbps download 10+ Mbps upload service (IPv6 connection tested OK)

                            *  Zoom Cable modem (which supports IPv6)

                            *  Google WiFi mesh routers (the problem remains remains regardless if IPv6 is enabled or not on the router)


                            I tried a variety of changes to the default Access Point name profiles as suggested for similar MMS (not SMTP) problems in other T-Mobile discussions, including IPv4/IPv6 and IPv4 APN protocols.  Same result no matter what I changed.


                            T-Mobile support called me back and stated that it's a "known issue" and they they are "working on" -- but no time estimate other than "try again in 24 to 48 hours".

                          • magenta2402680

                            Just to update this thread about my problem - we reset the network settings on my wife's phone and haven't been able to reproduce the problem since (we've re-enabled wifi calling). If we see it again, we'll try the steps above.



                        • jahartz

                          Is there an issue with all older Andriod 4 & 5 Lg phones?  Does T-Mobile monitor these support discussions???

                            • tmo_chris

                              I am not seeing anything specific to LG phones at the moment but I do see an issue with older Samsung phones, specifically the SIII. Please Contact Us again when you have a moment so we can get our engineers to investigate this with you.

                                • jahartz

                                  What is "SIII"?

                                  Is there an issue or ticket number I can reference regarding the older Samsung phone issue?  I was given ticket #17451920 as the trouble ticket for older LG and Samsung phones last night...


                                  When I called last night, I was told that they had "resolved" my trouble ticket; apparently linking it to the global ticket number above.  I spent over 30 minutes on the phone with technical support and a supervisor, and got nothing but I need to keep waiting.  SO FRUSTRATING!

                                    • tmo_chris

                                      Sorry for the confusion jahartz. The SIII is the Samsung Galasy S III (3). I sincerely apologize that you are still having issues with WiFi calling SMS. I know that you said the issue persists on 2 different phones and happens with the default app or a 3rd party app but would it be possible if you tested this again after uninstalling and 3rd party SMS apps you have on the phone? Also, I know your network speeds are great but since this is happening with multiple phones, would you be able to try this on a different Wi-Fi network like at a coffee shop or at a friend’s house just so we can rule out all of the variables? 

                                        • jahartz

                                          Finally got connected with 2nd level support, and have another (3rd) ticket opened yesterday.  Still not working, but I have hope...  The Tech says my problem is not the same as the SIII issue, and seems to be some kind of a network configuration issue.


                                          There has been a slight change -- now when WiFi calling comes on, SMS works for about 3 minutes, then inbound messages stop and outbound messages go into retry, until WiFi calling is off and I am re-connected to cell calling.


                                          The only app that works is T-Mobile Digits -- I tested and removed several other messaging apps with the same result.  I would use Digits, but unfortunately I can't deinstall or disable the pre-installed regular messaging app.  I can't set Digits as the default messaging app either; so when messages come through I get then twice with that set-up (immediately on Digits and again via the regular app when WiFi calling drops and switched to cell calling).


                                          Good suggestion on trying another WiFi network.  I tested it using the guest network at my church and at a store, with the exact same results.  I know SMS used to work at my church.  There is no cell signal there (inside or outside) so I use WiFi calling; and when I forget to turn off my sound notifications everyone in the church knows when I received text messages -- LOL!

                                            • tmo_chris

                                              I am super glad to hear that your issue is being escalated. I have hope that this is going to be fixed for you soon Please keep us updated.

                                                • richnjoisy

                                                  Has there been a resolution to this problem?  I have two Moto G5 pluses on TMobile who do not work inside my home's wifi for texting.

                                                  Once we get outside the home, everything works again. I have tried all the methods listed in this (and other) threads. Occasionally, it starts

                                                  working again but then - stops (such as now).

                                                    • tmo_chris

                                                      Hey richnjoisy,


                                                      The Moto G5 Plus is not a T-Mobile phone so we cannot fully support Wi-Fi calling/texting Are you using Wi-Fi in your home because the T-Mobile signal is not strong enough in your home?

                                                        • richnjoisy

                                                          yes - I live in a dead zone in western monmouth county, NJ.  Interestingly, the phones were working fine until I upgraded from the

                                                          $30 Walmart prepay (X two phones= $60) to the $60 "55 and over" plan. This required a new sim card. After that, text messaging

                                                          failed. I got it working for my phone but my wife's continues to balk (although I got hers to work for about 2-4 days and then poof! not working

                                                          again). Last night, mine failed but then my texts that I had sent an hour earlier went out. I k now this has something to do with being inside

                                                          my home's wifi. I have tried turning on and off wifi preferred, blue tooth, I tried bringing in another texting app, etc etc. I will continue to try and debug this

                                                          but when i saw this thread I thought (hoped) some universal solution perhaps had been discovered.  Again, as soon as we leave home and get outside

                                                          our wifi grid, texts behave normally. Thanks for replying - Rich

                                                            • richnjoisy

                                                              Just an FYI:  I plan to re-think how to best configure the APN in my phones.  There are four choices: TMobile IMS, T-Mobile US 260 LTE,

                                                              T-Mobile US DUN, and T-Mobile US 260 MMS


                                                              Inside these are the Name , APN, along with APN Protocol and APN roaming protocol.


                                                              My problems seems to be impacted by the selection setting of  IPv4, IPv6 or IPv4/IPv6


                                                              I have read recommendations which suggest changing these (some of these conflict of course yuck yuck).  Some suggest I rename "Name"

                                                              too. This means I, who knows nothing, am throwing darts.


                                                              Anyway, I thought I would mention that my phones seem to be impacted (sometimes positively) by what I do there.



                                            • richnjoisy

                                              I added the cellspot and this, indeed, fixed our problem. Now I just need to figure out how to find another ethernet connection for my Smart lights since

                                              the cellspot appears to be using up my only port.