4G LTE Cellspot Issues

joesong01

    I cannot find any information on the error lights that are currently present on my 4G LTE Cellspot. The troubleshoot guide has no option for the following error lights:

     

    POWER: solid green

    INTERNET: solid green

    STATUS: flashing orange

    GPS: solid green

    3G/4G: solid green

    4G LTE: off

     

    I have tried rebooting the cellspot twice but I am still receiving the same error lights. Currently only have 1 bar of service and it is very weak.

     

    Anyone have any solutions to this problem?

      All replies

      • em_just_helping

        Re: 4G LTE Cellspot Issues

        Here is the only page I can pick up

         

        4G LTE CellSpot setup & help

         

        Status lights

        4G LTE CellSpot status lights & ports

         

        That's for 4G cellspot V2

        1 of 1 people found this helpful
        • tmo_amanda

          Re: 4G LTE Cellspot Issues

          Hey, joesong01!

           

          Thanks for posting the status lights - that makes it super easy to figure out what's going on. In your case, your Cellspot isn't connecting to the T-Mobile network.  You'll want to follow these steps to get it connected:

           

          1. Wait at least 2 hours after the device was originally plugged in and set up.
          2. Make sure your Internet connection is working.
          3. Unplug your modem/router and CellSpot.
          4. Plug in your modem and wait for it to power up completely.
          5. If you have a separate router, plug that in and wait for it to power up completely.
          6. Plug in the CellSpot router and wait for it to power up completely.
          7. Contact your ISP to ensure ports UDP 500, UDP 4500 and UDP 123 are opened and place the device in a DMZ.
          8. If that does not work, contact us.
          • ktforever

            Re: 4G LTE Cellspot Issues

            We upgraded our internet and they sent out a new modem. The same exact modem. The cellspot worked flawlessly on the old modem and did not work with the new one. I asked isp if the ports were open 500, 123, 4500... they said yes.. they did not know what a DMZ was. My fix was to login my modem and find the cellspot device, then port forward the UDP 123, UDP 500 and UDP 4500 for the cellspot. I restarted modem and cellspot and bam! service again.