Linelink randomly stops working


    I had T-Mo @Home until the TA hardware died, at which point t-mo upgraded me to a Linelink. The Linelink is smaller, consumes less power, is easier to setup, and ultimately is a piece of garbage.




    I have several reasons. First and foremost, the Linelink stops working randomly. Never during a call, but at some point while idle it loses the connection to T-Mo and cannot place or receive a call. There is no warning - I still get dialtone and the indicator LEDs on the linelink look normal. This happens randomly but regularly - sometimes after a few hours, sometimes after a couple of days. Please don't tell me it's my ISP, my router, the color of the moon, or some other lame excuse unless you can provide solid technical reasons. And on the subject of a network-related issue, I have used the linelink with two different ISPs (Cox and CenturyLink) and two different routers (a Mikrotik RB750GL with Cox AND CL, and a Zyxel C3000Z with CL). It has exhibited this problem with both providers and both routers.


    The next problem is with the voicemail. I have an answering machine and would prefer to use it rather than T-Mo’s voicemail. But even with the T-Mo voicemail completely deleted (according to customer service), a caller will still get the T-Mo voicemail if the Linelink is “crashed” or if a call is in progress and the person on the call does not respond to call waiting in time. Since voicemail is “disabled” I have to way to check these messages. 

Problem number three is call waiting. I have called T-Mo support time after time complaining about this, and they have set the call waiting delay to the longest they can, so they say. When a second call beeps in, I have to respond *before* the second beep or it will go to t-mo voicemail. That’s a couple of seconds from first beep to lost call - not even enough time to excuse myself politely from the first conversation.


    T-Mo - I *require* one of two answers from you. Either that these issues will be fixed ASAP, or that they they will never be fixed and I should find another provider for my land line.

      All replies

      • magentatechie

        Re: Linelink randomly stops working

        Hey there, I'm sorry the LineLink is giving you so many issues.  I'll do my best to assist with answering the questions, but ultimately, no one here can access your account as it is a public forum and specific account questions do have to go directly through care (611, Messaging, T-Force).


        1.)  I don't know if you've explored this (you seem pretty technologically adept, so perhaps you have; but you didn't mention in your post) but there are specific ports that need to be open on the router in order for the device to function properly. They are:

        • 500 UDP
        • 4500 UDP
        • 5061 TCP/UDP
        • 443 TCP
        • 993 TCP

        Next, ideally, the device searches for and downloads firmware updates every 24 hours, but if for some reason it's not been doing this, T-Mobile can check to make sure the device is up to date and push an update to the device for you if necessary (Grand Central>Linelink Device Tool>Firmware).  Also, you didn't specify, but have you tried changing out the SIM card?  I'm sure that if the problem has carried over through two providers and two routers, it's not the ISP (unless it involves the port issue mentioned above).  This leaves the SIM and the device itself.  If you haven't explored this, T-Mobile can send one out to you at no cost, or you can purchase one ($25) in the store.  If you have changed out the SIM, or you change it out, ensure the port and firmware are correct, and the issue persists, I would explore the possibility of a warranty exchange for the Linelink device.


        2. & 3.)  You are saying that folks are still able to leave voicemails even though the service is disabled? And when you say you have no(?) way to check them, are you referring to when you dial 123 from the phone?  Forgive me if you have, but have you tried dialing your own phone number and pressing * to interrupt the greeting then your 4-digit PIN (usually defaulted to the last 4 of your phone number; if not and you cannot remember, T-Mo can reset it to this)?


        Next, in order for calls to stop being forwarded to the VM system altogether, your T-Mobile rep will need to access Grand Central>Account>HLR Profile>Call Forwarding for Voice>Unconditional Call Fowarding, If Busy, No Reach, and No Reply: Set to "None".  This should keep the line ringing without sending to VM, but I would make 100% sure that you'll be able to use your answering machine before trying this unless you want to completely remove the option to leave any message at all.  Speaking of the answering machine, I could swear I remember one of the mods saying something about them not working with a linelink, before but I can't seem to find it anywhere.  Perhaps one will chime in with some specifics as far as compatibility.


        I hope I was able to help out (a little).


        How-to guides: T-Mobile LineLink

        T-Mobile LineLink

        2 of 2 people found this helpful
          • netguy2018

            Re: Linelink randomly stops working

            Hi Magentatechie ,


            Thank you for your response. I'm a network engineer so I'm going to feel pretty stupid if this turns out to be a router issue


            I don't block any of the ports you listed. I also don't expressly forward them to the Linelink and I disable UPNP for security reasons. Since the LL has no provision for a static IP address, static port forwarding isn't a good idea - though unlikely, the LL's IP could change. I could assign a static IP to the LL's MAC in the router, but all of this seems to be overkill considering the average LL user probably doesn't know what an IP address is (no insult intended to those who don't) much less how to configure a static IP, a dhcp mapping, or port forwarding. If UPNP is required then this is a hard-stop. I will not introduce that security hole to my network.


            T-Mo has checked (many times) the status of my LL and it always comes back OK. I presume it has the most recent firmware. Where or what is Grand Central and the line link tool?



            I have tried changing the SIM card. T-Mo has sent me two new 3-in-one SIM cards but these do not work with the LL. Apparently the contacts on these SIM cards are not close enough to the edges for the LL to make contact. The LL complained that no SIM card was inserted (I don’t recall exactly how it was worded, but it could not see the sim). T-Mo has no other SIM cards they can send me and I’m unwilling to invest $25 to see if maybe it fixes the problem.



            Re voicemail: Correct. I have had T-Mo disable the voicemail because I want to use my answering machine (built in to the phone base). When I dial 1-2-3 from the phone I get “Sorry, your account is not recognized”. Yet when the LL is in it’s “crashed” state or when I fail to change over to a call-waiting caller, that caller will be able to leave a voice message with T-Mo. Yesterday I had T-Mo turn on voicemail for a few minutes and was able to retrieve four messages. The answering machine works fine when the LL is working and when there is no active call. And just for clarity, I do not expect my answering machine to answer a call-waiting call. I also don’t want T-Mo to answer the call-waiting call - the caller can hang on or give up at his option



Last but not least, I’m going to try a UBNT Edgerouter Lite soon. I hope it fixes the problems, but I’m not counting on it. The CL router provides almost no advanced troubleshooting tools or config options (not unexpected for the target audience), and a Mikrotik is… well… a Mikrotik. Fantastic device for the money, but will make your hair turn gray trying to configure

              • magentatechie

                Re: Linelink randomly stops working

                I'm sorry! I should have specified that Grand Central is a tool accessible by T-Mobile reps.  I provided the path for you in case they have any troubles checking for the firmware updates or switching off the VM manually.   Do reach out to care at your earliest convenience and ask them to follow the Grand Central>Account>HLR Profile>Call Forwarding for Voice>Unconditional Call Forwarding, If Busy, No Reach, and No Reply: Set to "None" path as this will allow the call to ring until you answer it (or don't and let them give up )


                I'm really glad to hear that your answering machine works properly with your LinkZone, I don't know what I was thinking of in terms of remembering otherwise but I'm happy to be proven wrong!


                As far as the SIM goes, if you received the trio-SIM, this means that the 3 different sized SIMS are nested within each other.  The tee-tee-tiniest being the Nano SIM and it barely extends beyond the metal contacts (forgive me, but if the SIM appears to be too small-perhaps this is the case?), next up is the Micro and the Nano fits snuggly in there.  This is the one you need for the LinkZone (12 x 15mm).  Do you still have any of the SIMs that were sent out, specifically, do you have the Micro adapter for the Nano?  If you don't have one, I'm sure you could get one from the store without buying a new card- my local store always seems to have a couple lying around.


                I hope you're able to get this sorted out one way or another!  And good to know about the Mikrotik- the last thing I need is more gray hair!

                1 of 1 people found this helpful
                  • tolliver

                    Re: Linelink randomly stops working

                    I also echo what netguy2018 is saying.  The only consistent thing I've had with LineLink is the issues that he mentions.  I pick up the phone, it acts as though there is a dial tone, I enter a number and it then acts as though the number I dialed is busy and it's not.  I'm not sure how many calls I've missed because of the issue that seems like the LineLink loses sync with T-mobile.  But having said that, if it's important, those that I care about and know me, will just call my cell.  Most of the time the incoming calls are scams or spam so it's not an issue for me that will cause me to worry about it and look for resolution.  Yes, it's irritating that I have to unplug the LineLink device and wait for it to resync just to make calls (when I want to use my non-cell phone) and I'm not crazy about paying for a service that doesn't function well but.............................................................................

                      • netguy2018

                        Re: Linelink randomly stops working



                        Maybe if both of us complain loud enough someone at T-Mo will fix the problem. If they cannot - or will not - fix it, I know where I will be moving my landline.


                        I suspect "will not" is the more accurate outcome. I find it hard to believe that T-Mo lacks the technical resources to fix the problem. The reason they won't is economics - I suspect there are a relatively small number of Linelink users, and only a tiny fraction of them are complaining about this problem. They probably come out ahead financially by losing the revenue from us rather than applying expensive engineers to fix our problem.


                        Are you listening, T-Mo? I just called you cheap.

                  • tolliver

                    Re: Linelink randomly stops working

                    Beyond my comments in the other posting, prior to having LineLink, I had Vonage.  And before Vonage, I had Lingo.  I have never had to look at the ports and protocols on my router nor have I ever had to switch out sim cards or anything else to get their services to function.  Pull their device out of a box, plug it in, setup some info on a webpage and whammo, it works systematically and without issue for very very very very long periods of time.  I even replaced a Vonage device one time because of a power issue that hit the house causing the device to fail.  The new one worked within minutes of plugging it in and adding it to my account.  NO SIM CARD was needed to be touched.  Either you guys can do the service and compete with the other providers to earn my money or you can't and really should sunset the offering.

                  • tmo_amanda

                    Re: Linelink randomly stops working

                    Hey, netguy2018!


                    magentatechie sent some helpful info your way. Have you had a chance to Contact Us yet to get your account updated?

                      • netguy2018

                        Re: Linelink randomly stops working

                        Hi Amanda,


                        I have called T-Mo with this issue many times. The day I posted the first message here I called and was told it's my internet connection. I told the tech I will not accept that as an answer unless they can provide the technical details. I asked for an engineer to call me - it's the LEAST T-Mo can do since I've been a customer for something like 14 years. So far, no call.


                        I'm ready to give up on this device. For all of T-Mo's engineering strength, a little Linelink is kicking their collective butts. The sad part of this is that I simply don't matter to T-Mo. I'll either quit complaining and live with the crappy service or move on - either way they don't have to deal with me anymore.

                      • netguy2018

                        Re: Linelink randomly stops working



                        I have changed my router from the Centruylink provided Zyxel C3000Z to a Ubiquiti EdgeRouter Lite. The internet connection was taken down and brought up several times during the change, and some technical issues regarding the TCP MSS for PPPoE traffic had to be resolved. The LineLink was not power-cyceld or disconnected from the switch at all during this process. Each time the Internet came up, the LL would re-establish a connection to T-Mo. At this time it is working, but it is too soon to tell if the router change fixed the problem.


                        I believe the LL behavior during the router change demonstrated the following:

                        -When working correctly, the LineLink will re-establish a broken connection.

                        -The LineLink can tell when the link to T-Mo is broken in software. In other words, the Ethernet port on the LineLink did not need to "go down" in order for the LineLink to register that it was no longer connected. This suggests that there is some sore of "heartbeat" or "keepalive" function between the LineLink and the T-Mo switch.


                        Based on this, I believe it is a logical conclusion that if my router or ISP was the problem - was breaking the connection somehow - that the LineLink would automatically reestablish the connection as soon as it discovered it was down, which during my router change occurred very quickly. It would not stay down for hours or days at a time and require a reboot to fix. I believe it is also logical to conclude that one of two things is causing my problem: 1 - the LineLink is crashing and requires a reboot. I think this is the most likely situation. 2 - T-Mo's switch is keeping the connection to the LineLink alive but is losing the link to it in some way that prevents phone calls to or from the LineLink.

                        • gt500boy

                          Re: Linelink randomly stops working

                          Having the same issue since getting the LL device.  And now on my third LL device (second SIM card).  Nothing seems to fix this issue.  Also checked with my ISP regarding blocked ports.  All ports have been verified by the ISP as not being blocked.  Odd that these issues started when I was required to switch out my 10 year old @home router (used only for VoIP, not network routing) with the LL device.  Same ISP before that, same modem &router (OnHub).  This device is obviously inferior quality and definitely has more issues than a device 12 years old it was required to replace. 

                          Also calling T-mo on each time this device has an issue is wearing.  As it seems hold times are ever increasing when trying to get an issue like this resolved.  The "solution" of changing out the hardware does not seem to be working for most people.  Or maybe they were not @home customers before LL and the sub-par quality and reliability is just what they are used to.  Either way, its pushing this 13 year loyal customer to look at other options. 

                            • chris13

                              Re: Linelink randomly stops working

                              Unfortunately, @Home worked a lot better than LL and they made us switch anyway.  I've been chasing down issues with LL since making us switch 2 or 3 years ago.  The only given I've found is constant need to reset.  I just switched to VZ Fios and am now experiencing a few more dropped calls than normal.  I'll check all the new router settings eventually, but probably just revert to the unplug/reset every so often.  Pretty much worthless to call tech support, unfortunately.  My bigger issue is losing call waiting, caller ID number when they made us switch to LL from @Home.  The LL saga continues...

                            • tonys1965

                              Re: Linelink randomly stops working

                              Hey netguy2018 did you ever wind up getting this resolved? I’ve been having the same problem since I got this line link 11 months ago. The tech keeps giving me the same response, the “ i‘m sorry you are having the problem of ( insert problem you called for here) that must be very annoying.“ It’s very frustrating because they think they resolved the problem by having me reset the line link after I just got done telling them that after rebooting the line link it works fine for a while but the goes down again. I‘be already contacted them about 10 times but haven’t been able to get anywhere. Should I just give up on it? What did you wind up doing?

                              • magenta7214097

                                Re: Linelink randomly stops working

                                I am having the same issues.   The only reason why I needed a line is due to my intercom in my building.   Randomly, the front desk will call my cell for guests stating the phone is not working.   the lights are ok and the phone gives me a dial tone however calls don’t go through.   so now I am constant randomly checking to see if the line works by dialing it from my cellphone.  I’m paying a monthly service and don’t expect to do this work.  After reading all the previous posts I see there is no solution but to find another method to meet my intercom needs.   Very frustrated

                                  • audiodoc

                                    Re: Linelink randomly stops working

                                    I'm not having this issue, myself, though I am using an Edge Router, the ER-6P. 

                                    I'm a novice so this Edge Router is really over kill for my purposes. I have read on the Ubiquiti community forums that one should disable the SIP helper modual.  Of course you may have already done so.  Are you still having these problems?  I was having similar issues with my Obitalk device before switching to the line link. Obitalk seemed to be going into "do not disturb" mode all by itself.  I was missing many calls, so went back to t-mobile's line link, having use the @Home service for many years.


                                    Off topic, but as I mentioned, I'm a novice at networking and am learning on the fly.  The ER-6P does not have a built in switch. The setup wizard sets up two Lans on eth 1 and eith 2, but doesn't set up the other ethernet ports. I'm in the process of learning how to set up eth 4 and 5.  So far I've got a home network set set up and a IoT (Internet of Thinks). I've got my line Link on a switch for the IoT network. Seems to be working well, but I'd like to put it on its own port and am trying to figure out how to do that. Need to know what setting and rules it requires.

                                  • magenta10616346

                                    Re: Linelink randomly stops working

                                    Hi! Even though this post is over a year old, I too would like to know if you ever had a resolution. I'm happy to know I'm not the only one having the same issue (almost, I have never been able to get the LL to recognize my SIM card and therefore never work)  and yet extremely frustrated that a company which normally has excellent customer service has engineers who are basically ignoring many customers with the same issue, an issue that has been happening for years apparently. I have had 3 Line Link devices, 5 or 6 SIM cards, a trip to the store to basically be told yes we are installing the SIM card correctly, and HOURS on the phone with various customer service agents. I've been a T-mobile customer for over 10 years and love them. However I am extremely frustrated with this issue, and don't appreciate the T-mobile engineers and Line Link "experts" who don't seem to be taking this seriously and just keep saying the SIM card isn't inserted correctly. I feel they don't want to actually look into the issue and troubleshoot their product, which is horrible customer service for a product the company still offers. I would love a solution to this. So Netguy2018 and everyone else on this thread, I second your words and complaints. This is completely unacceptable and I guess I will take my husband's advice, give up, and take my business elsewhere