Samsung S10 Unlocked from Sprint doesn't read T-Mobile Signal


    Good Evening,


    My cousin owns a Sprint Samsung S10 Unlocked but it doesn't detect my T-mobile sim card for some unknown reason, when I say it doesn't detect I mean it doesn't let me do calls or even use the data. The weird thing is when I reboot the phone it boots up with the T-mobile Logo and it downloads the T-mobile apps ( Unlock, Visual Voicemail, T-mobile App, etc).


    The thing is we already tried different company SIM cards ( AT&T, Boost, CLARO,) and they work perfectly on it. We already tried different things like:


    - Booting the phone, wait for it to load and put the SIM Card in

    - Turning the phone OFF then put the SIM Card in and then booting up

    - Check if the APN settings are correct ( Normally when I put the SIM Card it automatically loads the correct APN Settings)

    - Putting in Airplane mode then back to normal.


    The Phone Details are:


    Model Name: SM-G975U
    Android Version: 9
    Android Security Patch: November 1, 2019
    Baseband Version: G975USQS2BSIV


    Is there any particular reason it doesn't work and is there any way to fix this?


    Thanks in advance.