Oneplus 6T Errors browsing internet on WiFi

klj99124

    When trying to browse the internet while connected to WiFi using the T Mobile home internet I get a couple errors depending on the site, either "The connection was reset" or "Secure connection failed".

     

    The phone is a Oneplus 6T Android 9.0.17

    The phone successfully connects to the WiFi and receives a valid IP address

    I can ping internet addresses successfully and DNS look ups work

    Other devices, laptop and TV, work ok connected to the T Mobile home internet WiFi. The phone worked for at least a month too when I first got T Mobile home internet.

     

    The phone works normally when connected to other WiFi networks, it's only when connected to the T Mobile WiFi that the problem occurs.

    I've tried re-starting the phone, forgetting the WiFi on the phone and wiping the cache partition. None of these things worked. I've also tried multiple browsers on the phone with the same results.

     

    I'm not 100% sure that this is an issue with the phone, it could have something to do with the T Mobile WiFi, but, all other devices that connect to it work ok,

    I've run out of ideas for troubleshooting this problem and so far T mobile support has not been able to solve it. Any ideas?

      All replies