Why Doesn't the Timex FamilyConnect Charge Overnight?

magenta10603349

    Hello,

     

    I'm wondering if anyone else out there has had our same charging problems with the FamilyConnect. It seems related to but not the same as the one mentioned on this discussion.

     

    In our case, the watch will charge all night but be at something like 20% charged in the morning. We can see that it is properly docked because the charging light is on. It doesn't happen all of the time, maybe like 1 out of 4 times we try to charge it. So what ends up happening is that the watch is at 80% battery or so when we dock it for the night but when we wake up, it's down to 20%, though it's been on the charger the whole time.

     

    I've tried plugging it in different outlets, just to see if that makes a difference. It didn't.

     

    Any thoughts? Thanks!

      All replies

      • reckless4bandon

        I’m sorry to say I know exactly what you are talking about. We purchased the Timex Family Connect for my daughter. I was so excited to give it to her. She was so excited to get it on her birthday. We didn’t think too much of it when it died after 2 hours of her using it and playing the games. However, we experienced the same problems with it not charging and the first day of her wearing it all day, it randomly turned off five times. We tried for the rest of the week rebooting, changing settings, whatever we could to make the watch last but it seems we dropped $195 on a fancy wristband that doesn’t perform the promised functions. I tried to return it but because we bought it a week before her birthday and tried to make it work for a little over a week after, we are past the return period and the only option I was offered was to return the brand new watch we purchased for someone else’s used, refurbished watch of the same brand, probably with similar problems.

        • tmo_ian

          Hmmm, that is definitely an odd issue. If it's showing connected but not charging, there might be some sort of debris or dirt between the contacts. So you could try giving both a wipe down with a clean cloth. Another possibility is the watch is trying to do stuff at night and using more power than the charger can provide. Can you set up a School Mode for overnight? That should prevent apps from being used overnight by accident.

          • tmo_mike_c

            Hi.

             

            Have you checked out the suggestions above to see if they help? Please let us know.

              • magenta10603349

                Thanks for the suggestions and the follow-up. I don't think we've found the solution yet.

                 

                I tried setting up a School Mode for overnight but there seems to be some sort of default that prevents you from putting a PM as the start and an AM as the end. I've tried several different times but the app always responds with an error message that reads "Invalid Time range!"

                 

                I'm a little less convinced by the dirt or debris idea, though I have wiped them off. The problem is that it charges most of the time but has failed a few times, so it's little hard to figure out when the problem is solved.

                 

                Anyway, any ideas on how to set up the School Mode for a PM start and AM finish? Thanks.

              • tmo_mike_c

                Hi again.

                 

                Have you checked Ian's post above to see that test works? Please let us know.