Band 12 with no data connectivity

bullardk121

    I am having an issue where I'm showing 3-4 bars of lte connectivity on band 12 on my Pixel 3 XL, but I have no data connection. Voice and sms work great. I am at a family cabin and have had data work in the past, but not now. My wife's iPhone 11 works fine. If I put my SIM card in the iPhone 11 it works so it seems to be an issue with the phone and TMobile. Ive tried resetting everything with no luck (data, network settings, airplane mode, etc).

     

    I noticed yesterday when hiking in the middle of nowhere it started working but as soon as I got back it stopped. I don't understand why it says my phone is getting lte and I have as good a signal as my wife's iPhone, but her phone works and mine doesn't. Any ideas? I came up here to work "remotely" but I've gotten myself in trouble now that I can't get data to work on my phone. Any help is much appreciated.

      All replies

      • syaoran

        Re: Band 12 with no data connectivity

        Have you tried deleting and recreating the APN?

        How to reset the APN on an Android device | T-Mobile Support

        • drnewcomb2

          Re: Band 12 with no data connectivity

          When you say you have no data connection, do you mean you ran PING and got a complete failure or do you mean that you can't use apps like Facebook?

          • bullardk121

            Re: Band 12 with no data connectivity

            Sorry I should have clarified that. The ping test does pass yes. I can also search for anything through Google search, but I can't browse to anything or use any apps. The search results are not cached results because I can search for random things I've never searched before.

              • drnewcomb2

                Re: Band 12 with no data connectivity

                So what you actually have is a really bad data connection. I'm surprised that an iPhone would beat a Pixel on range but that's life, I guess. All I can suggest is that you move to a better location; get a band-12 signal booster, etc. I take it that the cabin has no broadband Internet service?

              • bullardk121

                Re: Band 12 with no data connectivity

                So just to expand on how weird this is:

                 

                1. Ping test passes.

                2. I can search for anything in the Google search bar and bring up current results. (I've cleared cache just to make sure it wasn't bring up anything locally)

                3. Weather widget works and updates.

                4. The articles in what used to be called google launcher (not sure what it is now, Google seems to like to rename everything yearly) update both automatically and manually. I can't browse/read any of the articles, except for articles from CNBC (but only through the google launcher, I can't browse to CNBC in a browser).

                5. If I turn off VoLTE, I lose connectivity altogether. ( I read somewhere that maybe this would help, I don't know if you have to have VoLTE turned on to even connect to band 12 (600mhz) or not?)

                 

                I contacted T-Mobile support but after resetting the network settings and doing a couple other things, they referred me to Google saying because my sim card works in my wife's iphone, it must be a phone issue. I contacted support at Google to see if they could help with additional testing, but the support guy knew less about the phone than I did and wasn't very helpful. He told me it's a network issue and referred me to T-Mobile support. So now I'm down to guessing it is either:

                 

                1. An issue with the phone and band 12 (when I'm connected at home, it works just fine, but I didn't specifically look at what band I have at home, though I'm almost certain it's not band 12).

                2. T-Mobile is doing work on the tower I'm connected to and somehow restricting access to my phone (still don't understand why my wife and her siblings iPhones all work though).

                 

                Kind of at a loss at this point. Don't even know what else I can try?

                • bullardk121

                  Re: Band 12 with no data connectivity

                  After a little more troubleshooting I'm convinced it's an issue with the tower I'm connected to. If I go far enough away and it connects to a different tower, with a much worse connection (according to LTE Discovery) I can use data on band 12. Is there a way to check with T-Mobile if they're doing work on a tower? I still don't understand why it would allow data on my wife's phone but not mine. I guess I'll just have to wait and see if/when it starts working again.