Question

Google blocking search


Userlevel 3
Badge

I placed a search on Google and this is the response I got back.

"This network is blocked due to unaddressed abuse complaints about malicious behavior. This page checks to see if it's really a human sending the requests and not a robot coming from this network.”

What does this mean? Is Google trying to block my use of its service because of issues with T-Mobile?


151 replies

….Called and was told it is an issue with google, but google will not resolve the issue and says its tmobile….

 

I can’t see how T-Mobile can blame Google for the issue when my neighbors all use the internet from different providers (Verizon included) without issue.  If it’s only happening with T-Mobile, then they have to get their IP locations corrected.

I agree but I’m not going to argue with someone in a call center, those ppl are just reading from a script and have no troubleshooting or tech abilities.

@HeavenM, can you provide any updates to this issue? Seems this is still a very active issue that is not being handled (or at the very least properly communicated) by T-Mobile. What is being done to rectify this?

Userlevel 7
Badge +14

Hey 😊 I have been keeping on the situation and hoping to have better news by now. Our engineering teams are engaged with Google to resolve the issue. There is no estimated time of completion yet. We do have all the examples we need at this time. 

You guys are so great about trying all the things to get the error and captcha to stop showing up. The suggestions from our teams right now are to refresh the browser and restart the gateway. You can also try different browsers and if possible, use iOS devices. 

I know this may not be the news y’all were hoping for. I’ll continue to watch and update here as soon as we know more. 

Userlevel 1

3+ weeks and pretty much nadda, restart the gateway which does nothing, and buy an iphone. Wow!

Same issue here on all computers. Sometimes can just check the I am not a robot box and other times have to select images from a grid. Very annoying. Today it was a complete block and would not allow any captcha options. Did I mention it is very annoying? Switching to DuckDuckGo as search engine.

same issue here in New Orleans

 

Userlevel 1

26 days and counting! 😊

I personally haven’t noticed a difference using iOS devices or non-iOS devices. I get the captcha basically every time I Google on both my iPhone and Macbook. As usual, rebooting the gateway is useless. I’ve also noticed the captchas getting more aggressive- sometimes the images it gives are so distorted that I have to actually put effort into solving it. 

Additionally, I have two internet lines, one using a Google Nest mesh Wifi network, and the other using the wifi that’s built into the gateway. I saw some say that the error had something to do with the mesh router, but my line that uses the stock router’s wifi still gets the captcha just as much as my mesh one does.

Same issues in Gainesville, FL

same issue here in New Orleans

 

The same message came up here, and also you may not be able to post comments on YouTube because of the blocking.  There is a work-around though.  You can use a VPN to change your IP.  Windscribe once had some free VPN services, and some other VPN companies offer deals on Stacksocial. 

Hey there. That is a really weird error to be getting on a search. If I am understanding correctly, this error pops up right after typing a search before any search results come up. I would love to get some more information about the situation, so I can pass along the message for the really techy people to dig in and find out why. If you are comfortable sharing, I would love to know what you searched for, what time with time zone, and a screenshot of the error. If there is a hiccup with a set of our IP addresses and Google, then we want to tackle that asap. Thanks for sharing so we can figure it out!

 

Hey 😊 I have been keeping on the situation and hoping to have better news by now. Our engineering teams are engaged with Google to resolve the issue. There is no estimated time of completion yet. We do have all the examples we need at this time. 

You guys are so great about trying all the things to get the error and captcha to stop showing up. The suggestions from our teams right now are to refresh the browser and restart the gateway. You can also try different browsers and if possible, use iOS devices. 

I know this may not be the news y’all were hoping for. I’ll continue to watch and update here as soon as we know more. 

 

Still having the same issue here north of New Orleans for what it's worth. I have tried most of the workarounds: dumping my cache, restarting, etc. Pretty much only using a VPN works now. 

Userlevel 1

Just here for my weekly check in. No improvements whatsoever since we first started dealing with this over a month ago.

We are on the New Orleans network also.  You would think they would figure this out! 😠 It is interrupting my google display search also.

Userlevel 1

it’s been a month, utter crap support!

One more person having the same issue.  TMobile needs to find out what the issue is and fix it

I started receiving this scrutiny back in August as well. Happens every time the IP address changes. 

To be honest, T-Mobile should be embarrassed. Stop with the excuse that this happens to other providers. That matters nothing. If it’s happening it means you’re network is doing something that’s pissing google off, or something is not configured correctly.  Maybe, too, if you stop cycling your IP addresses several times a day. Perhaps if you assign your IP addresses to the local region they’re handed out to instead of me, for example, who has residence in Florida yet my IP is based in the state of Washington. 

Seriously, fix your stuff.. 

I Hate AT&T but they don’t have this issue. I HATE Comcrap but this never happened either. 

It’s time you jump on this. 

Issues like this should have been resolved  in no more than 24 hours and this has been going on now for several months. 

This is not your best look. 

Clicking the box is one thing, but I’ll be damned if I’m clicking on yellow school busses. Kamala Harris may like a yellow school bus, but they piss me off. 

Same issue here and is getting aggravating :( 

Adding my name to the list of complaints. Been going on for months and I’m tired of it. Thinking of switching.

Has anyone also had issues with doing Walmart pick up orders and being cancelled due to this same concept?? Really regretting this all around now. 

Userlevel 1

Same issue here and is getting aggravating :( 

We’re way beyond aggravating,

We’re past ridiculous,

We’re into negligence territory.

this must be within certain areas that T-Mobile devices have been used or being used.  I am having the same issue; however, if I use my work computer with a VPN and go to google over my T-Mobile device then it does not happen then.  I know that the VPN when going to google is using my work IP address so it does not recognize the T-Mobile.  However, if I go off of VPN and just back on my home network then it happens.  This is definitely a T-Mobile issue that they should fix.

Pensacola, Fl here. I have worked on my computer trying to figure this mess out because when I searched about it all I saw was possible extension problems etc. Then I came upon this thread….. WOW!!!!!!!!! Get it together T-Mobile!

Same problem in Georgia

This happened to me today on my iPhone and I’m not sure how to even fix this issue as I’m on cellular service and not even connected to Wi-Fi. It won’t even allow me to click the “I’m not a robot”

Reply