Solved

Router Won't Connect to Online Play for Nintendo Switch

  • 18 September 2023
  • 9 replies
  • 5927 views

Badge

Hello everyone! 

I am in desperate need of help. I recently bought a Nintendo Switch and am trying to access online play. I always get an error message when I try to access online play. The error typically says something about my NAT type causing the issue. My T-Mobile router (Arcadyan KVD21) seems to have NAT type B. I was told that I could just access my router settings on my computer and enable UPnP. However, when I type in my IP address I do not see any router settings to change. All I see is connection status/quality and some gateway information. Basically all I see is exactly what is in the T-mobile home internet app. Does anyone know how to fix this issue? Should I just get rid of T-Mobile home internet and get something else if I want to play games online? 

icon

Best answer by copz1998 18 September 2023, 23:25

View original

9 replies

Userlevel 5
Badge +9

@BekkiC your problem sounded related to double-NAT. Do you have a home Wi-Fi router plugged into your Arcadian gateway? If so, you will need to put the Wi-Fi router into bridge mode. Also, do other devices have good internet access?

Let us know if this helps. 
 

 

Badge

@BekkiC your problem sounded related to double-NAT. Do you have a home Wi-Fi router plugged into your Arcadian gateway? If so, you will need to put the Wi-Fi router into bridge mode. Also, do other devices have good internet access?

Let us know if this helps. 
 

 

So I do not have another router plugged into the gateway. I just have the one that t-mobile supplied as is. And my other devices have good connection. I'm wondering if using a wired connection might fix this? I was looking through some other users' posts that are similar to mine. It seems that most users who have this issue have NAT type D and they want type B. I have type B but it isn't working which is why I'm confused. 

Userlevel 5
Badge +9

Take a look at this link. It might be helpful. 
https://www.purevpn.com/blog/change-nintendo-switch-nat-type/#:~:text=NAT%20Type%20D%3A,units%20with%20NAT%20Type%20A.

 

Badge

I’m having this problem as well with the same type of NAT B as op. Any help resolving this would be appreciated!

Badge

Wired connection does not help.

Badge

I was a Spectrum customer for 2 years and play Mario Party online with my friends, one of whom is a T-Mobile subscriber. I switched to T-Mobile internet on 12/29/23 and now we cannot play any Nintendo online games together. I can still play online with my friends who use Verizon and Spectrum Internet.

My friend and I both have a Sagemcom Fast 5688W Gateway. NAT type B. I also tried the wired connection. We have even tried playing on another friend’s T-Mobile gateway and it seems T-Mobile will not connect with T-Mobile. I am now trying a Verizon gateway and my T-Mobile friend and I are able to play online together again. 

It would be great if T-Mobile would fix this issue. I do not want to subscribe to Verizon, but I may go back to Spectrum after 90 days if the T-Mobile issue persists. 

Go to the tmobile internet app and change WPA version to WPA2. It will now be recognized by the nintendo. The WPA2/WPA3 recommend settings will NOT work with the nintendo for some reason.

Go to the tmobile internet app and change WPA version to WPA2. It will now be recognized by the nintendo. The WPA2/WPA3 recommend settings will NOT work with the nintendo for some reason.

This helped me. Thanks.

I’m still struggling to play online mode on my switch after changing my tmobile wifi settings to WPA2, 2.4/5gHZ :( I’m able to connect my switch to my tmobile wifi, but when playing stardew in co-op mode i’m still getting the same error “Unable to connect to other console(s). Please try again later.” Error code 2618-0513.

Any other suggestions by any chance? Can’t believe there are still issues with connecting switch to tmobile wifi.

Reply