Question

5G home internet keeps dropping


Userlevel 5
Badge

I’m having a problem with T-Mobile 5g home internet that has not been resolved despite many calls in to the help line.  I’ve had T-Mobile 5g home internet for almost a month now, and the short version is that every so often the gateway drops the network.  When I say “drop the network,” I mean to say it throws everything off of the Wifi that it’s broadcasting, and anything plugged in via ethernet says “no network found.  (To elaborate this point, cell phones switch to cellular data because wifi is gone for them, and computers hardwired into the gateway think that they are no longer plugged into anything.)  Turning off the gateway and turning it back on resolves the issue, but doesn’t prevent it from happening again.  Whatever is happening doesn’t seem to affect our connection speed/strength when the gateway IS providing signal to devices in the home, but due to the nature of our work, we need a connection that won’t just disconnect randomly.  

 

To address this, T-mobile has so far run a bunch of tests on their end, and seem to have ruled out a tower issue (which makes sense, as the tower shouldn’t have anything to do with whether or not the devices on the gateway’s wifi or ethernet connection get thrown off of the network.)  They’ve sent me a replacement gateway, which is experiencing the exact same problem (3 times in the last 36 hours, in fact).   I’ve noticed that the device gets pretty warm, so I set up a computer case fan as a cooler to force air through the device, thinking that perhaps it’s an issue with the device overheating.  However, while the gateway is notably cooler than it was without the fan, it has not prevented the issue from persisting.  The last thing that I can think to do (and my most recent attempt at resolving this issue) is to plug a router into the gateway via ethernet, and allow the router to handle the wifi/connections w/ devices in the house, and to disable wifi from the gateway all together.  Maybe the gateway is simply too overburdened with connections and gets somehow overwhelmed and shuts down, and having the router handle the “heavy lifting” of taking care of all of the individual device connections will resolve it?  I don’t have a great deal of faith that this will fix the issue (as the gateway also kicks ethernet things off of the network when it experiences this problem), but I’m running out of options/ideas of what to do in order to just get a stable, constant internet service.   

 

Is anybody else having this issue, has anybody resolved this issue, or does anybody have any advice or feedback regarding how I might get this resolved so that I can get back to having stable internet?


239 replies

Userlevel 1
Badge

Ok so far problem seems solved I called tmobile and talk to tech they sent me out another tower.  This time I didn't switch out the Sim cards but called t mobile and had them configure the Sim card that came with the unit so far so good almost a week without a rest 

Badge

I’ve been running mine with a fan blowing on it for the last couple of days.  My issues might be fixed, but I need more time to confirm.

I am experiencing the disconnect issue.  I have great service when it is online, but at random intervals, it loses connection to the internet.  I have it just as my ISP as I use a mesh router for my house.  I have the 5ghz wifi enabled, but nothing is connected via wireless.  Service drops and typically all I have to do is reboot router via the app and it comes right back.  Occasionally I have to do 2 reboots of the router.  I made the switch from ATT as the only provider in my area could only provide 25mb down and 1-2mb up via their uverse dsl.  Hoping to see a firmware update on this, but looking at the history of the post doesn’t give me a lot of confidence.  I am on the black round gateway with firmware SGJi10105-1.1.52.  Router sits in a ~72 degree room with plenty of airspace around it.  Curious of the firmware version of others on here.

Three weeks in and I'm ready to chuck this junk. Every time I try to stream ANYTHING the internet drops requiring a modem reboot. Constant 5g 5 bars and wifi never drops, only internet. Strange how my phone never loses internet though. Looks like it back to the other ripoff at Xfinity. 

Fellas, the answer is very simple they have no idea what they are doing with  the internet pacakage F troop here.  Go else where they are charging and not providing the service  Get your money back and move on:)  I tried all of the things mentioned and in each case at the endof the apologies and we will make this right verbiage they never called back with a satisfactory resolution or corective action that allowed me to simply enjoy the service.  My conclusion based on this is that they have no idea how to fix the problem and are accepting my monthly payment for their gateway internet service which nevre provided service for a complete month.  it was good for a week then bad for two weeks etc...

Fellas, the answer is very simple they have no idea what they are doing with  the internet pacakage F troop here.  Go else where they are charging and not providing the service  Get your money back and move on:)  I tried all of the things mentioned and in each case at the endof the apologies and we will make this right verbiage they never called back with a satisfactory resolution or corective action that allowed me to simply enjoy the service.  My conclusion based on this is that they have no idea how to fix the problem and are accepting my monthly payment for their gateway internet service which never provided service for a complete month.  it was good for a week then bad for two weeks etc…  I had such faith in T-mobile I played ball for 4 ,5 months.  Now I want my money back for those 4.5 month and we will simply part company. Xfinity bound ironically I don’t like xfinity but I have to admit thier service seems to at least meet the minimum requirment of um working:)  Not going to beat my head agaisnt the tmoblie Ftroop process any longer:)  Somtimes it is the simple answer that is the right one in this case t-mobile is cluless about the gateway package they are pushing:(  Eject now fellas and ladies So I am on the line right now and they were working on getting my money back and the call dropped sound familiar.  So done here:(  9 year customer moving on:(

So they seem to have refunded me $200.00 for the 4 months (we shall see if that really happens).  Frustration dropping just have to make sure xfinity does not gouge me LOL:) Oh finally run don’t walk from the tmobile gate way it is a peice of junk with unknown issues.  If they could not fix it in 4 months of service calls and untrue statement they never will “Run you fools!!!!!:) (as Gandalf said in the lord of the Rings LOL:) The Ronin

Userlevel 1
Badge

 so far problem seems solved I called tmobile and talk to tech they sent me out another tower.  This time I didn't switch out the Sim cards but called t mobile and had them configure the Sim card that came with the unit so far so good almost 2 weeks without a reset

I had run into this issue. After much research and fiddling with the gateway placement, I discovered some things. The gateway would drop connection at night, in the middle of the night. I have it placed near a window, but I have vertical blinds that I draw at night. The connection seems to be extremely sensitive to the placement of the gateway in my area, and I started checking the advanced cellular metrics as I played with different placement of the gateway. I figured out that some of the parameters would change from “poor” to “good” just by a few inches difference in the placement, and closing the blinds would affect the parameters even further. What I think was happening is that at night when the blinds were drawn, certain cellular parameters became very “poor” and the connection was dropped. I’m hoping I have fixed this by keeping the blinds slightly open a night. We will see. 

One possible solution.
It has been about a month since we signed up with Tmobile 5G home service in Oct ‘22.  The model of our black 5G tower is FAST-5688W.  Yes, it is sensitive to placement and also the proximity to the Netgear Nighthawk wifi router, causing the 5G internet to randomly drop over the initial 8 days.  That is until I moved the Netgear wifi router from 2 inches away to 12+ inches away.  It has been almost 3 weeks of reliable internet since.  We’re very happy that T-Mobile is available in the mountains of Colorado.  Subsequently we cancelled our Starlink reservation.  

I have tried all of the solutions on this thread and none worked. Eventually after many tries at calling, I got a local center out of California. They put in a “trouble ticket” to have an engineer go check out the tower (less than a mile a way).  Whatever they did, it worked.  No problems since.  I’ve put in several calls to find out what exactly was done so I know how to raise it if it happens again, but despite taking messages no one has called me back.  I would recommend using the key phrase “trouble ticket” and ask them to open one up and check the tower.  Hope this helps.  Happy to answer questions.

Have had the device two days and it works great! :) To the point that I have cancelled xfinity internet. Not a great test period, agreed, but ….
 

Seem to have the latest black box, looks new, 4 bars signal strength. Good cell phone signal strength out and about in the neighborhood. We also recently switched cell service from Verizon to T-Mobile.

Speed test varies a bit with the box but generally can get up to 200-300 plus, download.

However, with a boatload of computer hardware/software diagnosing experience in hand, I will not spend a lot of time working with support if I start developing drops, I will just dump the service and go crawling back to Comcast. 

Update:  I’m actually getting up into the 400-500 range at times. Even when it was showing 40-50 mbps the other night during prime time streaming, everything was running great. It’s just me and my wife here in a one story house, with not much concurrent device use. All of our devices, Roku box, iPhones, laptops, iPads, are late models that run fast.

I will update this in a month ….

 

 

Any update? You would be probably the only one not having issues...

Userlevel 1

Have the newer 5G home gateway. It was fine for a few months, the last few months it has been un-reliable. internet connectivity just drops (not slow, drops 100%).  This is not just the gateway by cell data on my phones also dies at the same time!   Multiple calls into T-mobile, technical tickets and promises of call backs, nothing.  Everyone should file an FCC complaint: https://consumercomplaints.fcc.gov/

 

Badge

Best advice is to get rid of your T mobile! I have to turn my internet box off and on every day, plus the app won't connect to it ever.   They lied about trades and free phones etc… now I'm stuck till I pay off everything. Then Ill have to try Mint.

Reply