5G Home Internet Service Equipment

  • 21 February 2021
  • 9 replies
  • 746 views

Badge

I ordered T-Mobile's 5G Home Internet to test it out.

It worked for about 45 minutes.

To begin with, the Bluetooth-based setup didn't work at ALL, so I had to do the setup manually - which as a CHORE. And I'm pretty tech saavy. Then the Wi-Fi stopped working. The SSIDs completely disappeared. I couldnt’ connect for beans.

So I used the Ethernet ports to access the UI and got it working again. Then the Ethernet ports stopped working - completely. Both of them.

Then the Wi-Fi stopped working - again. And the reset button never worked at any point after taking it out of the box.

This thing is a total Finnish piece of crap. 

I’ve been on HOLD with the WORST hold music in the WORLD for almost two hours now. 

This has been the single worst purchase and customer service experience I’ve ever had with T-Mobile. WHen I finally get through to someone I just want to send this back and to port my service over to Verizon.


9 replies

I am having a very similar problem and I am extremely disappointed in T-mobile as I have always had excellent service up till now.

Badge

It. Got. Worse. Four and a half hours on hold, an hour and a half with a lovely, wonderful customer service rep from South Carolina. Really, she was great! But the best she could do was ask me to go to my local store for a warranty exchange because her system wouldn't allow it. 

I went to my store - a ginornous marquis location in Downtown San Francisco - only to be told they don't have any of those units. In fact, nobody had ever seen one yet. They hadn't been shipped to stores. 

After an hour there and many phone calls, I did finally get someone to authorize an warranty exchange. But replacements are backordered until mid March. Are you freaking kidding me???

I really want to jump ship, but other carriers have crap coverage in SF and most plans are very expensive. So now I feel held hostage by low prices and decent coverage, only to have to deal with an inept corporate disaster.

I will note that the PEOPLE who helped me were amazing all along. Courteous, understanding, empathetic. But the company as a whole? The bureaucracy? It's a hot freaking mess. 

Badge

I feel like I’m being totally punk’d.

I got the replacement unit just now. Early, yeah, I know. Cool, right? WRONG. This unit is WORSE than the last one. Again, the setup failed, and was very difficult. It never really completed. In the device UI, it showed the SIM as connected, but there was no Internet connection. ANd now? Now the damned thing is just in a reboot loop. It turns on and that’s literally all it does. 

How is it possible that T-Mobile is sending this absolute CRAP out to its customers? It’s ridiculous. Didn’t ANYBODY Q/A test this stuff? 

Badge

I tried to call T-Mobile’s Home Internet customer service. I waited on hold for about 15 minutes before I remembered the FOUR AND A HALF HOURS I WAITED THE LAST TIME and I hung up. This whole experience has been a HOT F***ING MESS from the moment one of these Home Internet Gateways arrived at my house. 

So now? Now I have TWO of these junkers, one that’s maybe 80% reliable with crappy reception, and one that’s 0% reliable with NO reception. And I can’t bear to sit on hold for hours again. I just can’t do it. So now what do I do?? 

I just can NOT believe they’d ship these pieces of CRAP!

Badge

45 minutes on hold…. 

I can’t believe this...

Internet connected? Not so much. Can’t access anything on the web. 

 

Here is my experience if it helps someone …

I have google-fi service and phone (pixel3) and one of these days when my home internet (comcast xfinity) was down due to weather conditions I did a fast.com test on my phone over cellular data and I got 160 MB connection which was 2x times the connection I was getting on xfinity (200 MB plan). So, I signed up on 3/15/2021 and received the equipment on 3/17/2021 which is fairly quick. The connection/setup was quick and I got 160-240 MB connection right off the bat. 

Here are the bad / negatives.

  1. There is no WPS (wifi push button service) feature. I have few devices that only support WPS for wifi (cameras) and couple like printers/scanners that have WPS as easy setup option. I cannot use cameras anymore (unless I connect thru ethernet-cable). I need to use usb connection to configure/setup my printer connection. 
  2. The ethernet-lan-ports seem to be funky. I thought I can connect my exiting orbi-RBR50 as an access-point so that I dont have to change/re-connect all my devices and also it has WPS. But, the connection speed thru the orbi-access-point dropped from 160-200 MB to 50 MB. I thought the ethernet-cable is reducing the speed and ordered a brand new cable on amazon with the spec that states 1 GB connection speed. With this new cable, the speed further dropped to 30 MB. So, dont know if this is still the cable issue or the LAN-port itself has a significant quality issue. There are more issues with it. 
  3. Before I attempted to connect the orbi access-point, I had configured/setup my chromecast and google-home-mini devices to connect to the t-mobile-wifi and tested them working fine. Once after I connected the orbi-access-point to the LAN-port, those device connections started mis-behaving. None of the streaming worked. I can change the TV sound via Google-Home app and I can see the TV display the sound level. Thats about it. When I try to stream / cast from youtube or youtube-tv apps, the chromecast (TV) attempts to load the app, but never starts the streaming. I suspect the LAN-port connection messed up the wifi configuration and you dont have an option to correct it. I had to factory-reset the device to get it back working.
  4. When above issues arise, both the mobile-app and the web-app choke. They stop responding. This gets corrected after rebooting the gateway device. But, the gateway app service is very choppy and rudimentary. It feels like tmobile (or nokia) hired high school kids to write these services as part of their school project. This is really a shame. 
  5. After factory reset, I had to re-do all my device connections for one of the two chromecast to start working and the two google-home-mini’s started working. I have one chromecast still not working. Right now its failing to make the wifi connection half way through the setup. I will call google to see if they can help troubleshoot it.
  6. Device reboot forces the device to get new public-ip-address. I require my ip-address to be whitelisted on my office connection and I have to go update it everytime I reboot the device. 

Here is the summary.

  1. The 5G-WAN connection seems to be very stable in my 4 days of testing. 
    1. I let four video streaming services run for 12 hours and didnt see any throttling. So, the service seems to be truly unlimted bandwidth (at-least for now). 
    2. I let my laptop on a SSH connection running a test command in the loop for 12 hours and it did not loose the connection.
  2. The wifi-LAN (WLAN) is super basic and buggy.
    1. I am hoping tmobile can release firmware/patch quickly to remediate the issues. They must troubleshoot and make the ethernet-port connection to access-point device working at high-performance and just like an access-point supposed to without messing up the WLAN. 
    2. Add WPS. I am not sure if this requires a new device but it will be cool if they can add it as a app feature either on the mobile app and/or on the web app.
  3. For now, I have my main connections that I rely on daily basis all working and I will continue to use it for a month and make a call if its worth keeping. For me at this point, connection stability and speed are super important and will post an update if those have any issues by end of month. 
Badge

Try removing the useless battery then do a factory reset and see if a lot of issues go away.

No Ethernet connected when doing a factory reset

Use the bottom Ethernet connection instead of the top.

If you don’t use the WiFi disable all 3

 

I don’t use the crap app anymore.

Keep the admin password default that way you can reconfigure from Ethernet (password saved)

After a reboot or factory reset it does take a while for all the info to display give it time. 

Badge

The only thing remaining flaky with my equipment is the On/Off switch doesn’t always work. 🙄 The equipment, it’s firmware and the service (in my are) stink. I’m really, really losing my patience with this. 

ok guys here it is, IF YOU ARE CONNECTED VIA BLUETOOTH, IT WILL NOT SHOW UP IN YOUR WIFI SETTINGS. disconnect the gateway from blooth and go back to your wifi settings, you should see it now.

 

you are welcome.

B.

Reply