Question

all pdn ip connection failure

  • 31 October 2021
  • 14 replies
  • 3431 views

Badge

So after the recent update it seems like anytime I connect to a Sprint tower (that I having been using for months. B26 and B25).

I don't get this error if I connect to a tower much further away from my house (that's a T-Mobile tower) no problem, no errors, other than of course terrible speeds because of poor signal.

Just wondering if this is a known issue?

One thing to add is my cell phone connects to the sprint tower no problem, so it seems like a issue for just TMHI / "trashcan".


14 replies

I am as of today having the same issue and told they are working on my tower. I am trying to work from home and my son is trying to get school work done and we are both frustrated. I was told to call back at 5 if still not fixed. 

Badge

I connected to a Sprint tower my 1st month of service with B25 about 2.5 miles away. I was suddenly pushed to a tower 6.5 miles away and a B71 band. I went from >40Mbps to < 20 Mbps. with service below 5Mbps during hi use periods. I noticed an error when try all the tricks on the internet to connect to the closer tower. The Sprint tower is visible with zero obstructions between it and my house. I would get 3 bars for a minute with no connection to the web and then drop to B71 farther away. Finally I captured the error code, “PDN IP Connection Failure”, for some reason T-Mobile prohibited me from using this tower. My neighbor has been on it for 4 months. Has anyone gotten to the bottom of the “PDN IP Connection Failure”?

Thanks

I am having this “All PDN IP Connection Failure” error code as well. I have called T-Mobile’s support for 5 days in a row and no one can tell me what it means. They are just trying to say the coverage isn’t good in the area, despite our alcatel receiving full and very fast signal, and my boyfriend’s iPhone has full bars of 4G LTE coverage. The 5G gateway is showing 3 connected bars and looks as though it is working, but no pages will load on any devices. I believe our closest tower is a Sprint tower. Does anyone have any advice? This is really my only high speed internet option where I live and I am desperate. 

I started TMHI service a couple weeks ago.    I’m 0.6 miles from a T-Mo tower.  The signal has been strong.  5G, 3 bars, decent Mbps.  Lost connection 2/18/22.  T-Mo tech said it was a tower issue. 

To those who have experienced the “PDN IP Connection Failure”:  Was your TMHI service eventually restored?  Or did it become a long-term, unresolvable issue?  Please reply. 

I’m experiencing the same issues. I got T-Mobile home internet just over 2 weeks ago. Had blazing speeds, everything was working flawlessly. Then a week ago I lost all connection and kept getting the “PDN IP Connection Failure” on my Nokia trashcan. Multiple calls/hours on the phone, multiple factory resets, etc, didn’t fix the issue. I’ve been sent 3 different Nokia trashcans in the past 6 days since Tech Support didn’t know the cause. All 3 do the same thing. I have not had internet for over a week now. The last tech support rep I spoke with finally told me my gateway was not connecting to the appropriate tower. Apparently my gateways are no longer connecting to the tower near my house, instead it connects to some far off tower miles away and no web pages will load. I am beyond frustrated. I don’t know what I’m supposed to do. They elevated the case to have someone else look at the problem, but this last week has been so frustrating I’m ready to ditch T-Mobile for good if they can’t fix this issue. 

So i just got off the phone with T-Mobile home internet tech support. So after getting my 3rd placement my line for the Nokia Gateway was canceled. I am being sent the black device. I spent hours of troubleshooting & being told they don't know what the error message was. I talked to a supervisor & was told that the error message was caused by a loop. The firmware updates failed & has caused the device to have PDN IP Configuration error. I would call them to have the new device sent out ASAP.

Why hasn’t anyone from T-Mobile replied? I’m having the same issue and haven’t found any reliable fixes from internet searches.

Same issue, been happening since May 15... It's now May 25.

 

I've called T-Mobile so much I'm tired. I'm pretty much going to give up at this point and get another service

Badge

New sim card and two trash cans later same issues persist with me finally being sent the black device I hope this one is better than the trash can it's the only good internet in my area and my ol lady relies on the internet for her work from home job to TMobile y'all need to figure out what the PDN IP codes are and y'all need to figure out what "modem chip down" is I'm so sick of these two critical and major alerts that prevent my wifi from working I understand service is only 55$ but I'm also not gonna pay for service I'm not receiving yet again 

5 calls later I got a rep that seemed to know what the PDN error was.  He had me remove the SIM card and then he changed the frequency of my gateway to better talk to the tower after it booted back up. So far it's back to normal with no errors. 

Userlevel 6
Badge +6

I know it sounds like Greek but well… “The PDN connection is a logical connection between a specific IPv4 address and/or IPv6 prefix allocated to a UE and a particular PDN. This is the user IP connection. This is a common feature in mobile networks where the user plane is tunneled over a transport network in order to provide per-user security, mobility, charging, QoS, etc.” Science Direct

https://www.sciencedirect.com/topics/computer-science/network-connection

My guess is the programming of the equipment for the radios is in need of attention. Something fundamental is amiss for the user’s IP connections. I found the information and just took what is more specific to the conversation. You asked.

Userlevel 6
Badge +6

Just speculating a little more given the relationship between the SIM card and the behavior. The PDN connection is probably related to the external IP not internal IP addresses. That is where they would enforce security and controls when the node joins the network. The SIM and the ICCID provide the device/user identification for verification. The ICCID is specific to the SIM. The IMSI number is specific to the user so the combination of the two connect the device with the SIM to the user. If any of that does not add up no PDN connection will not be formed.

Sorry, just thinking it through. If the support database had a proper search engine and included data related to the error codes then the front end support people could probably go to a second level engineer and provide answers that clarify problems so users don’t feel like no one knows squat. Providing info as such might be way over the top for most users but if it is relayed at a level that makes sense to the common user then it could help. I myself like to have answers to odd issues. Sort of like on the WIFI statistics why does the gateway always report “Sent Errors” on the WIFI networks? What does “sent errors” really tell anyone if no one can translate what these are? 

I wish TMobile had real support for this type of issue.

I am getting more answers on Reddit than I am from any help desk or Tforce on Twitter.

At this point, I think early adopters of TMobile internet are getting throttled because the product is oversold and it is causing slow downs for new customers. They want new customers to stick around. My internet is consistently down Sunday - Tuesday. Then Wed - Saturday, it miraculously works.

No one at TMobile can help and if it blips again (been happening since May 15th) Sunday, I’m giving up. 

Userlevel 6
Badge +6

Depending upon the gateway you are using that might have something to do with the change. If you have the LTE WI-FI Gateway you should inquire about upgrading to the 5G solution or at least give it a test drive and consider it. If you have an iPhone put it into Field Test Mode dial, *3001#12345#* ,enter and look at the cellular information. If you have a phone that only supports LTE that might explain the behavior. T-Mobile may have upgraded equipment on that tower and now the equation has changed. If you get the PCI information from the gateway for the cells then you can use cellmapper.net and look for the origination of the cell sources. If tower changes have been made then maybe a relocation of the GW in your home might help but not if T-Mobile is currently making changes and/or improvements on the equipment.

  • Network Bands T-Mobile Operates 
    • 5G bands: N41, N71
    • 4G LTE bands: B2, B4, B5, B12, B71, B66

Sprint & Boost Mobile owned B25/B26 and T-Mobile uses the ABOVE 4G LTE bands with the home internet GWs. So what sort of gateway are you using? 

 Nokia 5G21 GatewayT-Mobile LTE Wi-Fi Gateway, or Arcadyan KVD21

Reply