Question

Anyone else had FTP problems using Hone Internet?

  • 14 September 2021
  • 11 replies
  • 141 views

Badge

I am testing T-M Home Internet and although it has Ben generally good so far, I just ran into a problem when I attempted a routine FTP upload using CyberDuck to a website I maintain. When I try to connect I get an Interoperability Failure message. My ISP says the website is fine and they are able to FTP to it and it t seems I have some kind of communication or network problem.

 

What are other people’s experiences doing FTP on T-M Home Internet?


11 replies

I’m using ExaVault.com without any problems. They are a paid for FTP service.

Badge

Thanks for that info; it’s good to know that FTP can work in some situations. I have now managed to speak with a TM  Home Internet support expert. He searched through trouble reports and found that FTP being blocked was a known problem and was being actively worked on.He was surprised the problem existed. He mentioned Port 80, number of  ipv4 and ipv6 addresses  available ,etc., and apparently there were different aspects to the bug and/or the trouble reports. He said  my free trial would be extended pending resolution of this issue.

Badge

UPDATE

One day after my conversation with TM Support, I received a voice message from the expert. He has now changed his story. He says the gray tower TM gateway does not support FTP. I am disappointed and confused. If he’s right, I shall shortly be returning the gateway.; lack of FTP is a showstopper as I maintain a club website. There must be quite a few other home users who maintain websites for families, churches, clubs, etc.

Userlevel 1

Turn off Passive mode (or pasv) in your ftp client, after that ftp will work just fine. You may need to enable “Port mode” in your client as an alternative to “passive mode”. I believe the last person I told to do this was even using Cyber duck and once they did so it worked fine

Badge

Jayke, thanks very much for this information. It’s just the kind of advice I was hoping to get.  I’ll try your suggestion when I get home tomorrow evening.

Badge

Well , I tried disabling passive mode in. Cyberduck by going to proxy preferences and deselecting it. Unfortunately, this seemed to have no effect; I still got the interoperability error message.  I tried also selecting Auto Proxy Discovery, but this did not help. I then tried bypassing proxy settings for my target site; no help.  As you. can probably tell, I was getting out of my depth and just groping around. Any suggestions welcomed!

Badge

In case it’s relevant, I am running Cyberduck on MacOS, and it has worked on many different networks over several years.

Userlevel 1

I’m not sure where you’re seeing proxy settings but you shouldn’t need to mess with them at all. I just downloaded and tested cyberduck. All I did was click “Open Connection” then type in my server, username and password. At the bottom of the window  I clicked “More Options” and i changed “Connect Mode” from “Default” to “Active (PORT)” then hit connect and it all worked..

It probably is also worth noting FTP is a technology that has been out of date and considered insecure for a very long time. It has been highly recommended not to use FTP for anything other than anonymous file transfers (think software distribution) since the 1900s. You should ideally use SFTP or SCP to upload files to your web hosting provider

Badge

I really appreciate the trouble you are going to to try to help me Jayke. It seems I am just a click away from finding a solution, but which click?!

 

I went to proxy settings because that’s where I found the option to turn passive mode on or off.

 

I see no “more options” at the bottom of the open connection window—I am guessing you are using the Windows version of Cyberduck, whereas I am on MacOS. (With its firewall turned off.)

 

I understand what you say about FTP being old technology lacking in security. However, when I took over the club website from my predecessor, he was using FTP so I did the same. There is no financial transaction or sensitive information on the website.

Badge

UPDATE

I installed Forklift,  turned passive mode off, and connected to my website without problem. This is not the I  app I want to use, but this confirms Jayke’s advice, and confirms there is nothing wrong with my laptop or my target website.

IThe issue of correctly configuring Cyberduck to work in non-passive mode remains, however. I  attach a screenshot of what I see when I open a connection on Cyberduck—no “more options” drop-down.

Badge

SUCCESS AT LAST!

 

I have finally learned how to switch macOS Cyberduck from passive to active mode, and it  is now  working on the gray tower-TM Home Internet.

 

For anyone else in the same situation, here is how to do it.

 

(1) Edit a bookmark rather than just opening a connection. This will show a “More Options” drop-down.

 

(2) Open “Connect Mode” and select“Active (PORT)”

 

I am just hoping T-M does not make any changes that will stop this from working…

Reply