Solved

Canon printer will not connect to T-Mobile 5G Gateway home internet

  • 15 July 2022
  • 9 replies
  • 1003 views

Badge

I have the Arcadyan KVD21 Gateway and a Canon PIXMA TR4520 printer. I have tried multiple methods to connect the printer to the T-Mobile wifi network and am still unsuccessful. Currently, I am attempting setup using the Canon Wi-Fi Connection Assistant. In Network Settings, the T-Mobile network encryption type shows up as Do Not Use. Is there a way to change the encryption type on the network? Would that enable the printer to access the T-Mobile wifi? Any and all suggestion welcome. I have tried T-Mobile tech support, but they cannot help, saying it's a printer issue.

icon

Best answer by SSW 15 September 2022, 02:51

View original

9 replies

  1. I have a very similar issue only the gateway was originally connected to my Canon MX922 printer, it’s only after I went back to the orig name and passcode for the gateway that I can’t connect it again.   I use a MacBook iOs version 10.15.7.  There are 6 devices connected to the gateway.  I think one of them is the printer as I see it on the list when I try to connect to it on the printer.  There is no access point on the gateway.  I just want to enter the new password which it won’t allow me to do.  I’ve checked with canon.  They don’t have a fix.

Canon G5020 won’t connect to home internet tower.  It sees the name of the tower when I try to do setup on the printer but won’t auto connect.  If I use manual connect, i type in the password from back of tower but it says wrong.  I have 6 other devices connected, know how to type and have typed it in over a dozen different days and times trying to get a miracle to happen.  What do I need to do?  

 

For my Pixma MG5420, I had to change the WPA version on the Tmobile gateway app (Network tab, select your wifi network, under WPA version, change to WPA/WPA2 from WPA2/WPA3).  Then on the printer, go to Device Settings ->LAN settings, ->wireless lan setup, ->Other setup options, ->Standard setup,->select access point, → Directly enter the access point name, then manually enter your wifi network and the passcode.  Voila!  This is after a fruitless call to Tmobile tech support, which described the problem I had connecting to a printer problem, and transfer me to Cannon tech support, which never connected me to a live person, but instead directed me to their website, then hung up.

Badge

What SSW posted will probably fix it. Change the encryption to WPA/WPA2. I had a Microsoft Surface Pro tablet that wouldn’t connect because of that.

Thank you SSW, that absolutely fixed it!!!!!

SSW, you helped me, too - thanks so much!

Thank you so much!  I have been struggling with this issue for a month or so on my Canon PIXMA 922 printer.

I now have a working printer.  YEAH!!!

Thank you sooo much for this. Was having the hardest time figuring it out. Thank you. 

Thanks SSW.  Your suggestion helped me work through getting my ancient Canon MX870 connected to the gateway.  
Now, on to the PIXMA 5300 printer.

Toyman

Reply