Question

GlobalProtect VPN not working with T-Mobile


Badge

I have seen several posts about VPNs not working with T-Mobile Home Internet. What is T-Mobile's plan to address this? I contacted my corporate IT department and they said it's not their VPN. All works fine on my old ATT home internet and Verizon Hotspot (work cell). Maybe I should drop T-Mobile Home Internet and go back to ATT.


31 replies

Badge

Just got my new T Mobile gateway and set it up.  Exact same issue with exact same VPN.  Nothing works on it!

SOLVED! After days with my IT department and then with Global Protect in Pali Alto, here’s the bottom line. T-Mobile High speed broadband can’t handle IPv6 dynamic IPs therefore can’t communicate in internet. Global Protect can only handle IPv4.

There are no settings on T-Mobile gate way to make it just use IPv4.
Global Protect doesn’t have a fix/VON software to fix this advanced IPv6 communication 

I can access my company’s server for data files, outlook for email etc, but cannot access internet based apps like one login or any websites. Except MSN.com - explain that. Not even Google. Com.

Have to switch to my Verizon cell data hotspot to my company laptop to access internet. Then switch back to T-mobile when done with internet  

T-Mobile is using advanced technology that companies are not ready to handle, and will take them a long time to become compatible.

Since most users don’t have IOv6, there’s no rush to upgrade corporately. For example, they advise that all the scanner guns in our warehouse aren’t compatible with IPv6, so if they upgrade VPNs now, none of the equipment would work in the warehouse.

Nor are VPN providers putting resources into IPv6 compatibility.

im so annoyed that I switched to the T-Mobile high speed broadband new technology that NO ONE at T-Mobile advised this would be an issue. Even calling tech support, they had no idea what the issue would be. After my IT department figured it out I HAD TO CALL BACK T-MOBILE AND BRUNG THEM UP TO SPEED.  Am I in the twilight zone? Ridiculous 

So much for all this infrastructure across the US. If we get this new technology, then can’t connect with old technology being used by 99% of corporations, then we’re screwed until they decide to upgrade.

How can this be such a mystery in 2021. IPv6 has been in development for more than 10 years.  WHAT’s the holdup and lack of warning of the issue.

So annoyed that I switched to this with no heads up. I’m screwed now unless I switch back to my unreliable Cox cable internet that had service outages at least twice a week while I’ve been working from home.

 

Thanks for the info, KnappTime2515.  I have the same problem and I think knowing that IPv6 is the problem might let me fix it.  I’m using my own router between the T-Mobile gateway and my computers.  I think maybe having my router accept IPv6 traffic but use IPv4 on the LAN might work around the problem.  If you have a router available, you might want to try the same thing.  It would be really nice if T-Mobile gave us the option of not using IPv6, though.

Just got T-Mobile internet to replace my art 4g internet. Same issue. Will not work with global protect. 
 

did T-Mobile provide any kind of update. The speed is way better than att but if I can’t use it for work sending back the router and cancelling the service. 
 

interesting I did ask them about restrictions with vpn’s as I encountered that problem with satellite and they did not raise this issue. 
 

just curious if the router solved the problem. 

No luck so far.  I even had T-Mobile roll back the version of my gateway’s firmware, because I had heard that fixed the problem for some people.  The service rep said he couldn’t do it, but when I said I needed to cancel my service then, suddenly it became possible.  It did get a little better, some web pages eventually load, but it’s still not usable.

I have one last thing to try.  There are some people who say lowering the MTU setting for globalprotect to 1350 or less might solve the issue.  I doubt it will work, but I’m going to try it.  I don’t have access to do it myself, but I’ll try to get the IT guys to do it when I’m in the office on Tuesday.  If you have admin access on your machine you can try it yourself:

netsh int ipv4 set subinterface “Ethernet 2” mtu=1350

Replace “Ethernet 2” (keep the quotes) with whatever name your computer uses for the globalprotect virtual interface in ipconfig.

I can confirm that lowering MTU worked for me. I set it to 1300. 

I contacted T-Mobile support. They indicated the software on my router had been updated to latest version which had issues with global protect. They rolled me back to previous version and it started working. It took 2-3 days, but I have been using it since Friday and all seems to be working. 
 

not sure if they did anything else that I am not aware of. 
 

hope this helps. 

Also confirmed reducing MTU value in netsh configuration resolved GlobalProtect VPN issue for Windows 10. 

NOTE: You need root/admin access to be able to change it through command line.

1. While connected to VPN, open a Command Prompt CMD (Right Click CMD -> Run Ad Administrator)

2. To verify your Virtual Ethernet Adapter Interface, Type the following:

netsh interface ipv4 show subinterfaces

Change Windows MTU Size

3. As mentioned on the above replies. credit Rich T, Type the following: 

netsh int ipv4 set subinterface “Ethernet 2” mtu=1300 store=persistent

Replace “Ethernet 2” (keep the quotes) with whatever name your computer uses for the globalprotect virtual interface in ipconfig.

4. Test your sites

Browse some Corp and Internet sites while connected to the VPN.

Note: You may have to restart your VPN connection by disconnecting and reconnecting. 

Allso ref: https://amithkumarg.medium.com/resolved-t-mobile-home-internet-vpn-issue-2f5ca594c23e

It took a while, but I finally got my IT dept to lower the MTU for me.  They refused to use netsh for some reason, but they were able to set it through group policy, or maybe it was a registry setting, I forget.  Anyway, they set it to 1350, and everything seems to be working now.

Fixed immediately … T-Mobile tech rep advised they need to downgrade my gateway firmware and they set to stop automatic update to prevent reverting to the update. Fixed it immediately. Unreal that he was only T-Mobile rep who had this knowledge,

 

needed to downgrade to ..,,168 from ..,178

see below 


 

WRONG;


 

Correct firmware version:

 


 

 

This is strange. My trash can is on firmware .0178 and my company uses GlobalProtect VPN and I’m able to connect every day without any problems. Occasionally a page will fail to load and I have to refresh a few times, but that’s the only issues I’ve noticed. In fact, it wasn’t until my trash can upgraded to .0178 that I was even able to connect to my work VPN.

Maybe it’s a setting on your company’s VPN and not T-Mobile? \_0_/

Trash can?

it depends if your company infrastructure is ready to handle IPv6

“Trash Can” = the grey, cylinder modem/router from T-Mobile lol. It looks like a trash can

Fixed immediately … T-Mobile tech rep advised they need to downgrade my gateway firmware and they set to stop automatic update to prevent reverting to the update. Fixed it immediately. Unreal that he was only T-Mobile rep who had this knowledge,

 

needed to downgrade to ..,,168 from ..,178

see below 


 

WRONG;


 

Correct firmware version:

 


 

 

This solved my problem and the T-Mobile rep took care of this very quickly for me when I called and asked to have my firmware update rolled back.  Thanks for sharing!!!

Badge

Not sure I understand the why??but all webpages and my cloud providers load just fine for me? I have private Internet access as a VPN and have no problems, download speeds are slowed down a bit with the VPN on but that was true with my last service provider. 

I’m experiencing this same issue and it seems there are two possible solutions -- 1. Get my corporate IT to drop GlobalProtect’s MTU setting to 1300, or 2) Get T-Mobile to roll back the gateway firmware version to 168 (and turn off firmware auto-updates).

Is one solution better than the other?  Do both?  Go back to Cox?

Advice appreciated,

Superfly

Lowering the MTU to 1350 worked for me !

I ended up calling T-Mobile support, and was pleasantly surprised to be quickly connected to a knowledgeable support rep. who instantly -- as soon as I said the words “GlobalProtect VPN” -- knew what to do.  He rolled back my firmware to the prior version (168) and my issues immediately resolved.

 

 

Userlevel 4
Badge +3

With any luck the new firmware they started rolling out last week will finally resolve the VPN issues.

 

Now if they could just put a proper dual-stack configuration in place so port forwarding would work....

I had the same issue as everyone was saying. I called the support, they rolled back firmware version to 0168 on the device. But i still not able to access internet while i am on VPN. I am able to connect but unable to access internet over VPN.

Change Windows MTU Size

3. As mentioned on the above replies. credit Rich T, Type the following: 

netsh int ipv4 set subinterface “Ethernet 2” mtu=1300 store=persistent

Replace “Ethernet 2” (keep the quotes) with whatever name your computer uses for the globalprotect virtual interface in ipconfig.

Confirmed this one works on Cisco Meraki VPN.  My VPN was connecting intermittently.  When connected, download speed was only ~45kbps.  It was enough to see files on the network but took forever to download anything, and was unable to load any website.  Once I changed the mtu size from the default 1400 to 1300, everything works just fine.  My gateway has .178 firmware.

 

My symptom was a little unique, but it might help somebody else with the same issue.

I was able to successfully connect thru GlobalConnect, however occasionally I would lose internet connectivity.  Of greater importance, I was unable to maintain a RDP connection to Windows Servers (2016 and 2019).  I could connect to the server, however it would drop after 20-30 seconds.  RDP connections to Workstations running Windows10 worked fine.

T-Mobile support downgraded my firmware to .0168 (as mentioned above).  My RDP sessions are now working as expected.

Also as mentioned above, as soon as I said “Global Protect” to the T-Mobile support person, they immediately knew what to do (downgrade the firmware).

I just received my Gateway over the weekend & ran into this problem w/GlobalProtect this past Monday.  Microsoft Outlook & Teams worked fine, but no web access.  As of Tuesday, the 24th, at least here in the Washington, DC, area, T-Mobile’s solution is still to roll back the firmware.

Hey all,

 

Same problem as most, wife’s now WFH and her work laptop’s VPN GlobalProtect would connect, but upon connecting, she couldn’t actually access any sites.   And her work was unwilling to make the MTU adjustment.

 

Called T-Mobile Home Internet Tech Support at 844-275-9310, tonight on Sept 2nd 2021.  After a decent hold time, the representative got on the line, told him we had the GlobalProtect conflict, and he seemed to know immediately what to do.

 

Interesting part is I asked him what they were going to do, and he said they would NOT roll back to .168.  Instead, he said T-Mobile has recognized they had issues with not only GlobalProtect but also other VPNs (believe he mentioned Cisco), and so their engineers have been working on it. 

 

He then remotely put our router on version 1.2101.00.1609.  (before the call we were on .0178). My wife then got on GlobalProtect, tested all her apps, and at least with a few minutes of testing everything seems to be working well now. 

 

Thanks for everyone who posted info about this problem on this thread.  **hopefully** it’s fixed now with this .1609 update that we just got.  A few more days’ testing time will conclude one way or the other.

For ordinary computer users understanding how VPN works is not a fun task, while most Americans even never heard the word. If you are a T-Mobile user, VPN setting issues can be resolved without inventing a new wheel or spending a whole day for settings unless you enjoy it. 

 

This was my solution which was reasonably quick and trouble-free. After I read articles above posted by other frustrated users (or grateful pioneers) I called T-Mobile tech support and pinpointed what I should ask for. The tech guy understood the task immediately and jumped into the “upgrading” a feature in my modem. He called back about 20 min later to declare the success. I like T-Mobile once again.

Reply