Question

Google Services Being Blocked by Home Gateway


Badge

For the past four days, we’ve had issues with not being able to access certain websites, including almost all google services (including gmail and youtube), cnn, as well as my work (no income != no good). 

I’ve tried all variety of fixes, the only thing that works is to run the connection through a VPN. Everything works find then. This narrows it down to an IP/DNS issue on T-Mobile’s end. What gives? Who do I contact to get this fixed? 


9 replies

Userlevel 1
Badge +1

I have not seen these issues, but here is where I would start.

  1. I am sure that you restarted the gateway and the device(s).
  2. If you are using a secondary router (or mesh), restarting that too may help.
  3. If you are using a secondary router, I have read that there are some issues with the MTU size. (But I would not expect that to be an issue starting over the past 4 days.) (I do not have specific references to the MTU concern, but if you search in the community you should see the discussions.
  4. Some folks are updating the DNS on secondary routers to include a public DNS server such as Google. (8.8.8.8) so that if T-Mobile has DNS issues.
  5. I just recalled seeing some folks on Facebook saying that a firmware update is rolling out. You may be a victim of a bad install. A factory reset may help.
  6. In regard to help, I contacted support through direct messages on Twitter. Response times have been pretty good.

Sorry if not much help. Good Luck.

 

Badge

Hi Steve. 

I have my DNS set to Cloudflare’s. Before it was just TMobiles. Using cloudflare, I can access CNN just fine now, and even youtube is loading again. Gmail is still not loading at all, or loading very slowly. According to the reddit thread, several other people are experiencing the same thing. (https://www.reddit.com/r/tmobileisp/comments/n1iiyl/firmware_version_12003030178_megathread/)

I can’t figure out how to get my firmware updated from ...0168 to 178.  There doesn’t appear to be a download link or a way to force the router to download it. It’s very confusing that we’re so limited in what we can do with the hardware. I find it highly frustrating that we’re at T-Mobile’s mercy for much of this.

Userlevel 1
Badge +1

In regard to Gmail; another suggestion to try is to clear cookies or try another browser or private browser session. I had several sites that would not load that I previously used but would load in a private session. Cleared the cookies and all was well.

 

I have not heard anyone being able to force the firmware update. The limited success I saw on Facebook was that a factory reset was done and it installed by the next morning. I have NOT done a reset and I am still on the 0168.

Badge

In regard to Gmail; another suggestion to try is to clear cookies or try another browser or private browser session. I had several sites that would not load that I previously used but would load in a private session. Cleared the cookies and all was well.

 

I have not heard anyone being able to force the firmware update. The limited success I saw on Facebook was that a factory reset was done and it installed by the next morning. I have NOT done a reset and I am still on the 0168.

Yes, I’ve done different browsers, cleared cache and cookies, I’ve cleared the dns cache in my OS (Kubuntu) and tried several other things. Nothing makes it better aside from using the VPN. I’m also noticing that when I change my DNS settings in my OS, it doesn’t take effect like I expected on the router, so I might look at that a little deeper.

 

Userlevel 1
Badge +1

It is interesting that VPN works. This leads me back to the MTU. If you are directly connecting to the gateway via ethernet or Wifi with your Kubuntu, you may want to check out reducing the MTU.  This article may be beneficial. It discusses Windows and MAC.

https://homenetworkgeek.com/mtu-size/

 

Badge

Steve!

I’ve adjusted the MTU along with pushing a different DNS and things appear to be working right now. We’ll see how goes for the rest of the day and onward. Thank you for your help and suggestions.

Badge

...Update…

Not everything is working yet. Others in the house have informed me that many images are loading slowly or not at all, and quite a few pages are throwing errors such at 503 not found and others.

This includes Amazon (intermittently), and a few other odds and ends. This is quite peculiar and I feel it’s related to the outage of T-Mobile’s service on Thursday when the router/modem entirely lost connection and shut our wifi off for about three hours and just said “connecting” with a yellowish dot during that time. By morning, the modem was back up but sluggish. Since then, we’ve had nothing but problems both with the wifi and the network.

Userlevel 1
Badge +1

I personally do not use the wifi on the gateway,  but I have read that many have issues with it. By default it has 3 channels with the same SSID to allow auto negotiation.  Some threads I read said this is not working well and connections do not move off 2.4 Ghz. You may want to put in separate SSIDs.  As a test, you may want to enable another 5ghz channel and test with one of the devices that seems slow. You also may want to make note of the speeds with Fast or Speedtest to see if anything seems to help.

There may be a couple other tuning settings in wifi that may help. I do not recall specifics. Try search this community for wifi. Good luck.

Badge

You’re spot on, Steve. The 5ghz channel is much better as the 2.4ghz is very weak. I’ll be using my ASUS router as a repeater and also changing the name of the 5ghz channel before I set up the repeater. I have to keep the 2.4ghz because I have a decade old HP Deskjet that works on that frequency only. (Its so dumb you have to plug in a USB cable to use wifi, but that’s HP for you.) 

I think security cams only work on 2.4ghz as well…

Anyhow, I very much appreciate your help. It’s nice to be able to access the internet again.

Reply