Question

High-Speed Internet Gateway will not lock to 5G speeds (5G21)


Userlevel 2
Badge

T-Mobile stop treating as if this is a phone. I have searched and searched and can not find answer. 

I live in an area where 4G, 4G LTE, and 5G is available. However the 5G signal is weaker than the other, so the gateway goes to the strongest signal. Stronger is not the fastest. When I can get it to connect to 5G for moment the speed is 250 Mbps download; but what happens the signal competing with 4G which drops my connection to 50 Mbps. I have a 5G phone it connects with no problem in certain areas of my home. 

What I need is the ability to only connect to 5G in the settings. Anyone have a solution until T-Mobile fixes this problem. 

Should be easy fix to just say only connect to 5G, and based on some of the reviews I think this is more of a common problem than T-Mobile understands. Anyways, anyone else experiencing this issue and found a solution?


23 replies

Userlevel 5
Badge +5

Yeah...  I am holding out as long as I can against going back to Spectrum.  Got tired of the rate increases, continually haggling for a $10 discount.

 

Rate card says "up to 200mbps"... but no matter how many times I asked, they would not lift the 100mbps cap on our line.  Even when I called to cancel and  told them that was specifically why I was cancelling--over 4 years base price kept going up from $60 to now $75, while we were still limited to 100mbps.

We've had that line active in some capacity for 41 years... and they just refused to do right by us.  My dad was on one of the crew's that was rolling cable through the Carolinas in the 70's.  I ran a dedicated line for our internet TWICE (first was base RG6, then later to quad-shield with copper core, not that copper clad steel crap).  So it is a SUPER clean line... techs are always shocked how little drop there is from ther tap after the ~78 foot run.

$50 for 64/14 with TMO, versus their 108/12 for $75.  Tested to the same location while I was on the phone with them.  All they offered was a $10 discount for one year--which was still resulting in a $5 increase from what I had been paying.

Enough was enough.  I countered... if you will lift the cap to the published 200 that we know the line is physically capable of and your own marketing tells us we can get I would reconsider and they declined.

 

So, kicked them to curb.  And now they are bombarding me with offers for $50 for one year.   Even had a rep come to the house TWICE!  And my response again... lift our cap to the advertised 200 and we can talk.

No can do…

So, no soup for you!

Userlevel 2
Badge

On my 5G phone, is it utilizing B66 - labeled as LTE+5G, just did a speed check this morning. On this band, in the Cortland NY area, getting 291 Mbps down and 22.5 Mbps up.  The 5G Home Internet Gateway keeps going to band B2 (700 Mhz), getting 58 Mbps down and 24 Mbps up. Not this is not terrible speed, but when you have speed that is 5 times this available and it is simple a software issue, very frustrating. This is particularly true for games today 100 GB or more is not uncommon. 

Userlevel 2
Badge

Update, patience. A new tower or new bands, whatever the issue was is no more, sort of. First, 100-150 downloads is my new normal, uploads are hanging around 50 Mbps. I have had speeds near 500 Mbps those are rare. I am getting several bands now n41, n61, and now B4, they seem to rotate depending on available bandwidth and weather. Also noted my 4G LTE phone is now back to around 130 with solid 45 upload. So I take this is all the transition going on, I glad my issue is resolved by patience. I think this will be the case for many having the same issue, if you can afford to wait. Very happy now.:grinning:

Userlevel 2
Badge

With a better understanding now, I realize my best is going to be 50-70 down and 15-25 up connected to Band 2. B66 band at least for me has been very disappointing. After getting it to lock on to 5G, the speeds were 15-20 down and 3-5 up, and some sites would not work. Again it is not coverage in my area that is the issue. I have a S20 5G phone which connects to B66 it gets 200-250 down and 12-25 up. So it is one of two obstacles here, one Nokia modem hardware/software and/or T-Mobile downgrading its performance as phone’s have preference. Either way, I just going to be happy with the Band 2 for now. I do have a recent option to go Spectrum as they just added cable in my neighbor, though I have heard of surprise bills and terrible customer service so on the fence. Thanks to all those whom gave me feedback.

Userlevel 2
Badge

Only been a couple of days but this is so aggravating, I want to like this solution but only if I can keep it connected to 5G. I am concerned this is going to be like T-Mobile previous solutions and never gets the firmware needed to make it successful. Any thoughts from anyone?

Userlevel 2
Badge

I know this threat is getting long and aging, but I hoping for a solution. So this weekend, I gave it another try. I found 5G (B66) and found a great location, with 3 bars but with speedsno better than 700 Band. So tried one more things this morning, I did a hard rest in a location which I know has 5G was working to my surprise, I got new network connection - B2 (750) and a secondary (which I had not been getting) n41 (515790?). The speed is amazing 275 Mbps down, and 10 Mbps up. It has locked on it for about 30 minutes or so then you guessed it is drops to 700 Mhz band again. So I reset and again amazing and now waiting to see how long it last. I wish I could just manually lock in these channels. Anyone had any luck with T-Mobile customer service to resolve this issue?

Badge

Same issue.  I have a ticket open for over a month with their engineers.  No resolution.  Still waiting for them to call.  I was promised a return call the last 4 times I called in.  
 

 

Userlevel 5
Badge +5

Phones and router may be using different APN's.  Have seen people in the past were able to create a new profile on the Askey's that matched their phone's APN settings.  Don't know if that is still an option or not though.

 

Home Internet is deprioritized on their networks, so it may still choke you down regardless... may actually be worse if it results in your packets getting held in queues longer.

Userlevel 2
Badge

Update, this morning I decided just to get the best location for the best signal for the B2 700 Mhz band. Was getting 70 Mbps download and 25 Mbps upload. Said to myself that will fine for now. Then a few hours later, the gateway is on B66 - 5G. But why did I noticed this, the speed was terrible 16/5. So I started playing with the best location for the gateway, I have it hooked to UPS and tried different position in my area where I know 5G works great on my phone. The whole time it locked to 5G. So my initial issue fixed only to read what djb14336 stated by deprioritized on the network. I think he is right.  So even if you are fortunate to get B66, T-Mobile has given this last priority status on the network. I go to test over the weekend, see if it gets any better or worse or loses 5G again. 

Userlevel 2
Badge

For me not only time was the solution, finding the right spot. Sometime it is just rotating the device and seeing how the signal changed especially if it is fringe signal. Sometime right next to a window is not be signal, for me it was right in the middle of my home. Though right now I do have it in the window turned just right for 4 bars. Hope this helps, it can be frustrating at first, but after you find the right place and T-Mobile continues their expansion, it should improve.

I know this is an old thread, but the issue seems to be ongoing.

What I did was get a directional 5g antenna and aim it at the 5g tower (n41 band 2500 MHz) so the 4g (B66 band 1700 MHz) signal wasn't the strongest. 

What I really wish is that the gateway worked with millimeter wave bands (mmWave) as I have a mmWave tower in the boulevard directly across the street from me. Not even my brand new phone uses it, so I'd guess a new version of this gateway supporting mmWave in the near future. 

Same issue.  I have a ticket open for over a month with their engineers.  No resolution.  Still waiting for them to call.  I was promised a return call the last 4 times I called in.  
 

 

Gee, just have my problem submitted a day go or so… meaning have to wait for two months maybe. Comcast just got done installing their fiber optic cable around the neighborhood and you know what that mean... 

Userlevel 3
Badge

Hi All,

 

As of right now, it is almost impossible that I know of to always lock in the 5G signal. I have though had this service for a few months now and with my experience working in IT for my local city, I have been able to figure out a few things to help get the best signal you can more times than not. I’ve actually written quite a bit so instead of redoing it all again here I am just going to link the other post below.

 

 

Hello,   

I’m new to T Mobile Home Internet (1 week),  I do not have a 5G cell phone.  I live in a large Los Angeles area with established 5G.   I am getting 4 bars on my Gateway but am only receiving speeds in the morning around 100 and afternoon speeds are about 50.  I believe, I am locked onto a 4LTE but am not sure.   I can try to troubleshoot faster speeds and locking onto a 5G tower but I need to know what I am looking for.   Doing a google search wasn't that helpful.  There is Cell Tower Metrics on my Cell using the T Mobile Home Internet App. In the App I can see information regarding the cell tower that my Gateway is using.

Can someone tell me what I look for to tell if I am on a 4G Tower or 5G Tower?   Do I look at the “Band” in the cell tower metrics?    What Bands are 5G?  Currently my Band says “B66”  is this 5G?

 

Please Advise.

 

Bob

Userlevel 2
Badge

Here we go again, after over a month of connecting to 5G network getting amazing speeds, I thought the issues I was experiencing were over. We are again back to loss of 5G network, which occurred right after the firmware update, 1.2003.03.0178.  Now I get issues during my Zoom meetings, unstable connection. I’m so tired of this BS. I am sick of T-Mobile, and the loss of customer service since the merger with Sprint. Spectrum can’t be worse than this.

Badge

Hello,

I just received  T Mobile Home Internet (2 days ago). I am hoping to replace Spectrum, but I must say that the speeds with T Mobile is slower than expected (specifically the upload), which is important to me. Speeds are up/down and inconsistent (e.g. 83/16 - 260/1)

I am currently connected to bands n41 & b2 

 

I hopefully I will get a more consistent speed and faster upload.

Update, this morning I decided just to get the best location for the best signal for the B2 700 Mhz band. Was getting 70 Mbps download and 25 Mbps upload. Said to myself that will fine for now. Then a few hours later, the gateway is on B66 - 5G. But why did I noticed this, the speed was terrible 16/5. So I started playing with the best location for the gateway, I have it hooked to UPS and tried different position in my area where I know 5G works great on my phone. The whole time it locked to 5G. So my initial issue fixed only to read what djb14336 stated by deprioritized on the network. I think he is right.  So even if you are fortunate to get B66, T-Mobile has given this last priority status on the network. I go to test over the weekend, see if it gets any better or worse or loses 5G again. 

What frequency is Band 2 LTE?

Frequency Band of 3GPP LTE FDD mode

Band No. Uplink Frequency band Downlink Frequency band
2 1850 MHz – 1910 MHz 1930 MHz – 1990 MHz
Badge

For me not only time was the solution, finding the right spot. Sometime it is just rotating the device and seeing how the signal changed especially if it is fringe signal. Sometime right next to a window is not be signal, for me it was right in the middle of my home. Though right now I do have it in the window turned just right for 4 bars. Hope this helps, it can be frustrating at first, but after you find the right place and T-Mobile continues their expansion, it should improve.

Thanks!

Badge

It really is frustrating. I was hoping to be able to get rid of Spectrum, but if my upload speed does not improve I guess I will have to try ATT.

I literally down the street from cell tower (end of the block). The tower shows to have 5G available on it, but yet I still get slow downloads.

 

 

Here we go again, after over a month of connecting to 5G network getting amazing speeds, I thought the issues I was experiencing were over. We are again back to loss of 5G network, which occurred right after the firmware update, 1.2003.03.0178.  Now I get issues during my Zoom meetings, unstable connection. I’m so tired of this BS. I am sick of T-Mobile, and the loss of customer service since the merger with Sprint. Spectrum can’t be worse than this.

Same issue for me after this same exact update.  I was able to manipulate it by disabling Wifi, rebooting, then re-enabling.  This worked for about 3 or 4 days.  Now it doesn’t work anymore.  My speeds are perfectly fine on LTE, but as you said earlier, it SUCKS knowing that you can pull 4x the speed, but can’t lock on consistently.  Hopefully it’s just a simple firmware upgrade.  I know this upgrade fixed VPN issues and Party Chat issues on Xbox, but it’d be nice if they could combine the two and allow 5G.  When I call T-mobile, they continue to tell me someone is doing physical maintenance on the tower.  Uhh… since March some dude has been hanging from the tower?  Someone should probably go check on him.

Hello,   

I’m new to T Mobile Home Internet (1 week),  I do not have a 5G cell phone.  I live in a large Los Angeles area with established 5G.   I am getting 4 bars on my Gateway but am only receiving speeds in the morning around 100 and afternoon speeds are about 50.  I believe, I am locked onto a 4LTE but am not sure.   I can try to troubleshoot faster speeds and locking onto a 5G tower but I need to know what I am looking for.   Doing a google search wasn't that helpful.  There is Cell Tower Metrics on my Cell using the T Mobile Home Internet App. In the App I can see information regarding the cell tower that my Gateway is using.

Can someone tell me what I look for to tell if I am on a 4G Tower or 5G Tower?   Do I look at the “Band” in the cell tower metrics?    What Bands are 5G?  Currently my Band says “B66”  is this 5G?

 

Please Advise.

 

Bob

I am using CellMapper to figure out which towers I am connecting to. The CGI number will help you figure out the cell tower. The first 6 digits are the network (310260 is T-Mobile) and the remaining numbers identify the tower. 

Got the Nokia gateway last Wed (May 5). Initially only got 2 of 5 bar signal strength, in metro area that T Mobile said has 5G available (I understand how that goes, “not necessarily where your exact location is” ) Still, highly motivated to get away from years of plunking down 3 figure monthly fee for landline TV and internet (cable co.). Having some skills at using web GUI’s I opened the one for this Nokia, noticed the “wireless” menu under “network” on left pulldown menu, opened each radio (2.5GHz and 5 GHz), I decided to turn off all of those (had to do it on each WiFi sub-SSID, 12 in total-- attention T-Mobile, y’all need to do some serious web page re-design to simplify that! :wink: ) since I have my own established SSID’s, and connected the gateway via ethernet to WAN on my home router. VOILA, it immediately got 3 of 5 bars, rechecked “speed test” on Google and it gets solid 40 MB/sec down, 9 MB/sec up, ping in low 30’s ms. I’m not a “gamer” so ping time isn’t a great concern until it gets over 50-- since Thursday, still solid on 3 bars, band 12 (I realize that isn’t 5G, so if there’s a disappointment, it’s that so far). 

My location to the 2 towers in my area is that I'm at the edge of the frequency range used by band n41. While I always have B66 as my primary signal, when I get n41 as the secondary signal, my download is next to nothing. Speed test usually can't even get connected.  As long as I have b71 ( a lower frequency, longer range) as my secondary signal, then downloads are as good as Spectrum. If I could lock onto b71, I would never consider Spectrum again!

Reply