Question

Home Internet IP address madness.

  • 14 September 2021
  • 1 reply
  • 63 views

Badge

I figured I could simply set the gateway IP, SSID, and password exactly the same as my old DSL modem, but nooo, first T-Mobile says my old password is too short...

Is there a way to change the gateway IP address from 192.168.12.1 to 192.168.0.1? The first time I turned the gateway on and configured it, I’m certain it not only asked me for the SSID and WiFi password I wanted, and the admin password I wanted, but also the gateway IP address.

I then went to my office next to my house and reconfigured my wireless repeater-bridge (thanks to the T-Mobile gateway insisting I couldn’t use the WiFi password I had been using) and I set it up to use 192.168.0.1 as its gateway and DNS server, with the SSID and password I’d assigned. I assigned the repeater-bridge the IP address 192.168.0.2 and the end IP to 254 (instead of the default 24) because I put my wired printer and media server connected to it at high numbers.

Saved the settings in the repeater-bridge and my desktop (wired connection to it) has Internet again.

But then I try to login to my laser printer and media server, both of which are on 192.168.0.xxx and can’t access them. So I launch a command prompt and enter ipconfig /all and I see 192.168.12.1 is the gateway IP. Whaaaaaat?!

So I put that in a browser, I get the T-Mobile user interface, but the gateway rejects the password I’d entered just a few minutes ago while setting it up.

I called T-Mobile support and got a person who apparently doesn’t know what an IP address is. After attempting to explain what I need to do, I give up on that.

So I hold the reset button on the T-Mobile until it says release button to reset to factory settings. I go through it again with the app *but it never asks for an IP* like it did the first time.

I don’t know how my repeater-bridge is communicating with it when I entered 192.168.0.1 in dd-wrt’s settings. The catch with this is once Save then Apply is clicked, every time I’ve setup a dd-wrt repeater-bridge, there’s no getting back into it to change settings other than resetting it then setting it up all over again. 192.168.0.2 and 192.168.12.2 get nothing. It’s like it becomes a completely invisible device pretending to be nothing but a switch connected by virtual cable to the WiFi Access point. I *had* to enter the correct gateway IP during dd-wrt’s setup or it wouldn’t work.

I can live with the 12 instead of the 0. I’ve already changed that on my wired printer connected to the repeater-bridge. It’s a bit of a pain to do with the buttons on a LaserJet 4100DTN, but that’s all it needed to work again. (Dynamic IPs on printers, with MS Windows, almost always ends with the printer changing IP from a power cycle or who knows what, then Windows’ can’t find it.) To make that one tiny change on the media server I’ll have to connect a mouse, keyboard, and monitor to it. (See my other post for issues with it setting up a Canon printer with WiFi.)


But people shouldn’t *have* to make changes to every device on their LAN because one company decides it’s going to use a Gateway IP address that’s different from what the majority of people use for their private LANs. That’s 192.168.0.1, 192.168.1.1, or 172.16.0.1. If T-Mobile is wanting to keep things simpler, offer those three as as user choices, NOT 192.168.12.1.

Now I must reset all my security cameras, which are programmed for the 192.168.0.1 address. “Bless your heart” (meant in the most Southern way possible) T-Mobile, for not using networking standards.


1 reply

Userlevel 2
Badge +4

I’m assuming you are not trying 1234.

Set it in the web interface as that lets you used shorter PW and SSID then the app on the phone.

 

 

Reply