Question

Home Internet IP address madness.

  • 14 September 2021
  • 7 replies
  • 1629 views

Badge

I figured I could simply set the gateway IP, SSID, and password exactly the same as my old DSL modem, but nooo, first T-Mobile says my old password is too short...

Is there a way to change the gateway IP address from 192.168.12.1 to 192.168.0.1? The first time I turned the gateway on and configured it, I’m certain it not only asked me for the SSID and WiFi password I wanted, and the admin password I wanted, but also the gateway IP address.

I then went to my office next to my house and reconfigured my wireless repeater-bridge (thanks to the T-Mobile gateway insisting I couldn’t use the WiFi password I had been using) and I set it up to use 192.168.0.1 as its gateway and DNS server, with the SSID and password I’d assigned. I assigned the repeater-bridge the IP address 192.168.0.2 and the end IP to 254 (instead of the default 24) because I put my wired printer and media server connected to it at high numbers.

Saved the settings in the repeater-bridge and my desktop (wired connection to it) has Internet again.

But then I try to login to my laser printer and media server, both of which are on 192.168.0.xxx and can’t access them. So I launch a command prompt and enter ipconfig /all and I see 192.168.12.1 is the gateway IP. Whaaaaaat?!

So I put that in a browser, I get the T-Mobile user interface, but the gateway rejects the password I’d entered just a few minutes ago while setting it up.

I called T-Mobile support and got a person who apparently doesn’t know what an IP address is. After attempting to explain what I need to do, I give up on that.

So I hold the reset button on the T-Mobile until it says release button to reset to factory settings. I go through it again with the app *but it never asks for an IP* like it did the first time.

I don’t know how my repeater-bridge is communicating with it when I entered 192.168.0.1 in dd-wrt’s settings. The catch with this is once Save then Apply is clicked, every time I’ve setup a dd-wrt repeater-bridge, there’s no getting back into it to change settings other than resetting it then setting it up all over again. 192.168.0.2 and 192.168.12.2 get nothing. It’s like it becomes a completely invisible device pretending to be nothing but a switch connected by virtual cable to the WiFi Access point. I *had* to enter the correct gateway IP during dd-wrt’s setup or it wouldn’t work.

I can live with the 12 instead of the 0. I’ve already changed that on my wired printer connected to the repeater-bridge. It’s a bit of a pain to do with the buttons on a LaserJet 4100DTN, but that’s all it needed to work again. (Dynamic IPs on printers, with MS Windows, almost always ends with the printer changing IP from a power cycle or who knows what, then Windows’ can’t find it.) To make that one tiny change on the media server I’ll have to connect a mouse, keyboard, and monitor to it. (See my other post for issues with it setting up a Canon printer with WiFi.)


But people shouldn’t *have* to make changes to every device on their LAN because one company decides it’s going to use a Gateway IP address that’s different from what the majority of people use for their private LANs. That’s 192.168.0.1, 192.168.1.1, or 172.16.0.1. If T-Mobile is wanting to keep things simpler, offer those three as as user choices, NOT 192.168.12.1.

Now I must reset all my security cameras, which are programmed for the 192.168.0.1 address. “Bless your heart” (meant in the most Southern way possible) T-Mobile, for not using networking standards.


7 replies

Userlevel 5
Badge +5

I’m assuming you are not trying 1234.

Set it in the web interface as that lets you used shorter PW and SSID then the app on the phone.

 

 

Badge

Wow just wow! T-Mo really crippled this piece of high-tech gear, didn’t they?

Can’t change the IP address?

Yes, total madness as you said. I got the gateway this pm and returning it tomorrow…

I’ll try again when they make this gateway a router/gateway like the old one.

Badge

OK, that IP address, 192.168.12.1, is set in concrete.
So, I changed my Orbi router to router mode; it was smart enough to assign itself a different address
192.168.1.1 and it is doling out similar subnet addresses to all devices in the house. All hassle was worth it since my internet speed has doubled what it was with the LTE gateway!

Wow. I’m glad I came across this post. I have this thing waiting for me at home to setup, but I’ve got way too many devices that are using static IP’s to change. I’m not going to even open the box, just going to send it right back.

 

Just wanted to say thanks for your post, and saving me hours of frustration. Guess I’m staying with comcast. :(  

Badge

hey @cazmo i think you should give it a chance if your current router can behave in router mode (which is the default mode in most routers) and not in access point mode like mine was. i say this ‘cause afterwards internet speed jumped to nearly 340 mbps depending on location. my 2-year experience with t-mo home gateway has been overall quite good.  just recently when they were upgrading the tower to 5G, there were 2 weekends when the service was entirely down over 24-hr periods.

good luck...

What you want to do is perfectly rational and there are no technical issues. It is one of a thousand valid ways to lay out your network.

Simply define a subnet that is big enough to hold all your categories. That single subnet will have a single gateway with an address in that subnet. Everything in the subnet will talk to the gateway via ARP. The gateway then routes to other subnets.

Later, if you decide, you can break the categories into individual subnets in the same lan (multinetting) and route between them.

Or, you could break them into lans/vlans and connect them via bridges.

Or, you could break them into lans/vlans and individual subnets and route between them.

VLANS can be defined by the device or the switch. So, if the device doesn't support vlans natively, you can use a switch from  that does.

Userlevel 4
Badge +4

Anyone having this issue may want to consider investing in your own wifi router. Once you configure your wifi settings on the router you own, you can keep your settings the same no matter what internet service you get. Even TMobile home internet gateway allows you to connect your own router.

The only minor issue is that you can’t disable the DHCP function yet on TMobile gateways. Yes it will add 1-3 ms of ping lag, but TMobile ping in general is high anyway so it’s negligible. There are also some specific devices and/or apps that may not work if you have more than one DHCP layer.

I’m optimistic that TMobile with add bridge mode to disable DHCP. It makes more economical sense for them to do that rather than keep getting support calls on their woefully bad built in wifi on their gateway. They can let 3rd party router makers take the burden of wifi support issues.

Personally, I have a philosophy that goes like this. I value every service and utility that comes to my house, but that doesn’t mean I want you inside my house like family. If I use an internet provider’s device as my router, that router will know every single device I have on my network and respective network traffic. This means the internet provider may be collecting this data for legal purposes. If I use my own router and set my own DHCP, my router’s firewall will prevent my internet provider from having this information. This also allows me to swap gateway devices from any internet provider without having to change my home network settings.

Reply