Home internet no data connection

  • 21 May 2022
  • 5 replies


I can connect to my wifi but it says no data connection. There was a critical alert on the gateway that said pdn ip connection failure. I called tech support last night. After over an hour on the phone we got it working. It didn't last long. Shortly after getting off the phone it was doing it again. We factory reset it a couple times, completely unplugged, waited a minute then plugging it back in. Everytime I try to setup the connection in the internet app it gets all the way to configuring network then it says it can't be done automatically and I have to start over.

5 replies

I have been having the same issue as of yesterday. I have not had any problems with the service before. I don't have T-Mobile phone service, just home internet. The tower will show there is connection then jump to no connetion. Therefore, when my devices connect, they will then disconnect because the tower keeps jumping from connected to no connection. We struggled with this all day 5/23/22. I was getting the same critical alerts as you. The tower kept showing critical and major alerts that said "PDN IP connection failure". I am currently using my cellphone and connected to my home internet. But if we have the same problems today I will have to call T-Mobile. Although, it doesn't sound very promising after hearing they helped get yours working but it didn't last long.


I called them again the following day. They ended up replacing the gateway. It briefly worked for that evening. Then it cut out again. I moved it to another spot with a weaker signal. Now it's working just fine🤷

I tried moving mine to several different spots in my home with no luck. Same issue. I'm hoping it works better today. 

Userlevel 5
Badge +8

Could the following thread be a help?



I have been having the same problem for the last month. Still no internet. No resolutions. No answers. And T-Mobile seems clueless. So I have paid for a month of nothing. Many factory resets, swapping SIM cards, moving to different areas, new gateway, and still nothing. 🤷🏻‍♀️🙄