Question

home internet not showing on tv

  • 13 April 2021
  • 3 replies
  • 62 views

Badge

So I have my internet device right next to my Westinghouse roku tv but the network isn’t showing up on the tv and I’m not sure if it’s the WiFi or the tv itself. Any ideas? I’ve done all the restarts and stuff with my tv 


3 replies

Userlevel 4
Badge +9

Hello there, I’m sorry you’ve having trouble getting the TV to connect to your T-Mobile Home Internet!  I know if my internet isn’t working and I can’t watch Adam Ruins Everything, I’m tearing my hair out! :D

Does your T-Mobile Home Internet show on other devices? Try to connect your phone or a tablet to check if the network name appears and you are able to connect AND use it. 

If so, try to start a mobile hotspot from your phone and see if the TV is able to connect to your phone’s mobile hotspot.  This should help you determine if the issue is with the home internet or with the TV.

Badge

I have a TCL Roku TV and it has no problem seeing the T-Moble Wi-Fi. I have a large number of devices on my home network, so I already had a Deco mesh network set up before I set up the T-Moble service this week. I just unplugged my Deco from my old cable modem and plugged it into one of the two LAN ports and everything connects without having to select the new Wi-Fi. If you have a router or AP, try plugging its ethernet port into the device and see if you can use your Roku that way. If youe TV has an ethernet connection, you could also try running a long cable from the TV to the device to connect it directly.

I suspect it may have something to do with 2.4GHz-only adapters. I had a similar problem with a Toshiba laptop, a network scan would display “Unknown Network”, the change below caused the SSID to be correctly displayed. It may resolve your issue.

On the Gateway browser app at: Network/Wi-fi Networks/2.4GHz/General Settings/Transmission Mode, change  “Auto” to “n/g”.

Good luck!

Reply