Question

Home Wifi not added to saved network on Android


Badge

I have a Pixel 4a, and just got TMo home internet. So far I’m loving the speeds and the cost. I have the Arcadyan gateway. I can connect my phone with no issues.

However,

  • I never see the network added to my saved network list, and
  • if I get disconnected, I get an authentication problem, and it doesn’t reconnect. 
  • If I cycle power on my phone, it connects with no issue, or
  • I have to enter the password to get it to connect.

My wife also has a android phone (moto-G) and it works as expected, so I suspect it’s a Pixel problem, although I had no problem with the Netgear router that I used prior to switching.

 

Anyone see anything similar?

 

Thanks


10 replies

Badge

OK, problem resolved. I had to perform a factory reset on my phone. I first tried a network reset, which didn’t help. There may have been a more elegant solution, but I couldn’t find it.

 

I just wanted to update this in case someone else runs into the same problem. 

I have this same issue with my Pixel 4.

Also, my parents came to visit and they both had Pixel 3's with the same issue. The network will not save. My partner's iPhone, our smart TV, and Xbox One remember the network fine, so it seems to be a Pixel issue.

 

If I'm home all day, it's fine. If I go out and come back, I have to reconnect and enter the password. 

 

I really don't want to do a factory reset and sort of don't believe that will fix the issue anyway.

 

Anyone else find a different solution?

Also, I called the Tmo support line and chatted with 2 different folks for over an hour and it was very unhelpful and extremely frustrating. They didn't seem to understand the problem and gave me textbook steps to "forget the network" even though that isn't possible as my device won't add it to my list of saved networks. 

I also find it surprising that there isn't more people having this issues with over 1 million subscribers at this point. Nobody else out there using Pixels or .. they are all fine re-entering their passwords 5x a day?

Pixel 3a XL user here, noticing the same thing. In addition, I couldn't join the network by just choosing it in the Android WiFi settings, even when I put in the right password; I had to use the T-Mobile Internet app. Android didn't give me a warning message; it just silently switched back to the router that I've been using up to this point. 

I have a Pixel 3a. Same problem. My husband has an iPhone. No issues. It is a pain manually connecting to the gateway multiple times a day. The only solution I've seen on here so far is to do a factory reset. But that solution seems draconian. It will take days to backup and/or reload all my data and apps.

I had the same problem with a pixel 3a.  Tried lots of things (including factory reset of the device, was not willing to factory reset the phone either (cc @Katecreatesit ) but i did get it to work without doing that.

The following worked for me:

using a non-pixel phone, login to app as admin and create a NEW network with
1) 5GHZ  (ONLY)
2) WPA2 (ONLY)
3) A password that does not use commas (“,”) .

I was then able to add THAT network to all devices and it was able to remember them normally.
(i then deleted original network)

I did not bother to go back and try to isolate which of the above 3 things really were required for this to work, but it did.

Thanks, phugm, I did exactly as you suggested and my problem is solved. It also mitigated the serious battery drain issue I was experiencing. And great user name!

I also have a Pixel 4a and I was able to solve the issue by doing the following:

Per Google support:

  1. Open your device's Settings app.
  2. Tap Network & internet. Internet.
  3. At the bottom of the list, tap Add network. You may need to enter the network name (SSID) and security details.
  4. Tap Save.

I followed the steps above and manually clicked “Add network” and then filled in the SSID, Security, WiFi password and clicked save.   My WiFi connection is now listed as saved and reconnects automatically.

Prior to this, I was doing the same thing as the rest of you by just clicking my WiFi access point name and having to reenter the password every single time.

Have a great day everyone!

 

I also have a Pixel 4a and I was able to solve the issue by doing the following:

Per Google support:

  1. Open your device's Settings app.
  2. Tap Network & internet. Internet.
  3. At the bottom of the list, tap Add network. You may need to enter the network name (SSID) and security details.
  4. Tap Save.

I followed the steps above and manually clicked “Add network” and then filled in the SSID, Security, WiFi password and clicked save.   My WiFi connection is now listed as saved and reconnects automatically.

Prior to this, I was doing the same thing as the rest of you by just clicking my WiFi access point name and having to reenter the password every single time.

Have a great day everyone!

 

I had the same issue with a Pixel 3a and a Pixel 4a. Both worked fine after following your tip.  I will add that I manually entered the SSID and set Security to WPA3-Personal and Metered to “Treat as unmetered”. as well.

Thanks Justin!

I had the same problem with a pixel 3a.  Tried lots of things (including factory reset of the device, was not willing to factory reset the phone either (cc @Katecreatesit ) but i did get it to work without doing that.

The following worked for me:

using a non-pixel phone, login to app as admin and create a NEW network with
1) 5GHZ  (ONLY)
2) WPA2 (ONLY)
3) A password that does not use commas (“,”) .

I was then able to add THAT network to all devices and it was able to remember them normally.
(i then deleted original network)

I did not bother to go back and try to isolate which of the above 3 things really were required for this to work, but it did.

pixel 4a here, (no 5g) worked for me.

Reply