Question

How do I connect my router to the T-Mobile LTE Wi-Fi Gateway?

  • 14 November 2020
  • 5 replies
  • 321 views

Badge

My old setup consisted of a cable modem connected to a router. I would like to continue using my router (and  mesh router system that I plan to upgrade to in the very near future). How do I connect a router to the T-Mobile LTE Wi-Fi Gateway? Is it possible?

I’ve tried turning of Wi-Fi in the gateway and have connected one of the ethernet ports on the back of the gateway to the WAN port on my router, but I cannot connect to the internet. Are there settings that need to be changed? Or, is it just not possible?


5 replies

Userlevel 6
Badge +13

The easiest way is to put your router into Access Point Mode and then plug it into the T-Mobile modem. 

Userlevel 1
Badge +1

Make sure your router has dhcp set up on the wan port. Should work at that point. Access point would be if you wanted IPv6 otherwise just double/triple nat

I too, would like to utilize my previous router and mesh system with my new T-Mobile LTE Gateway and am curious how this worked out for the above customer with the original question?  I’m hoping to use the extended allowances of connected devices that the mesh system previously provided when connected to my old cable modem….and of course speed things up as well as prevent all the interruptions, reload, etc.  Thanks!

Badge

My router has been flashed to use DD-WRT firmware. I followed the instructions I found on the DD-WRT wiki at https://wiki.dd-wrt.com/wiki/index.php/Wireless_Access_Point#Simple_Version_.28Same_Subnet.29 and was able to get my router to work.

Here’s the simple version of the instructions:

Simple Version (Same Subnet)

On the secondary access point router:

  • Do a hard reset
  • Disable DHCP and set the wireless channel different from the other router(s)
  • Set the IP address to 192.168.1.2 (or any IP outside the gateway DHCP range that does not collide with the gateway nor any other static devices)
  • Connect a LAN port from the Access Point to a LAN port on the primary router

There are more detailed instructions at the link above.

It’s pretty cool. I can now connect wirelessly and wired to both my router and the T-Mobile LTE Wi-Fi Gateway.

As an aside I’m getting 90-100 Mbps download speeds (about ½ of what I’m getting with Xfinity internet) and around 15 Mbps upload speeds (about double what I’m getting with Xfinity internet) when hardwired to either my router or the T-Mobile gateway. Wireless speeds depend on distance from the router/gateway (e.g., 70Mbps/20Mbps at ~3’ from router).

Badge

I did double NAT like this. Access Point mode is no good if you have more than 20 devices on your LAN.

https://community.t-mobile.com/tv-home-internet-7/ten-device-limit-33127?postid=120221#post120221

Reply