How to Connect to a Consumer VPN on T-Mobile Home Internet (5G Nokia Gateway)


Badge

I am NOT paid or endorsed by any VPN company or anyone else to make this post. This is simply what works for me and my particular VPN client. I am using the Nokia 5G grey tube router, and I’ve seen a few posts complaining that they can’t use a VPN with it. Also special thanks to the T-Mobile rep who advised me on some of this when I got the service.

If you’re using PIA (and this may apply to your VPN as well), click the 3 dots, go to your settings, and do the following under the Connection tab:

  • Make sure your protocol is OpenVPN
  • Change your connection type to TCP
  • Change your configuration method to Static

After this, close the settings, and reconnect to your VPN. If using other software, make sure to save your settings if it does not automatically do so. It may take 1-5 minutes for your IP to change to your VPN. After this, google “what is my ip” and make sure it matches with your VPN. In my case, it took about 2 minutes for my IP to completely change over, even after my VPN client connected.

 

Below are some pictures for those of you who aren’t quite as savvy:

I hope this helps anyone trying to use a VPN. I can’t provide any support beyond this post, so best of luck.


13 replies

Userlevel 1
Badge

Just use the WireGuard setting. Boom. Done.

 

Never had a lick of problems using WireGuard.

I use NordVPN and made these changes and it fixed the issue when I reconnected.

 

Thank you for the suggestion.

Just use the WireGuard setting. Boom. Done.

 

Never had a lick of problems using WireGuard.

 

I tried WireGuard earlier today and it didn’t work.  I just tried what Orionos suggested. So far, so good.

I’m trying to setup Mozilla VPN WireGuard, but it’s very slow on my new T-mobile Nokia 5G grey tube router I just setup.  Speed tests at around 3Mbps on VPN on the nearest servers to me, vs a great +90Mbps with VPN off while on T-mobile.  Prior to T-mobile, the Moz VPN used to run about 20Mbps on Cox on the same VPN servers.  The only settings Moz VPN has is Ipv6 off or on which makes little or no difference.  Any ideas?

Called T-Mo Home ISP help line and got great phone and tech response to this Moz VPN mismatch, within a couple of hours the tech sending in two firmware updates, the first of which made a dramatic improvement changing from around 3Mbps or less which was unstable and spotty, to an average around 12.5Mbps with my Moz VPN on, thus greatly improved to generally in a range between 9 to 15Mbps, very  usable for very near 100% of my VPN business and browsing purposes. The VPN Ipv6 setting still makes no difference. T-Mo is clearly pushing the envelope on service performance to get these connection use issues resolved for every different type VPN. Had a short period Sat morning when I first turned it on around 8am when speed fell to 1 and 2Mbs, not really usable at all on most websites, which could be due to a morning tower traffic issue (as has been mentioned in related posts elsewhere), or just as easily be some sort of insignificant, one-off anomaly. It’ll take several more mornings to be certain. I’ll keep checking for any sort of recurrent time-of-day issues, but I can live with this Moz VPN running speed, in the 9 to 15Mbps range, as long as it doesn’t often fall off to unusable at regular times.  The total speed available at +90 is great still there, which is way more than my 2 computers and several tv’s will ever need.  I’ve seen it sometimes as high as 150 to 200Mbps which, since less than 5Mbps is required for even the densest videos data streams, means I still have excellent reception at all of my 5 tv’s on Roku all over the house with plenty of unused bandwidth available, with a rock solid 3 out of 5 bars signal reception showing on the T-Mo grey tube screen wifi router located on my ground floor.

Userlevel 2
Badge +2

I found WireGuard is about 25% slower than OpenVPN behind Tmobile. With Spectrum it was the opposite. 

I never have problem with Torguard VPN with Spectrum until I switched to T-Mobile recently. Here is how I fixed this problem in my pc Windows 10 and android phone.

For PC Windows 10, after I launched the Torguard VPN app to connect to Torguard VPN using wireguard, I used the command line with admin authorization:

netsh interface ipv4 set subinterface "wg-torguard" mtu=1376 store=persistent

to decrease the MTU size to 1376 for wg-torguard interface.  I then got the maximum speed that I normally got with Torguard VPN (around 150Mbps download). Without doing this, my speed is super slow like 5Mbps max. When I used the OpenVPN solution which was mentioned above, it worked too; but the speed is cut down in half (60Mbps); I was trying to make the OpenVPN speed back to normal; but unsuccessful because I could not see the OpenVPN subinterface after I executed the command to display the subinterface. 

 

For android OS, I used the OpenVPN solution which was mentioned in this thread to resolve the super slow speed issue (3Mbps); but my speed was cut down in half (60Mbps) from the speed that I normally got (150Mbps). WireGuard didn’t work at all. 

Userlevel 2
Badge +2

I’m using PIA. With OpenVPN I ran netsh interface ipv4 set subinterface "Local Area Connection" mtu=1376 store=persistent.

I’ll be darned. My speed tripled. Great tip. Thanks!

I’m trying to setup Mozilla VPN WireGuard, but it’s very slow on my new T-mobile Nokia 5G grey tube router I just setup.  Speed tests at around 3Mbps on VPN on the nearest servers to me, vs a great +90Mbps with VPN off while on T-mobile.  Prior to T-mobile, the Moz VPN used to run about 20Mbps on Cox on the same VPN servers.  The only settings Moz VPN has is Ipv6 off or on which makes little or no difference.  Any ideas?

Here is what you need to do to restore your great speed with VPN for Windows 10 after you launch the Mozilla VPN WireGuard:​​​​​​​

  1. Type this command line with admin authorization to display the interface:  netsh interface ipv4 show subinterface
  2. You should see the MTU size & Interface name; then type this command line with admin to replace the MTU size of the VPN interface that you see with size,1376:  netsh interface ipv4 set subinterface "?" mtu=1376 store=persistent.  On this command, replace ? with the VPN interface that you see. For example, your VPN interface is wg-mozilla, then the comand should be:  netsh interface ipv4 set subinterface "wg-mozilla" mtu=1376 store=persistent
  3. Repeat step 1 again to display the interface info and verify that the MTU size is 1376 for VPN interface; then run speed test again.  This should fix your probllem.

The following links which will described more about MTU size to fix this problem if you interest:

https://homenetworkgeek.com/mtu-size/

https://amithkumarg.medium.com/resolved-t-mobile-home-internet-vpn-issue-2f5ca594c23e

 

Does anyone know how to display the OpenVPN interface information in windows 10 after you launch the VPN app with OpenVPN?  I used the command line “netsh interface ipv4 show subinterface” to display the interface information and I didn’t see the interface for OpenVPN after I launch the VPN app with OpenVPN; but I did see the Wireguard after I launch the VPN app with Wireguard.

I found WireGuard is about 25% slower than OpenVPN behind Tmobile. With Spectrum it was the opposite. 

In theory I think WireGuard should be faster than OpenVPN.  In my case, under T-Mobile internet my WireGuard is currently twice faster than the OpenVPN when I run the command line to reduce the MTU to 1376.  I believe I can make my OpenVPN to match the speed of WireGuard if I am able to get the OpenVPN interface name when I am OpenVPN.  Currently I didn’t see the OpenVPN interface from the command, “netsh interface ipv4 show subinterface”.

Badge

Thanks for posting this.  I just got TMo Home Internet on Friday.  I also use PIA VPN.  Based on another post, I thought I wouldn’t be able to use PIA with TMo, but your post cleared up that concern.

I ran some speed tests using different PIA configurations and found the best is WireGuard with small packets.  It is BLAZING fast compared to our old Uverse, like DL/UL speeds of 180/70 Mbps compared to 46/6 with Uverse fiber-optic WITHOUT PIA enabled.

However, a couple hours ago, my computer was no longer able to connect with PIA enabled unless I reconfigured it to OpenVPN, which has terrible speeds, even slower than Uverse.  I don’t know if there was a glitch in the PIA servers or what, but after messing with it (reconfiguring PIA, rebooting computer) it seems to have cleared up and am back in business with WireGuard.  

Userlevel 4
Badge +5

I use PIA default config no issues. Have it on Mac’s PC’s Raspberry Pi’s, Firestick, no issues at it comes out of the installer.

Reply