Question

HP Printer Wireless Set up Issue


Badge

Since setting up my 5g home internet device, I am not able to connect my HP Photosmart C4599 wireless printer to it. I reinstalled it on my home computer which connects to the modem with ethernet cable.  I currently have the printer set up using cable connected to home computer, but when I try to configure it over wireless, I am not able to complete the set up.  I get to the point where I select my SSID and put in my password so that is all working, but then after that it fails for “MAC Address Filtering may be enabled on your wireless router which can prevent your HP printer from connecting to your wireless network during setup. Temporarily disable MAC address filtering on your wireless router.” I got into the router using the admin user/password but don’t see an advanced option for disabling MAC address filtering.  Is there a way to do this or what other options do I have?

Thanks for your help!


19 replies

Badge

Hi iTinkeralot,

So the only thing that changed in my setup is that I now have the 5g home internet wifi device instead of using internet through cable company.  So my wireless printer has been working this whole time from when I originally set it up so it is not like any ports would have been blocked or firewall rules would be causing issues since then the wireless printing would have never worked to begin with, correct?

My OS is Windows 10 and I did disable my Windows Defender Firewall security temporarily and tried configuring wireless printing again and get the same error that has to do with MAC address filtering and disabling that on my router. When I have the printer plugged into USB, it is showing as IDLE, and when I unplug it from USB, it shows as OFFLINE. At least I can print when I am connected to USB for now.  It may be that the printer is pretty old?  I am planning on getting another printer in the near future anyway so hoping that a newer one I won’t have this issue.

Any other suggestions on the MAC address filtering and how I can possibly disable that temporarily?

Thanks!

 

Userlevel 4
Badge +3

Hi iTinkeralot,

So the only thing that changed in my setup is that I now have the 5g home internet wifi device instead of using internet through cable company.  So my wireless printer has been working this whole time from when I originally set it up so it is not like any ports would have been blocked or firewall rules would be causing issues since then the wireless printing would have never worked to begin with, correct?

My OS is Windows 10 and I did disable my Windows Defender Firewall security temporarily and tried configuring wireless printing again and get the same error that has to do with MAC address filtering and disabling that on my router. When I have the printer plugged into USB, it is showing as IDLE, and when I unplug it from USB, it shows as OFFLINE. At least I can print when I am connected to USB for now.  It may be that the printer is pretty old?  I am planning on getting another printer in the near future anyway so hoping that a newer one I won’t have this issue.

Any other suggestions on the MAC address filtering and how I can possibly disable that temporarily?

Thanks!

 

There is no way of your printer to know whether it is being filtered or not so the error message is just a guess or generic message. If your printer is setup for a static IP that was working on your previous WIFI network, then it will not connect on your TMO WIFI since it defaults to a subnet that is most likely different than what you had before. If this is the case, I would contact HP and ask how to set your IP back to auto.

When your printer is connected to your PC via USB, it is no longer a networked device so that is why it works the way it does.

Userlevel 5
Badge +4

I agree with Cali Cat the message is probably just not exactly what is going on. The printer is pretty old but it was working on your prior network device. It could be you hard set the IP address on the printer previously so be sure to check the actual IP address the printer is trying to use. If it has a static IP address change the IP address to DHCP so it obtains an IP address from the T-Mobile gateway. It could be the printer logic with the IP address on an incorrect network subnet will report that error though it is not the proper message to report. I could see from the user setup info that it will need WPA so it is too old for WPA2 or WPA3 authentication. It would also probably only work with 2.4 GHz and not 5 GHz frequencies so just make sure the 2.4 GHz also has WPA for authentication. 

So I am having the exact same issue as unclejoe00.    I am switching internet service from Xfinity with Netgear modem router to the TM 5g gateway.  3 devices worked fine before on the wifi…. HP Officejet Pro 8610; Netgear Wi-Fi extender EX 3700 and TP link Wi-Fi extender Model RE220.  All say the fix is to disable MAC filtering on the router or if Access Control List is used in router to manually add the MAC addresses.  The old router and 5g gateway are both set for WAP2 and the devices confirm that security setting.  I tried to work this out with TM customer service but got no suggestions.  I want to cut the cord with Xfinity but need to get this resolved first.  Thanks for any help or suggestions you might have. 

Badge

Thanks all for replying on this. When I did the initial networking configuration setup way back when I first got the printer, I just followed the instructions on the HP CD to set up the wireless and don’t recall ever specifying a static IP vs DHCP.  Assume it would be defaulted to use DHCP. But over the last couple of days, I re-installed the printer set up from that same CD along with trying to set up the Wireless connectivity and don’t see any static IP vs DHCP configuration selection.  It just fails on that last step after selecting my SSID and password. So since I am not very networking savy, can you guys tell me how I could find out if my printer is using a static IP vs using DHCP? Assume this is something I should be able to see from my computer as long as it is connected to the printer using the USB since that is the only way to connect currently? On my printer, there aren’t many Wireless options to look at from the console.

Thanks again for your replies!

Userlevel 4
Badge +3

Thanks all for replying on this. When I did the initial networking configuration setup way back when I first got the printer, I just followed the instructions on the HP CD to set up the wireless and don’t recall ever specifying a static IP vs DHCP.  Assume it would be defaulted to use DHCP. But over the last couple of days, I re-installed the printer set up from that same CD along with trying to set up the Wireless connectivity and don’t see any static IP vs DHCP configuration selection.  It just fails on that last step after selecting my SSID and password. So since I am not very networking savy, can you guys tell me how I could find out if my printer is using a static IP vs using DHCP? Assume this is something I should be able to see from my computer as long as it is connected to the printer using the USB since that is the only way to connect currently? On my printer, there aren’t many Wireless options to look at from the console.

Thanks again for your replies!

Do you have your 5 GHz and 2.4 GHz on separate SSID? I am assuming your HP Printer only works on 2.4. Try again with different SSID for 2.4 Ghz and make sure both PC and printer are on the same 2.4 GHz SSID.

Badge

No, 2.4 and 5 GHZ are combined since that was the default. I could try doing this but think one of the people that was having same issue as me replied that they already tried splitting them up into separate SSIDs and it didn’t work for them.  But I will give that a try today. 

Thanks!

Userlevel 4
Badge +3

No, 2.4 and 5 GHZ are combined since that was the default. I could try doing this but think one of the people that was having same issue as me replied that they already tried splitting them up into separate SSIDs and it didn’t work for them.  But I will give that a try today. 

Thanks!

Just splitting the SSID is just one part. You have to make sure your PC that is being used to setup the printer is on the same 2.4 GHz SSID.

Userlevel 5
Badge +8

No, 2.4 and 5 GHZ are combined since that was the default. I could try doing this but think one of the people that was having same issue as me replied that they already tried splitting them up into separate SSIDs and it didn’t work for them.  But I will give that a try today.

 

Your HP Photosmart C4599 printer appears to have come out in 2009, so it is probably not capable of any newer WiFi standards.

 

Splitting the bands might not be enough.  You might also have to dumb-down the transmission mode and/or encryption mode on the 2.4GHz band to an older standard.

 

Badge

That is interesting since my home computer is as old as my printer and doesn’t have a wireless card in it so I have it connected to the 5g internet device with Ethernet cable so not sure what it would be using. It might be combined one automatically since it is not using a SSID when using Ethernet cable?  I just tested using the 2.4 GHz SSID from printer and still not working, but now the showstopper might be that I can only connect to 5g device over Ethernet vs Wireless and can’t chose 2.4 GHz SSID.

Userlevel 5
Badge +4

To restore network defaults

  1. Press the Wireless button on the product.

  2. Press the button next to the down arrow on the display until Restore Network

    Defaults is highlighted, and then press OK.

  3. Confirm that you want to restore the network defaults.

Since the printer was associated with another router I would suggest to restore the defaults. Then proceed to make the connection to the T-Mobile WIFI. To make it “easy” HP had a printer software and process using a USB cable to transfer the WIFI info to the printer from a PC. Maybe you remember doing that long ago? 

According to the HP manual, you need the HP Photosmart Software CD and included USB setup cable to provide an easy way to connect the HP All-in-One to your wireless network. The information starts on page 12. If you don't have the software CD you may be able to login to the HP support page and obtain that as a download. Since the printer is so old it might be they no longer offer it as a download. My guess is that printer software was Windows 7 when it released so unlikely they will have any downloads for software or drivers for it given the age.  If you installed the software on your computer before check and see if you still have it operational. If so then you can run through the steps outlined in the manual to get the settings into the printer. 

Newer printers seem to connect to the WIFI with more grace. The old ones that only support WEP or WPA authentication seem to be a bit more of an issue. If you want it to be more secure it might be time to upgrade or just set it up connected via USB to your computer and share it with other clients on the network for printing. 

Userlevel 4
Badge +3

That is interesting since my home computer is as old as my printer and doesn’t have a wireless card in it so I have it connected to the 5g internet device with Ethernet cable so not sure what it would be using. It might be combined one automatically since it is not using a SSID when using Ethernet cable?  I just tested using the 2.4 GHz SSID from printer and still not working, but now the showstopper might be that I can only connect to 5g device over Ethernet vs Wireless and can’t chose 2.4 GHz SSID.

Ethernet should work too. Your printer may not be compatible with the default WIFI encryption spec. Even if turns out to be the case, you would likely have to reduce the security level which leaves all your other connected devices at risk. Unfortunately, you can’t set the security level per device.

Userlevel 5
Badge +8

That is interesting since my home computer is as old as my printer and doesn’t have a wireless card in it so I have it connected to the 5g internet device with Ethernet cable so not sure what it would be using. It might be combined one automatically since it is not using a SSID when using Ethernet cable?  I just tested using the 2.4 GHz SSID from printer and still not working, but now the showstopper might be that I can only connect to 5g device over Ethernet vs Wireless and can’t chose 2.4 GHz SSID.

 

Ethernet is totally different than WiFi.  One is wired, and one is wireless.  That’s why your PC works on wire, and your printer probably will also if it has an ethernet port and wired up physically to your gateway.

 

After you split the bands, the 2.4GHz wireless protocol might still be too new for your printer to recognize and connect to WiFi.  Adjusting the parameters mentioned above might solve the connectivity issue.

Badge

Thanks for the feedback iTinkerlot but have actually done all of that already. I actually found the old HP printer manual which is the same information that you sent me online so I have been doing all of those things the last couple of days including restoring the network defaults on the printer. I just think the printer is too old and is using WPA only, and the 5g device is using WPA2/WPA3.  For now I will just go with connecting to printer with USB as short term solution, and then longer term will buy another printer since they aren’t too expensive these days at least for what I need one for.

Thanks again Everyone for your feedback!

Having exact same issue with HP OfficeJet Pro 6830.  Complains about mac address filtering.  After seeing some other posts I tried splitting into 2.4G and 5G networks but that did not help at all.  So I set it back to combined network.  Any help would be appreciated.  Everything else seems to work great.

 

I have my Brother Printer is connected through wifi. However, I cannot airprint from any of my Apple devices. Only PC and Surface can do arprint.

Userlevel 5
Badge +8

I have my Brother Printer is connected through wifi. However, I cannot airprint from any of my Apple devices. Only PC and Surface can do arprint.

 

The following thread suggests gateway reboot / reset:

 

But what worked for me, was turning on IPv6 in the Brother configuration.

Unable to print - Apple AirPrint on a mobile device , step #8

AirPrint wouldn't work until I enabled IPv6 on my printer

 

Userlevel 5
Badge +4

Hi unclejoe00, I am not sure what OS you are running but I would check the firewall settings. It may be a firewall setting. I found the information below from a quick search on the printer. If you can disable the firewall as a test that is the first test I would make. If you remove it from the USB and have the printer showing it is connected to the WIFI LAN confirm what the printer IP address is and see if you can ping the printer. If you can then I would go to the firewall settings on the client right off and confirm those.

“The following ports are also used by your HP product and might need to be opened on your firewall configuration. Incoming ports (UDP) are destination ports on the computer while outgoing ports (TCP) are destination ports on the HP product.”

Per HP Information: http://h10032.www1.hp.com/ctg/Manual/c01516369.pdf


• Incoming (UDP) ports: 137, 138, 161, 427
• Outgoing (TCP) ports: 137, 139, 427, 9100, 9220, 9500


The ports are used for the following functions:

Printing
• UDP ports: 427, 137, 161
• TCP port: 9100

Photo card upload
• UDP ports: 137, 138, 427
• TCP port: 139

Scanning
• UDP port: 427
• TCP ports: 9220, 9500

Product status
UDP port: 161

Faxing
• UDP port: 427
• TCP port: 9220

Product installation
UDP port: 427

Userlevel 4
Badge +3

I would check your HP Printer to see if it is set to a static IP address. If that is the case, you cannot connect with a new wifi router that is defaulted to a different subnet. Check the HP help to see how the setting can be viewed and changed back to auto.

Reply